Jump to content
The simFlight Network Forums

BGL's causing CTD?


jbucholz
 Share

Recommended Posts

Hello,

I purchased and installed MyTraffic X 5.3 Pro as per the instructions given. Everything works fine, I see traffic, no issues there. The problem I'm having is I have a bunch of add-on scenery that I have custom AFCADs for. Following a suggestion I found on this forum, I changed the affected airport BGLs in the MyTraffic folder to .passive. I did not move or delete the BGL's. When I go to start a flight, the progress bar reaches 100% then FSX crashes. I isolated the cause by first deactivating the MyTraffic scenery in the scenery library. When everything loaded fine, I changed the BGL's that I made passive back to be active again. Started FSX, deactivated the scenery in the library and started a flight, worked just fine. Went back and changed the BGL's back to passive, got a CTD. It would seem as if changing the BGL's to passive is causing the issue. I have installed the available patch through communicator. Any help would be appreciated.

Jeremy

Link to comment
Share on other sites

This is a strange one. Does this happen with all airports, and only with one, and then with which one?

Normally, it is not necessary to rename the airports to .passive, but moving MyTraffic between "addon scenery" and "propellor objects" should be sufficient.

Another idea I have is to delete all files in the SceneryIndexes folder below c:\users\All Users\Microsoft\FSX and restart FSX then, this can help.

If all of this does not help, we need much more information of what exactly you have installed. Sometimes users have really many instances of the same airport installed.

Link to comment
Share on other sites

Well, my test airport was always KLAS where I have the FSDreamteam sceney installed. When I get home, I'll try it at other airports and let you know.

As far as moving the scenery, do you mean moving the mytraffic BGL's to the addon scenery folder?

Also if this problem persists, if I move the my traffic sceney to the bottom of the scenery list, would this allow for my custom AFCADs to be used instead of the mytraffic ones?

Link to comment
Share on other sites

As far as moving the scenery, do you mean moving the mytraffic BGL's to the addon scenery folder?

Not necessary as long as the MyTraffic scenery folder has been added to the scenery library.

Also if this problem persists, if I move the my traffic sceney to the bottom of the scenery list, would this allow for my custom AFCADs to be used instead of the mytraffic ones?

Yes. As Burkhard said move it to between "addon scenery" and "propellor objects" in the scenery library.

Mike

Link to comment
Share on other sites

Not necessary as long as the MyTraffic scenery folder has been added to the scenery library.

Yes. As Burkhard said move it to between "addon scenery" and "propellor objects" in the scenery library.

Mike

Thanks, Mike, yes I mean to move the entry for MyTraffic in the scenery library down, not to move any files between folders.

This works on all airports that are fully FSX compatible. There are some airport on the market that originate from FS9 airports and have non-FSX compatible headers, these might give some traffic flow and positioning problems, but very unlikely they lead to crashes. This is known from corrupted scenery indices, and from very rare second order effects which I hope we do not have to isolate...

Link to comment
Share on other sites

Well, still no luck. I tried all of your suggestions above. At first I thought everything was running fine...until about 10 minutes into my flight when I got a CTD. This was after departing KPHX which is a default airport. Here are the details:

Problem signature:

Problem Event Name: APPCRASH

Application Name: fsx.exe

Application Version: 10.0.61637.0

Application Timestamp: 46fadb14

Fault Module Name: ntdll.dll

Fault Module Version: 6.1.7600.16559

Fault Module Timestamp: 4ba9b29c

Exception Code: c0000005

Exception Offset: 0002e25b

OS Version: 6.1.7600.2.0.0.768.3

Locale ID: 1033

Additional information about the problem:

LCID: 1033

This is the same error that I was getting before doing all the things you suggested, however, this time, it actually lets me get into a flight before crashing. Here is the details from my event viewer when it would crash while loading a flight:

Faulting application name: fsx.exe, version: 10.0.61637.0, time stamp: 0x46fadb14

Faulting module name: ntdll.dll, version: 6.1.7600.16559, time stamp: 0x4ba9b29c

Exception code: 0xc0000005

Fault offset: 0x0002e25b

Faulting process id: 0xf44

Faulting application start time: 0x01cb6fa4ad15fa5f

Faulting application path: C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\fsx.exe

Faulting module path: C:\Windows\SysWOW64\ntdll.dll

Report Id: ece54221-db98-11df-a8ad-4061862bf1f9

Link to comment
Share on other sites

I did some research on ntdll.dll. Once I found out it was a windows module, I quickly determined the CTDs weren't being caused by MyTraffic persay. I found a link doing a search in google that explained that when certain addons in FSX make the computer work a bit harder, a dll called uiautomationcore.dll was causing random system modules to crash. I tried the suggested fix of removing this dll from both the system32 folder and syswow64 folder.

I've now been in flight for roughly a half hour and no CTDs (crossing fingers). Hopefully this will cure the problem. Seems as if this problem never arose until I put the extra load on my system by adding traffic. I'll keep you posted.

Link to comment
Share on other sites

Eureka! Finished my 2.5 hour flight without a CTD, closed FSX, went to KLAS where I was getting CTD's before the flight began, no CTD! I think I've fixed the issue. Thanks for the help.

That makes me happy, I wouldn't have thought about that one. It only appears in Full screen mode, which I never use, since grafics are worse in full screen than in windowed mode for a marginal if at all frame rate win. :grin:

Link to comment
Share on other sites

That makes me happy, I wouldn't have thought about that one. It only appears in Full screen mode, which I never use, since grafics are worse in full screen than in windowed mode for a marginal if at all frame rate win. :grin:

Same here...I always run in window mode to take advantage of TrafficToolbox, ADE, Super Traffic Board and other programs which link to FSX.

I did think you might have had a permission problem seeing as you installed FSX in the Programs (x86) folder, but I'm glad you got it running. :rolleyes:

Mike

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.