Jump to content

Error loading FSX


Recommended Posts


********* FSUIPC4, Version 4.635c by Pete Dowson *********

Reading options from "C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\Modules\FSUIPC4.ini"

Trying to connect to SimConnect Acc/SP2 Oct07 ...

User Name="Jerry Carroll"

User Addr="vatusa6@earthlink.net"

FSUIPC4 Key is provided

WideFS7 Key is provided

Running inside FSX on Windows 7 (using SimConnect Acc/SP2 Oct07)

Module base=61000000

Wind smoothing fix is fully installed


109 System time = 25/11/2010 09:35:31

109 #### 5 #### Opened RegKey "SYSTEM\CurrentControlSet\Services\lanmanserver\Shares"

109 #### 6 #### RegEnumValue 1 DataLen=93(13), "Users"

109 #### 7 #### 13 bytes left. found, "Path=C:\Users"

109 #### 8 #### Made path: "\\JERRY-PC\Users\Jerry\Documents\Flight Simulator X Files\"

Link to comment
Share on other sites

109 #### 8 #### Made path: "\\JERRY-PC\Users\Jerry\Documents\Flight Simulator X Files\"

Okay. That log line is made immediately before a call to Windows, to the API named "GetFileAttributes", using that path above as the name. In FSUIPC the line immediately after that call is another log line, looging the attributes being returned. It doesn't get there. There's something wrong with Windows which is causing windows itself to crash or hang on that call.

Please try sharing the Flight simulator Files path itself, with any name you like (FSPLANS is usually a good one as I said).

Meanwhile I'm going to try and reproduce the problem here by forcing the "Users" sharing to be used. ...


Tried that. No problem here. This is with Win7, 64-bit Ultimate version.

So, I'm sorry, but it is either a windows bug specifically in the version of windows you have, (which seems unlikely) or a Windows installation error or file courrption on your system. If the work-around, sharing the FSX files folder, doesn't work, I can't see an answer other than repairing or reinstalling windows. Possibly, if you are not using and never will be using WideFS at all, i could have a special INI file option to tell FSUIPC not to bother to convert paths to UNC form. This would simply keep them all local to the FS PC.



Link to comment
Share on other sites

Interesting. When I attempt to change the sharing properties of the folder the dialog box stops responding. I tried on other folders with same results. Any idea what would cause that?

No, but it sounds like the same thing that is causing the FSUIPC attempt to get the folder attributes to hang. I am sorry but I really don't know enough about Windows internals to be able to help at all. Possibly trying a Windows repair, from the Windows install disk, might help, or, if the damage has been done by something being installed which affects lower level modules (like, maybe, video or other hardware drivers), you could possibly try to find a rollback restore point which would undo the damage.

Otherwise, I've a feeling that it's a Win reinstall job.

For information, the "GetFileAttributes" call which is hanging FSUIPC is in the KERNEL32.DLL windows module, so using repair to get Windows to re-install its copy of that might help. Of course it may not be that module directly as it probably calls a host of others. And it could be a data corruption rather than a module one in any case.

I was going to offer a facility to make FSUIPC ignore "Users" shares, in case it was specifically related to using that name, but if you've found the sharing problem applies to other folders too I don't think it is worth trying.

If you do want an option in FSUIPC to ignore sharing altogether (so not using WideFS for anything) let me know. In fact I suppose I could make it automatic -- if WideFS is not registered, don't get UNC paths. What do you think? Of course it doesn't fix your problem, just goes around it, maybe.



Link to comment
Share on other sites

Yes, ignoring the sharing would be good for me. I do not use WideFS so that wouldn't be an issue. I appreciate your help with this and sorry to take up your time as it turns out not to be an issue with your software.

Keep up your great work. Much appreciated.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.