Jump to content
The simFlight Network Forums

(Un)installing MyTraffic2006


H. Hartvelt
 Share

Recommended Posts

Hello,

I returned to FS2004, due to better framerates than in FSX when using scenery like Amsterdam from Aerosoft. So I had Mytraffic2006 installed till I wanted to install the new 9.0 version of FSCommander. The DBManager of FSC stuck halfway. Volker Heine examined my scenery.cfg file and concluded that it was a disaster. He advised me to remove all add-on scenery and install it again. So I did. But I did not succeed in removing MyTraffic2006 via the control panel. The message was that the software was removed, but alle files were still in the FS2004 folder. I read in this forum that MyTraffic doesn't change the Windows registry, so I removed all MyTraffic folders in FS2004 manually and cleaned the scenery.cfg file in FS2004. That helped. Now I was able to run the FSC DBManager properly. So the next step is to install MyTraffic2006 again, but this process also stucks halfway. I see a window Launch the TRAFFICBASEBUILDER!! This proces will take a few minutes. No way! The proces stops. I can see that the scenery.cfg file contains 7 new areas, but when I start FS2004 I get a message that the scenery cannot be found. That's correct, because the folders and files which should be installed are not in the FS2004 library. What to do now?

I read on this forum that Windows7 (which I use) causes a lot of trouble and maybe the answers on my questions can be found on this forum too. In that case please don't blame me, but supply me with a link to the work around.

I thank you in advance for replying.

Hans Hartvelt

The Netherlands

Link to comment
Share on other sites

Hello,

I returned to FS2004, due to better framerates than in FSX when using scenery like Amsterdam from Aerosoft. So I had Mytraffic2006 installed till I wanted to install the new 9.0 version of FSCommander. The DBManager of FSC stuck halfway. Volker Heine examined my scenery.cfg file and concluded that it was a disaster. He advised me to remove all add-on scenery and install it again. So I did. But I did not succeed in removing MyTraffic2006 via the control panel. The message was that the software was removed, but alle files were still in the FS2004 folder. I read in this forum that MyTraffic doesn't change the Windows registry, so I removed all MyTraffic folders in FS2004 manually and cleaned the scenery.cfg file in FS2004. That helped. Now I was able to run the FSC DBManager properly. So the next step is to install MyTraffic2006 again, but this process also stucks halfway. I see a window Launch the TRAFFICBASEBUILDER!! This proces will take a few minutes. No way! The proces stops. I can see that the scenery.cfg file contains 7 new areas, but when I start FS2004 I get a message that the scenery cannot be found. That's correct, because the folders and files which should be installed are not in the FS2004 library. What to do now?

I read on this forum that Windows7 (which I use) causes a lot of trouble and maybe the answers on my questions can be found on this forum too. In that case please don't blame me, but supply me with a link to the work around.

I thank you in advance for replying.

Hans Hartvelt

The Netherlands

A general expectation: 99.9% of all problems under Vista and W7 come from the stupid censorship of the MS law department called User Access Control. Switch this off, at least as long as you are not online in unknown parts of th internet or completely drunken, in both cases you shouldn't install anything anyways.

If the installation does not go smoth in that way, please descibe exactly - what gets installed, and which messages you get when the process ends, which line it is, etc...

Link to comment
Share on other sites

Hello Burkhard,

Thank you for replying. I did this and I hope that this is what you meant.

Control panel -> User accounts -> Change User Account Settings -> slider to the most downward position: Never notify. Then restart Windows.

If you meant something else, I will hear from you.

I cleaned the scenery.cfg files in FS2004 and in Win7(C:)-> Users -> Hans -> AppData -> Roaming -> Microsoft -> FS9.

I started the installation again. Product is MyTraffic2006, boxed version together with MyTraffic2010.

The problem remains the same. The installation proces stops during the window Launch the TRAFFICBASEBUILDER!! This proces will take a few minutes.

On the task bar I see an icon and when I click on it, a DOS window opens (C:\Windows\system32\command.exe). There are a lot of lines. The upper one says:

D:\FS2004>DC3_MY.exe

'DC3-MY.exe' is not recognized as an internal or external command, operable program or batch.file.

At the bottom of the list is the next message: Press any key to continue.

When I press any key, the DOS window closes and a new Window appears stating: Windows Installshield Wizard complete.

When I click Finish, my screen becomes totally white and a new message appears: The Installshield installation engine does not respond. Windows is looking for a solution and the next message is: Error message: an error occurred while launching the setup. The remote procedure call failed.

I click Exit to leave the installation process.

I can see in both scenery.cfg files that 7 new areas are created, but in the FS2004 library, no files are added.

I hope that this gives you enough information to help me.

PS My operating system is Windows7 64 bits.

Kind regards,

Hans Hartvelt

The Netherlands

Link to comment
Share on other sites

Hello Burkhard,

Thank you for replying. I did this and I hope that this is what you meant.

Control panel -> User accounts -> Change User Account Settings -> slider to the most downward position: Never notify. Then restart Windows.

If you meant something else, I will hear from you.

I cleaned the scenery.cfg files in FS2004 and in Win7(C:)-> Users -> Hans -> AppData -> Roaming -> Microsoft -> FS9.

I started the installation again. Product is MyTraffic2006, boxed version together with MyTraffic2010.

The problem remains the same. The installation proces stops during the window Launch the TRAFFICBASEBUILDER!! This proces will take a few minutes.

On the task bar I see an icon and when I click on it, a DOS window opens (C:\Windows\system32\command.exe). There are a lot of lines. The upper one says:

D:\FS2004>DC3_MY.exe

'DC3-MY.exe' is not recognized as an internal or external command, operable program or batch.file.

At the bottom of the list is the next message: Press any key to continue.

When I press any key, the DOS window closes and a new Window appears stating: Windows Installshield Wizard complete.

When I click Finish, my screen becomes totally white and a new message appears: The Installshield installation engine does not respond. Windows is looking for a solution and the next message is: Error message: an error occurred while launching the setup. The remote procedure call failed.

I click Exit to leave the installation process.

I can see in both scenery.cfg files that 7 new areas are created, but in the FS2004 library, no files are added.

I hope that this gives you enough information to help me.

PS My operating system is Windows7 64 bits.

Kind regards,

Hans Hartvelt

The Netherlands

Don't still understand all, but DC3-MY.exe is the self extracting archive of the DC3 aircraft as example. It should not run from the folder you show, but from the FS2002\MyTraffic\MyTrafficAircraftinstallers one.

So, using a typical explorer window browse to the folder D:\FS2004\MyTraffic . If I remember will, there should be a file runonce.bat. Double click to it, what happens? If all runs well you now see all the archives extract.

Link to comment
Share on other sites

Don't still understand all, but DC3-MY.exe is the self extracting archive of the DC3 aircraft as example. It should not run from the folder you show, but from the FS2002\MyTraffic\MyTrafficAircraftinstallers one.

So, using a typical explorer window browse to the folder D:\FS2004\MyTraffic . If I remember will, there should be a file runonce.bat. Double click to it, what happens? If all runs well you now see all the archives extract.

Hello Burkhard,

No way! My problem is that no folders and no files are installed yet. So there is no folder D:\FS2004\MyTraffic and there is no file runonce.bat. I have browsed the DVD to see if it was there, but that's not the case. I suppose that it's included in the setup.exe file. So what do you suggest now?

Regards,

Hans Hartvelt

The Netherlands

Link to comment
Share on other sites

Hello Burkhard,

No way! My problem is that no folders and no files are installed yet. So there is no folder D:\FS2004\MyTraffic and there is no file runonce.bat. I have browsed the DVD to see if it was there, but that's not the case. I suppose that it's included in the setup.exe file. So what do you suggest now?

Regards,

Hans Hartvelt

The Netherlands

Hm, you say you ran the Installer MT2006V41.exe or similar. This installs to where your registry knows FS9 to be. So first question, where did you install? The installer shows the installation path where it will create the MyTraffic folder. So first locate where you created this.

Link to comment
Share on other sites

Hm, you say you ran the Installer MT2006V41.exe or similar. This installs to where your registry knows FS9 to be. So first question, where did you install? The installer shows the installation path where it will create the MyTraffic folder. So first locate where you created this.

Hello Burkhard,

Thank you for replying.

I accepted the default path of the installer, which is: D:\FS2004. But in this directory, no folder MyTraffic has been created. I remember that there was a folder MyTraffic here in the previous installation, which I have removed manually. It is still in my recylce bin, but it is empty. Also all aircraft folders and aircraft.exe files can be found in the recycle bin, so may be I can restore the aircraft folders to the Aircraft folder of FS2004. I can also restore other folders such as MyWorldAirport and MyWorldObjects, which are not empty.

There is another path: C:\Users\Hans\AppData\Roaming\Microsoft\FS9. This FS9 folder contains a folder Aircraft in which all MyTraffic aircraft can be found. This folder also contains files such as FS9.cfg and scenery.cfg

There is a third path: C:\Users\Hans\AppData\Roaming\MyTraffic\MyTrafficManager\40.1.0.0. This folder is empty.

So it doesn't look like very clear to me. I hope that it does help you.

Regards

Hans Hartvelt

The Netherlands

Link to comment
Share on other sites

Hello Burkhard,

Thank you for replying.

I accepted the default path of the installer, which is: D:\FS2004. But in this directory, no folder MyTraffic has been created. I remember that there was a folder MyTraffic here in the previous installation, which I have removed manually. It is still in my recylce bin, but it is empty. Also all aircraft folders and aircraft.exe files can be found in the recycle bin, so may be I can restore the aircraft folders to the Aircraft folder of FS2004. I can also restore other folders such as MyWorldAirport and MyWorldObjects, which are not empty.

There is another path: C:\Users\Hans\AppData\Roaming\Microsoft\FS9. This FS9 folder contains a folder Aircraft in which all MyTraffic aircraft can be found. This folder also contains files such as FS9.cfg and scenery.cfg

There is a third path: C:\Users\Hans\AppData\Roaming\MyTraffic\MyTrafficManager\40.1.0.0. This folder is empty.

So it doesn't look like very clear to me. I hope that it does help you.

Regards

Hans Hartvelt

The Netherlands

Looks like User Access Control plays dirty tricks with you, switch it off and then install again. Or move the aircraft from your user profile over to the FS9 aircraft folder by hand. Your reference to the MyTrafficManager rings another alarm with me: Maybe you have the Aerosoft version of MyTraffic, that has an own installer made by Aerosoft I know nothing about, and not the Simmarket version that is supported here?

Link to comment
Share on other sites

Looks like User Access Control plays dirty tricks with you, switch it off and then install again. Or move the aircraft from your user profile over to the FS9 aircraft folder by hand. Your reference to the MyTrafficManager rings another alarm with me: Maybe you have the Aerosoft version of MyTraffic, that has an own installer made by Aerosoft I know nothing about, and not the Simmarket version that is supported here?

Hello Burkhard,

Yes, you are right. It's the Aerosoft version. I had contact with Shaun Fletcher about the uninstalling of MyTraffic2006. Because he could not help me, he referred to this site. So after I had removed all folders and files manually and wanted to reinstall MyTraffic2006, I didn't ask for support on the Aerosoft forum, but directly on the MyTraffic forum. I thought you are closer to the fire.

Do I understand you well that you cannot help me further on and refer me back to the Aerosoft forum?

Regards

Hans Hartvelt

Link to comment
Share on other sites

Hello Burkhard,

Yes, you are right. It's the Aerosoft version. I had contact with Shaun Fletcher about the uninstalling of MyTraffic2006. Because he could not help me, he referred to this site. So after I had removed all folders and files manually and wanted to reinstall MyTraffic2006, I didn't ask for support on the Aerosoft forum, but directly on the MyTraffic forum. I thought you are closer to the fire.

Do I understand you well that you cannot help me further on and refer me back to the Aerosoft forum?

Regards

Hans Hartvelt

I already spent half an hour now to help you, without ever getting a single cent for support, and you made things far more complicated than necessary by hiding such basic information. Concerning the Simmarket version, it has been removed from sales more than 4 years ago, spo the suport ended more than two years ago. Also Aerosoft no longer sells it, just has it as an unsupported courtosy on its DVD.

So while I try to help you, you may understand that I expect you to follow my advices and give complete reports, and not some small pieces here and there. So do as I recommended in my last post, here in more detail:

Delete all fragments of MyTraffic you have spread over your computer.

Switch user access control off.

Make sure you have full control over your FS2004 folder.

Then install the product you have again from the DVD.

Link to comment
Share on other sites

I already spent half an hour now to help you, without ever getting a single cent for support, and you made things far more complicated than necessary by hiding such basic information. Concerning the Simmarket version, it has been removed from sales more than 4 years ago, spo the suport ended more than two years ago. Also Aerosoft no longer sells it, just has it as an unsupported courtosy on its DVD.

So while I try to help you, you may understand that I expect you to follow my advices and give complete reports, and not some small pieces here and there. So do as I recommended in my last post, here in more detail:

Delete all fragments of MyTraffic you have spread over your computer.

Switch user access control off.

Make sure you have full control over your FS2004 folder.

Then install the product you have again from the DVD.

Hello Burkhard,

I apologize for causing you so much trouble. I was not aware of the fact that there has ever been a second version of MyTraffic distributed by Simmarket and that this forum was meant only for that version. In my second post I mention that I have the boxed version i.c.w. MyTraffic2010. I supposed that you would realize that this is the Aerosoft version.

As far as I know I have ever informed you as complete as possible and also followed all your guidelines. In one of my earlier posts I mentioned that I have moved the slider of the User Account Settings to the utmost downward position "Never notify" and I suppose that this is what you mean when you say "Switch user access control off". If I have misunderstood you, please let me know.

I don't know what you mean with "Make sure you have full control over your FS2004 folder". I am the only person using this computer and I am the administrator. I have all rights to make changes.

I have removed all fragments of Mytraffic from my computer and tried to install MyTraffic2006 again from the DVD. The result is the same as in previous trials. The process stucks when the text "Launch the TRAFFICBASEBUILDER!! This process will take a few minutes" is displayed.

As an alternative I have restored all folders and files concerning MyTraffic from my recycle bin to FS2004. Unfortunately I see no AI aircraft at all. Even when I set the slider of the traffic to 100%.

So I am at the end of what I can think of. If this applies to you too, than I will give up this add-on.

Regards

Hans Hartvelt

The Netherlands

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.