Jump to content
The simFlight Network Forums

Many, A Lot! of strange behaviors -simply resolved


Recommended Posts

I have been struggling with several weeks of very strange FSUIPC behaviors (4.60a and 4.645)

CH Yoke, CH Pedals, Saitek ST290 joystick, FSX Acceleration and Vista 32. FSUIPC had been running pretty reliably since 2007. When I don't allow FSUIPC to load I have no problems with any of the flight controls.

I verified that no axis was assigned in FSX controls, I disabled the game controller in FSX controls

Several weeks ago the following (just SOME of the problems)

- axis quits responding in FSX but Axis Assignment & FSUIPC calibration show good values

- axis assignment shows good axis - rescan in a couple minutes shows a permanent change to different axis

- Axis assignment shows good values but FSUIPC joystick calibration shows no input

- An axis assignment suddenly changes in mid-flight e.g moving the mixture control on the CH Yoke is moving the mixture in the VC and suddenly starts moving the Throttle in the VC - rescan in Axis Assignment DOES NOT show the changed assignment

- axis assignment shows good values and a good assignment but FSUIPC console shows no input

- CS 727 flight controls only quiver when CH yoke is moved but axis assignment shows good values

- everything is OK in FSUIPC - shut down FSX - restart FSX and most axes in FSUIPC are unassigned despite them being assigned in FSUIPC.ini

I worked on the problem for dozens of hours and could find no common thread

I verified there was only one copy of the FSUIPC dll in Modules

NOTHING WOULD CONSISTENTLY FIX THE PROBLEMS

I deleted ALL reference to FSUIPC - Modules, .ini, all entries in FSX.cfg

I then reinstalled FSUPC (4.60) registered it, created all my axis and button assignments from a FRESH START ...NO MORE PROBLEMS!!!

It's only been 12 hours and 4 hours of flight time but I've flown a lot of different aircraft and have stopped/restarted FSX/FSUIPC many times with no problems.

Just a suggestion for those of you asking about "strange" behaviors - It is a quick and easy solution - I HOPE

Link to comment
Share on other sites

Hi,

It would have been super fast just to move the FSUIPC.ini file out and then run FSX and a new file would have been produced. That also would have given you a clean start.

Tried that - didn't make any difference

I tried many of the solutions recommended over the years by various folks - all they did was generate new varieties of the same problems.

I don't see a downside to the delete / reinstall - the whole process only took a couple minutes.

I just wished I'd kept the old .ini file to retry it after the new install

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.