Jump to content
The simFlight Network Forums
AxelS

FSC gets always active

Recommended Posts

Hi,

I have a problem. I use 2 Monitors, FS9 is running on the left and FSC running on the right one. Also at the right one I have the FMC window and the IVAO scratchpad. So always when I take the mouse to the right monitor to prepair the FMC by crossing the FSC window the FSC gets activ and the FMC is vanished to the background. The FS9 sound is also vanished. This happens too without taken the mouse over the FSC window each view minutes. In final approach it is a problem when ever vanishing the sound of FS9. You loose the feeling for the aircraft and always have to activ the FS9 window by clicking with the mouse. So I don't like to use FSC anymore and get back to ServInfo for watching out for ATC.

By the way, it appens too without connecting to FS9 but only when crossing the FSC window with the mouse.

Can anybody help?

Regards

Axel

Share this post


Link to post
Share on other sites

Hi Axel,

this is NOT a FSCommander problem.

In your case you have "x-mouse " (the focus follows the mouse) selected in your personal settings in Windows or mouse settings.

Check that and undo it.

Regards,

Volker

Share this post


Link to post
Share on other sites

Hello Volker,

thanks for the quick answer but I think it is a FSCommander problem yet, it happens only with FSC not with ServInfo or any other application I do have running at the second monitor.

I can take the mouse when ever I want and cross other apps and nothing happens, FS9 window is still active. !?!

For your information:

I use FSC9 from Aerosoft

WinXP

FSUIPC newest and latest Version

FS2004

Regards Axel

Share this post


Link to post
Share on other sites

Hi Axel,

can it be that you have activated in the MAP menu "Allways on top" ?

If not then there is no solution because this problem has no other users reported.

A few months ago there were 2 user had this problem with an ATI Graphic card.

This, however, based on the settings of the ATI software.

Regards,

Volker

Share this post


Link to post
Share on other sites

Hi Axel,

can it be that you have activated in the MAP menu "Allways on top" ?

If not then there is no solution because this problem has no other users reported.

A few months ago there were 2 user had this problem with an ATI Graphic card.

This, however, based on the settings of the ATI software.

Regards,

Volker

Hi Volker,

you loose this bet, "Always on top" is not activated and I have a NVidia Card. Maybe the problem

will be produced from the Card driver. I will try some changes and will let you know when I could

solve this problem. For the first time thanks for your help,

regards Axel

Share this post


Link to post
Share on other sites

Hi Axel,

I too and many more have had this problem and nothing seems to have been fixed.

You are quite right in that it is only FSC that does this, stealing the focus.

We have found a way round the problem (in spite of FSC developers non action) and that is to download TweakUI from MS

When installed, on the General tab - click focus and then check the "Prevent applications from stealing focus" option and then click Apply.

I don't know if our problem is OS related, I have XP with SP3

Rog

Share this post


Link to post
Share on other sites

Hi Axel,

I too and many more have had this problem and nothing seems to have been fixed.

You are quite right in that it is only FSC that does this, stealing the focus.

We have found a way round the problem (in spite of FSC developers non action) and that is to download TweakUI from MS

When installed, on the General tab - click focus and then check the "Prevent applications from stealing focus" option and then click Apply.

I don't know if our problem is OS related, I have XP with SP3

Rog

Hi Volker,

have tried many thinks like switching the monitors, the windows at the monitors and so on but every time the same and like I wrote above it only

happens with FSC any other apps don't making this problem.

@Rog

Hi, thanks for you answer and help. I have XP with SP3 too and I've tried TweakUI. What can I say, it works, the Problem is history! Thank you so

much for your help. Now I can use FSC without frustration.

Kind regards Axel

Edited by AxelS

Share this post


Link to post
Share on other sites

Hi everyone,

I emphasize again and again that this is NOT an FS Commander problem. In fact, stealing focus is not even standardly possible under Windows. This would only be possible if you run a separate program in the background which was to distribute focus between running applications. As a consequence, there is nothing to fix in FS Commander, because FSC does not do anything. Not even Flight Simulator can grab focus unless you click on it, and MS can virtually do anything under Windows

If a mouse move over a given application places the focus on that application this is a matter of your personal mouse settings. This is where to look for. Contrary to what Rog states, there are not many others who have this problem, but only a few and in all cases it turned out that they had opted for that in their settings.

Regards

Sascha

Share this post


Link to post
Share on other sites

Hi Sascha,

... In fact, stealing focus is not even standardly possible under Windows...

Well it would seem it is because its always happening and I may add its ONLY FSC that has this problem. If I pass the mouse cursor over IE, Explorer, FSX, Outlook, Excel, Word etc nothing happens.

...Contrary to what Rog states, there are not many others who have this problem, but only a few and in all cases it turned out that they had opted for that in their settings.

Having looked at the Control Panel Mouse options I cannot see anything that would result in this behaviour so what did they change?

Rog

Share this post


Link to post
Share on other sites

Hi Sascha,

Rog are right and I say it again and again if you want, it only happend with the FSC!!!! I have running any apps on my system like Firefox, Excel, TOPCAT, VRoute and so on when I use FS9 but no App make such a problem when I move the mouse over it!!.

Also I've take a look to my mouse settings and there were nothing to changes what would be change this behavior.

Regards Axel

Share this post


Link to post
Share on other sites

I can confirm that it is a problem, and it only affects FSCommander. I'm running FSX on win 7hp 64bit, and FSC 8.6, FSX on one monitor in window mode and FSC on my other screen.

With FSX running and a flight in progress and not paused, moving the mouse over the FSC window causes the FSC window to steal the focus. I have NO other programs which do this. Some of them steal it when they open but that is a windows issue, FSC steals it when you mouse over it while it is already running. It does not steal the focus if you mouse over the FSC window with FSX paused.

The accessibility option for focus to follow the mouse is disabled (if it wasn't, all programs would be doing this, and FSC would do it whether FSX was paused or not).

Now here's something which hasn't been mentioned yet - it seems to be a problem with the FSC setting under Windows > Options > Flight > "zoom with mouse wheel". If that box is checked FSC steals the focus every time the mouse goes near it. If the box is UNchecked, FSC never keeps the focus.

For example at the moment I have FSX running behind my browser and FSC running on the second screen as I'm typing this, if I click on the FSC window it gets the focus but gives it away immediately to FSX which comes to the front on the main monitor.

If I'm in FSX and I click something on FSC the same thing happens - FSC takes the focus for as long as it takes to register my mouse click then gives it straight back to FSX. This means I can do whatever I want in FSC without (effectively) FSX ever losing focus. The only thing I can't really do is resize the FSC window - I can only move the edge out by a few pixels before it gives the focus away again.

Edit - FSX just crashed :oops: and suddenly FSC can keep the focus again, because there is nothing for it to give it away to. I'm going to restart the flight then see whether I can get FSC to keep the focus for long enough for me to resize it by disconnecting it from FSX. Watch this space.

Edit 2 - confirmed - disconnecting FSC from FSX (via the GPS menu) lets FSC keep the focus; reconnecting it means FSC loses focus immediately after each click.

Hope that helps ...

Gary

Share this post


Link to post
Share on other sites

Hi everyone,

the observations made by the users in this thread are correct in that the problem of "focus theft" occurs only if the option for mouse-wheel zooming has been selected. The reasons is that VB6 originally does not support the mouse wheel so we had to implement a relatively complex work-around to get the mouse wheel working. Originally, the mouse wheel option was only meant for a two-computer set-up in which case the problem does not arise in the first place.

Anyway, the problem is much more complex than we thought and, frankly, I wish we had never implemented the mouse wheel option, but now it is there and we will look for a solution, but I cannot promise that that will be soon.

Sorry for the inconvenience.

Sascha

Share this post


Link to post
Share on other sites

Thanks Sascha

Personally I don't use mouse wheel zoom anyway, I'm happy to click the zoom buttons on the fly-out menu, so as far as I'm concerned the issue is now resolved.

Since I stumbled on that workaround FSC has behaved perfectly - everything works as though it had focus even when it doesn't, and FSX hasn't at any time (except when it crashed altogether LOL) lost focus for long enough to mute itself.

Works for me :grin:

Gary

Share this post


Link to post
Share on other sites

Hi All

Not sure if this is the same problem I have

I have FSX and FSC running on the same computer on a single screen, and I can switch between them left clicking using my mouse on the taskbar

Therefore the other programme runs happily in the background until required, which is how it should be

However my problem is that whenever I go online in FSC to download IVAO data, every time the data is refreshed the FSC screen becomes active on its own which is every few minutes and the only way I can stop it is to exit IVAO

Will I have to use "tweakui" or is there someting in FSC that I can do

I have checked and I do not have "always on top" switched on

Regards

Paul

Vista 32

FSX

FSC version 9

Share this post


Link to post
Share on other sites

Hi Paul,

if the FSC is connected to the Flightsimulator, while the download of IVAO-, VATSIM- or weather data, the focus returned to the Flightsimulator.

If this is not the case within your system, then there are some settings in your system different.

Regards,

Volker

Share this post


Link to post
Share on other sites

Hi Volker,

I tried the following:

1. I run FS9 on my first Computer (Win7 Home Pro, 64 Bit, FSUIPC 3.99) and FSC (Ver. 9.1.1, Build: 21-10-2011) on the same Computer on an extended Desktop (2nd monitor).

Everything works fine. As You mentioned before, after downloading online data FSC gives back the focus to FS9. But normaly I don´t use this configuration.

2. But when I run FSC on my 2nd Computer (WinXP, SP3) connected to the FS9 via FSUIPC and WideFS (Ver: 6.78), than after downloading online data that FSC won´t give back the focus to other programs running on that computer.

btw: it would be fine to have a hotkey to manually initiate a download of current IVAO or VATSIM data. This would be usefull, when I´m watching other Pilots departing or arriving while I´m not connected to the network or my aircraft is not moving but connected.

Regards,

Michael

Share this post


Link to post
Share on other sites

Hi Volker,

thanks for Your quick response.

I disabled the Focus back to FS, and after restarting FSC, connecting to FS and Download current IVAO data I startet Firefox on the same computer which stay active till FSC automatically downloaded the current IVAO data.

After that it did not give back the focus to Firefox. I used the configuration 2 described in my previous post.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.