Jump to content
The simFlight Network Forums
toconce

FSC error code 9 (rUNTIME ERROR)

Recommended Posts

Hello,

My System:

FSC version 8.6 build 101 209 (Box version 8.2)

Windows XP(SP3) Pentium®4 - 3Ghz - 2GB RAM [DELL DIM9100]

FSUIPC (Registered and latest version)

FS9

Problem description:

I get a runtime error whenever I click the Select option on the SID/STAR menue for KDFW. I posted this here before after loading AIRAC 1103 from Navigraph and you suggested to check with NAVIGRAPH. At that time, other users were also having the runtime error. NAVIGRAPH (Rich) descovered a corrupt file and corrected in 1103 rev 2.

After downloading 1103 rev 2, I still had the problem and posted the issue again at NAVIGRAPH. Rich (NAVIGRAPH) suspects the large amount of SID/STARS for KDFW that might be causing the problem and requested for me to post the issue here. I decided to wait for AIRAC 1104, which I downloaded today, and I still get the runtime error when selecting the SID for KDFW. If I key in the waypoints as published in the SID, it finds them all and plots them correctly in the plan.

What is frustrating about the error, is that it terminates FSC rather than leaving it up; however, you guys have done a great job developing this product, I use it all the time, I love it, and I'm contemplating Version 9 when I upgrade my hardware.

Best Regards,

Martin

P.S. After submitting this isuue, I saw your reply to my last post; I should have continued that post instead of starting this one; sorry!

Share this post


Link to post
Share on other sites

Hi Martin,

please read this announcement: http://forum.simflight.com/topic/67825-flightsim-commander-ver-90-bug-fix-2011-03-16/

and follow the instructions.

Regards,

Volker

Hi Volker,

I followed your instructions; however, I think these exe files are for FSCommander version 9 because when executing FSC.exe an error is displayed about "file and structure incomplete....", and when executing the DBManager, it errors out with "sevCmd3.ocx not correctly registered, file missing or invalid....".

I restored both FSC.exe and FSDBManager.exe. Now this might be a clue to what is happening, after restoring the exe I ran FSC and when I cliked on the SID select for KDFW, this time the runtime error did not happen, but no SIDS were listed, just all blank. Next, I ran the database manager and then FSC. This time when selecting the KDFW SID, the runtime error happened. Then, I reloaded the NAVIGRAPH Cycle 1104 and tried FSC again, but the runtime error remained.

I feel like a ping-pong ball between NAVIGRAPH and FSCommander.

Regards,

Martin

Share this post


Link to post
Share on other sites

Hi Martin,

sorry, I have not seen that it was the 8.x version.

Unfortunately, version 8.x is an expired version and is not further developed.

Regards,

Volker

Edit:

would you please contact me via e-mail. You will find my e-mail adress at the bottom on our homepage

Share this post


Link to post
Share on other sites

Hi Martin,

please read this announcement: http://forum.simflig...fix-2011-03-16/

and follow the instructions.

Regards,

Volker

Hello,

I have the same problem after installing airac 1104. Following the advise above I installed 16-03-2011 build, but nothing change. By the way I should note that I was using 01-03-2011 build without having any problem and I am still able the use it when I revert to airac 1103. I appreciate any other help.

Best regards,

Suavi Akar

Share this post


Link to post
Share on other sites

I have same issue with FSC9. After Airac update i get this runtime error. There must be something wrong with airacs. I can't read transitions.

FSC 9 - 16032011

Airac 1104 Rev1

I click on Sidstartrans -> transition select and get result is an runtime error 9 Subscript out of range.

LOWW MOTIX UL610 PABSA UL604 LALIN UQ314 MOOCE UL604 EKSOS Y103 LASGA UM726 LASTO UM852 LARET HLZ EDDV

Share this post


Link to post
Share on other sites

Hi to All,

this is a different problem.

The error is in the Cycle 1104. Temporary use the Cycle 1103.

We soon expect a new revision.

Regards,

Volker

Share this post


Link to post
Share on other sites

Hi guys,

again corrupt file as in the first revision of 1103 ... I have created a second revision of 1104 and have released it on the Navigraph webpage. Sorry for that, at the moment I have no idea, why this happens every time in the FSC AIRAC. Thank you!

Share this post


Link to post
Share on other sites

Hello Richard,

thank you very much for your work. I'm glad that there is so fast a solution.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.