Jump to content
The simFlight Network Forums

Autosave causing micro-pauses in FS9?


Recommended Posts

AutoSave 1.501 & FS2004

Hope this is the right forum. For a while now I have noticed minor pauses every 30 seconds or so (FS2004 on Win7 32-bit). I opened the resource monitor and found the pauses were caused by disk write activity, and finally traced it to the autosave function. Every time it writes a new file it causes a brief pause (probably 1-3 seconds at most). This is merely irritating in the cruise phase, but much worse at critical phases during manual handling, as it tends to result in over-control as the flight control inputs don't take effect during the pause. Autosave is a brilliant addition that I don't want to ditch (saves my bacon on VATSIM flights after the inevitable CTD). Is this a known problem with autosave. Is there a work around?

Link to comment
Share on other sites

I opened the resource monitor and found the pauses were caused by disk write activity, and finally traced it to the autosave function. Every time it writes a new file it causes a brief pause (probably 1-3 seconds at most).

Wow! 1-3 seconds!? you must have a seriously badly performing disk system! Normal small file writes are cached and hardly ever affect foreground activity. Maybe you need to free up more space on disk? Maybe you need to check disk write settings -- turning off disk caching in order to avoid data loss on a system crash would make it force-write files immediately, which wouldn't be good with a slow or congested disk system.

Autosave is a brilliant addition that I don't want to ditch (saves my bacon on VATSIM flights after the inevitable CTD). Is this a known problem with autosave. Is there a work around?

All Autosave is doing is calling the function in Flight Sim which saves a flight, at the interval you ask. There's no other way I know to save a flight. Maybe if you purchased on of those utilities which creates a disk in memory, and moved your "My Documents" folder there it would work, but there's no real way of saving flights other than by ... saving flights, which for FS means writing files.

If I were you I'd look at defragmenting your disk, the one holding your flight files, and freeing up space. And check that you have write caching allowed. Not sure where that's specified offhand.

Regards

Pete

Link to comment
Share on other sites

Wow! 1-3 seconds!? you must have a seriously badly performing disk system! Normal small file writes are cached and hardly ever affect foreground activity. Maybe you need to free up more space on disk? Maybe you need to check disk write settings -- turning off disk caching in order to avoid data loss on a system crash would make it force-write files immediately, which wouldn't be good with a slow or congested disk system.

Well, I've suspected this for a long time - data writes seem appallingly slow compared to my WinXP experience on the same hardware. It was was *much* worse with Vista, but still not good now I have Win7. But I have 34GB free (of 50GB total) on the FS9 partition, and 165GB free (of 465GB total) on the Windows partition. So probably not a consequence of restricted disk space?

If I were you I'd look at defragmenting your disk, the one holding your flight files, and freeing up space. And check that you have write caching allowed. Not sure where that's specified offhand.

Have defrag'ed the disk a few times already. Not sure about disk cacheing settings though - will check that at a saner time of day and report back. Thanks for quick response :)

Link to comment
Share on other sites

Oh well, write-caching *is* already enabled on both HDD's (FS9 B-drive & Win7 C-drive). And it doesn't seem to make any difference to the pauses whether I turn write-caching on or off. Windows performance assessment gives the disk transfer rating 5.9 / 7 - if that means anything at all?

Link to comment
Share on other sites

Oh well, write-caching *is* already enabled on both HDD's (FS9 B-drive & Win7 C-drive). And it doesn't seem to make any difference to the pauses whether I turn write-caching on or off. Windows performance assessment gives the disk transfer rating 5.9 / 7 - if that means anything at all?

Not much, really. With Win7 the top rating is 7.9 -- I get that with a SATA 3 ("6 Gb/s") solid state drive, but nothing less.

As I said, all AutoSave can do is call on FS to save the flight. It doesn't do that itself. It's just an automated way of pressing the ; key and entering a name. Of course if you have a cycle of 10 (say) files being saved, it also has to erase the oldest each time it saves a new one. Maybe that's defeating the caching, though I've never noticed the sort of hesitation you mention (1-3 secs!!!).

You could try disabling the regular cycle and use the "alsosave" facility only. Here's the relevant part of the doc:

You can also add parameters for an optional additional file which has a fixed

name and which is saved regardless of FS's mode or state:

AlsoSave=name of file

AlsoInterval=60

For example, adding

AlsoSave=My Restart

AlsoInterval=30

will save the flight as "My Restart" every 30 seconds. This is in addition

to the timed files above. The idea here is that you can set "My Restart" or

whatever as your default flight, so after an program or hardware crash, or

power outage, you can simply load up FS and continue from a few seconds

before the problem.

If you want only this behaviour, and no timed files, set the File parameter to

zero (thus "Files=0"). Then only the "also file" will operate.

Maybe, because it doesn't then have to erase older files it will work better for you. The disadvantage is that you don't get a series of saves to select from.

Regards

Pete

Link to comment
Share on other sites

You could try disabling the regular cycle and use the "alsosave" facility only.

Actually that's all I use - I only need to recover the last position after a CTD on VATSIM flights, and I also use save-on-ground (I often get CTD after touchdown at EDDM for example). My settings:

Interval=60

Files=0

SaveOnGround=Yes

AlsoSave=CrashSaver

AlsoInterval=60

Looks like a new PC is on the cards (for many other reasons besides this). Thanks Pete for your help anyway.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.