Jump to content
The simFlight Network Forums
Shermann

ADD ON MEnu Disapperead

Recommended Posts

Hi !

I have a little problem with FSX run on WIN vista 64. I have had FSx installed for some month then all of a sudden i launche FSX for a flight and i saw that the add on menu inside FSX was missing. I disinstalled all Add ons i disinstalled FSX and installed it again. After installin add ons i calibrated all Joystik thru FSUIPC the version downloade 3 days ago from the site. Then i installed some payware plane like i had before and going inside the simulator and the add on menu was there but inside there was nothing no FSUIPC, NO DBS AIRPORT, The menu of FS PASENGRES disapperead, I dis installed all again and nstalled FSX service pack 1 sercive pack 2 FSUIPC again and the plane one by one all as administrator UAM disbaled no firewall no antivirus. I calibrated again the axis but then this time fs passendgers menu disapperead again and this time even the whole Folder of ADDon..I Dont know what to do anymore as it seems to be useless to disinstall as the problem always come back...

Thanks for possible HElp or idea

Alfredo

Share this post


Link to post
Share on other sites

I have a little problem with FSX run on WIN vista 64. I have had FSx installed for some month then all of a sudden i launche FSX for a flight and i saw that the add on menu inside FSX was missing. I disinstalled all Add ons i disinstalled FSX and installed it again. After installin add ons i calibrated all Joystik thru FSUIPC the version downloade 3 days ago from the site. Then i installed some payware plane like i had before and going inside the simulator and the add on menu was there but inside there was nothing no FSUIPC, NO DBS AIRPORT, The menu of FS PASENGRES disapperead, I dis installed all again and nstalled FSX service pack 1 sercive pack 2 FSUIPC again and the plane one by one all as administrator UAM disbaled no firewall no antivirus. I calibrated again the axis but then this time fs passendgers menu disapperead again and this time even the whole Folder of ADDon..I Dont know what to do anymore as it seems to be useless to disinstall as the problem always come back...

Uninstalling and reinstalling things rarely truly helps, unless you start with Windows itself, reformatting the hard disk. Quite often, especially wiyth FSX, reinstalling it makes things much worse because parts of it don't uninstall properly and then won't reinstall. This particularly applies to SimConnect, which is the part which loads and runs those things you want to see in the Add Ons menu.

It might not yet be quite that bad, however. If re-running the FSUIPC4 installer (NOT uninstalling anything) brings FSUIPC back to the Add-Ons menu, then the other missing things are probably missing because of a corrupted DLL.XML or EXE.XML file. Even if re-running the installer does not work, it still might be due to a badly corrupted DLL.XML file. Some installers are prone to make a mess of that file, which is probably why yuo are experiencing the problems after installing each add-on.

Best thing hen is to find the DLL.XML and the EXE.XML files (you might not have the latter). They are in the same folder as your FSX.CFG file. If you don't know where to look for that, show me your FSUIPC4 log and I'll point it out.

When you've found the fil(s) you have two choices:

1. Either delete them both, then reinstall each add-on, ONE AT A TIME, testing after each. If, after any of those installs, the Add-Ons menu disappears or loses an entry, you've just found the bad installer and can start again, omitting that, and report to the relevant support.

2. OR you can paste the files into a message here (they are trext files) and I'll se if there's some simple corruption which you can fix by hand.

Regards

Pete

Share this post


Link to post
Share on other sites

Dear Mr Dowson!

Fortunally there is you in this world!! I Installed FSUIPC and the add on menu is there again. The DLL.exe.dll is not in the folder like u said. NOw i was wondering even if all the add have been already installed can i install them again ? Anyway i noticed that in the main folder of FSX i have two files BGLMANX.DAt and in folder where i have the dll.xml i have two of this file, i copy u both of them..

This is one

<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="Launch" version="1,0">

<Descr>Launch</Descr>

<Filename>dll.xml</Filename>

<Disabled>False</Disabled>

<Launch.ManualLoad>False</Launch.ManualLoad>

<Launch.Addon>

<Name>FSUIPC 4</Name>

<Disabled>False</Disabled>

<Path>Modules\FSUIPC4.dll</Path>

</Launch.Addon>

</SimBase.Document>

THis is the Other

<?xml version="1.0" encoding="windows-1252"?>

<SimBase.Document Type="Launch" version="1,0">

<Descr>Launch</Descr>

<Filename>dll.xml</Filename>

<Disabled>False</Disabled>

<Launch.ManualLoad>False</Launch.ManualLoad>

<Launch.Addon>

<Name>FsPassengersX</Name>

<Disabled>False</Disabled>

<Path>FsPassengers\bin\fspassengersx.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>FSUIPC 4</Name>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Path>Modules\FSUIPC4.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>Addon Manager</Name>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Path>bglmanx.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>Object Placement Tool</Name>

<Disabled>True</Disabled>

<ManualLoad>False</ManualLoad>

<Path>..\Microsoft Flight Simulator X SDK\SDK\Mission Creation Kit\object_placement.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>Traffic Toolbox</Name>

<Disabled>True</Disabled>

<ManualLoad>False</ManualLoad>

<Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Traffic Toolbox SDK\traffictoolbox.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>Visual Effects Tool</Name>

<Disabled>True</Disabled>

<ManualLoad>False</ManualLoad>

<Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Special Effects SDK\visualfxtool.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>PMDG Options</Name>

<Disabled>False</Disabled>

<Path>PMDG\DLLs\PMDGOptions.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>PMDG Events</Name>

<Disabled>False</Disabled>

<Path>PMDG\DLLs\PMDGEvents.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>PMDG Sounds</Name>

<Disabled>False</Disabled>

<Path>PMDG\DLLs\PMDGSounds.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>DBS Airport GPS</Name>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<DLLStartName>module_init</DLLStartName>

<DLLStopName>module_deinit</DLLStopName>

<Path>Dbs\dbs.aptGPS.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>AirbusNewHUD</Name>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Path>Addon Modules\AirbusNewHUD.dll</Path>

<DllStartName>module_init</DllStartName>

<DllStopName>module_deinit</DllStopName>

</Launch.Addon>

<Launch.Addon>

<Name>FeelThere PIC737X Helper</Name>

<Disabled>False</Disabled>

<Path>FeelThere\B737\PIC737XH.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>FeelThere EJetX Helper</Name>

<Disabled>False</Disabled>

<Path>FeelThere\E170\EJetH.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>Level-D Simulations</Name>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Path>Modules\LVLD.dll</Path>

</Launch.Addon>

</SimBase.Document>

Thanks

Alfredo

Share this post


Link to post
Share on other sites

I Installed FSUIPC and the add on menu is there again.

Good. So things are not badly broken.

The DLL.exe.dll is not in the folder like u said.

I think you mean EXE.XML? That would only be there is there were some EXE (external programs) involved in any of the Add-Ons. Ultimate traffic 2 and EZCA, for example, use this method.

NOw i was wondering even if all the add have been already installed can i install them again ?

Should be okay, but I can't guarantee what other programs do.

in folder where i have the dll.xml i have two of this file, i copy u both of them..

They cannot both be called "DLL.XML". One is probably a backup made by one of your add-ons. It cannot have the same filename -- Windows doesn't allow two files with the same name in the same folder.

This is one

That first one is a good one and will load FSUIPC4 okay. I suspect the reason you lost the AddOns menu is that one of your other installers renamed the DLL.XML in order to create its own, and then failed to do so for some reason.

The other one, the longer one, also looks good, and loads these programs:

FsPassengers\bin\fspassengersx.dll

Modules\FSUIPC4.dll

bglmanx.dll

PMDG\DLLs\PMDGOptions.dll

PMDG\DLLs\PMDGEvents.dll

PMDG\DLLs\PMDGSounds.dll

Dbs\dbs.aptGPS.dll

Addon Modules\AirbusNewHUD.dll

FeelThere\B737\PIC737XH.dll

FeelThere\E170\EJetH.dll

Modules\LVLD.dll

So if i were you, before reinstalling anything else, I'd rename the operating DLL.XML (the first one you listed) to, say "DLL.was XML", and then rename the 2nd one, the longer one, to DLL.XML, and see if that works. It should do if all those DLLs are where it says they are!

Then you only need to reinstall anything still missing.

Regards

Pete

Share this post


Link to post
Share on other sites

Hi Mr Dowson!!

Doing like suggested the add on folder disappear again. So i think better to delete the long one and keep the short one and installing all add ons again and check which of them mess up the file,,

Share this post


Link to post
Share on other sites

Doing like suggested the add on folder disappear again. So i think better to delete the long one and keep the short one and installing all add ons again and check which of them mess up the file,,

Well, unless there's something not coming through when pasting, the file looks okay. So it may not be the file but one of the add-ons actually messing things up when running.

You could enable SimConnect logging -- see the thread in the FAQ forum for how to do that. Then paste the SimConnect log here and it should hopefully show what was last loaded ...

Regards

Pete

Share this post


Link to post
Share on other sites

Hi Mr dowson i have a simconnect log file in the modules folder but what there is inside is very long like two chapters of the bible i am almost scared to copy it here

Share this post


Link to post
Share on other sites

Hi Mr dowson i have a simconnect log file in the modules folder but what there is inside is very long like two chapters of the bible i am almost scared to copy it here

That means things must have worked? Or at least programs ARE using SimConnect successfully!

It is only the early part which is relevant. Try cutting out the first 50 or 100 lines for pasting.

Pete

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.