Jump to content
The simFlight Network Forums

Network Set up help please


Alpaslan
 Share

Recommended Posts

Hello, after setting up everything according to manual, I only get this message " Deleting old STB Flight Plans ---- Connecting to Flight Simulator, please wait. ---- Watchdog reports the UT2 service state is now: Opened " from STB installed on client, then nothing happens, apperantly STB cant connect FSX.

I have got on same client, FSinn, Radar Contact, and ASE work perfectly. Also, in SDK AI Traffic sample, works, and confirm " simconnect " runs without error. So I am thinking, maybe the problem is I use same PORT number with ASE. I have got only one Simconnect.xml file on server, and one Simconnect.cfg file on Client. What I tried to do, just set STB data server on server, and STB on client, Same PORT number, with already exist Simconnect.cfg. ASE is using that port. Do I need add some entries in Simconnect.cfg and Simconnect.xml and assign another free Port for STB ?

Using Win 7 x64 on server and Vista x32 on Client.

[simConnect]

Protocol=IPv4

Address=192.168.0.2

Port=500

MaxReceiveSize=4096

DisableNagle=0

Attached Simconnect.xml.............Regards.

SimConnect.xml

Link to comment
Share on other sites

After some more try, I came a point, that I got an error saying " Unable to contact SuperTrafficBoard Data Server.STB will be disconnect .Additional details below: System.ServiceModel.EndpointNotFoundException:No DNS entries exist for host salim-pc. " and lots of other detail but couldnt make a print screen in Vista. I press Print Screen but can not find picture.

Link to comment
Share on other sites

The problem appears to be .NET is unable to resolve your hostname to an IP address (for the FSX computer). Try using the IP address instead and see if that works any better.

Simon

Hi Simon, I tried putting IP adress as well, but receive exactly same error.

Salim

Link to comment
Share on other sites

Hi Simon, I tried putting IP adress as well, but receive exactly same error.

Salim

That seems very strange as it would not need to resolve a host name when it has the IP address. Does exactly the same message still refer to "salim-pc" in the error message? If it does, the configuration hasn't changed.

You could send me your TrafficBoardFrontEnd.exe.config from the client if you wish.

Simon

Link to comment
Share on other sites

Hi Simon, sorry my bad, it is not same error message. I got this error after putting IP address.

post-20630-0-64930600-1311025670_thumb.j

But strange thing is, first I have no firewall on both pcs, also in case I added correct ports, and allowd STB programs. Configuration dont seem to be wrong, I have got same IP on simconnect.xml, simconnect.cfg, STB data, STB client. Also path for FSX folder is correct, FSX folder is read and write for sharing and fully accesible. Last STB DS running on FSX pc.

Couldnt attached TrafficBoardFrontEnd.exe.config, Forum upload rules wont allow. So pasted here, this is from client. Regards.

<?xml version="1.0" encoding="utf-8" ?>

<configuration>

<system.serviceModel>

<behaviors>

<serviceBehaviors>

<behavior name="UT2Behavior">

<serviceDebug includeExceptionDetailInFaults="false" />

</behavior>

</serviceBehaviors>

</behaviors>

<bindings>

<netTcpBinding>

<binding name="UT2Binding" closeTimeout="00:01:00"

openTimeout="00:01:00" receiveTimeout="00:10:00" sendTimeout="00:01:00"

transactionFlow="false" transferMode="Buffered" transactionProtocol="OleTransactions"

hostNameComparisonMode="StrongWildcard" listenBacklog="10"

maxBufferPoolSize="524288" maxBufferSize="196608" maxConnections="10"

maxReceivedMessageSize="196608">

<readerQuotas maxDepth="32" maxStringContentLength="8192" maxArrayLength="16384"

maxBytesPerRead="4096" maxNameTableCharCount="16384" />

<reliableSession ordered="true" inactivityTimeout="01:00:00"

enabled="false" />

<security mode="None" />

</binding>

<binding name="NetTcpBinding_IStbData" closeTimeout="00:01:00"

openTimeout="00:01:00" receiveTimeout="00:10:00" sendTimeout="00:01:00"

transactionFlow="false" transferMode="Buffered" transactionProtocol="OleTransactions"

hostNameComparisonMode="StrongWildcard" listenBacklog="10"

maxBufferPoolSize="524288" maxBufferSize="1000000" maxConnections="10"

maxReceivedMessageSize="65536">

<readerQuotas maxDepth="32" maxStringContentLength="8192" maxArrayLength="1000000"

maxBytesPerRead="4096" maxNameTableCharCount="16384" />

<reliableSession ordered="true" inactivityTimeout="01:00:00"

enabled="false" />

<security mode="None">

<transport clientCredentialType="Windows" protectionLevel="EncryptAndSign" />

<message clientCredentialType="Windows" />

</security>

</binding>

</netTcpBinding>

</bindings>

<services>

<service behaviorConfiguration="UT2Behavior" name="Ut2Interface.Ut2Server">

<endpoint address="UT2Data" binding="netTcpBinding" bindingConfiguration="UT2Binding"

contract="ExternalSharing.IUT2Data" />

<host>

<baseAddresses>

<add baseAddress="net.tcp://localhost:31123" />

</baseAddresses>

</host>

</service>

</services>

<client>

<endpoint address="net.tcp://192.168.0.2:500/stbdata/Ut2Service"

binding="netTcpBinding" bindingConfiguration="NetTcpBinding_IStbData"

contract="IStbUt2Data" name="NetTcpBinding_IStbData" />

<endpoint address="net.tcp://192.168.0.2:500/stbdata/AirportService"

binding="netTcpBinding" bindingConfiguration="NetTcpBinding_IStbData"

contract="IStbAirportData" name="NetTcpBinding_IStbData" />

</client>

</system.serviceModel>

</configuration>

Link to comment
Share on other sites

Same port number, 500 for simconnect. 500 in simconnect.xml and simconnect.cfg. I also use Active Sky Evolution with simconnect, but it connects without error.

Two different applications (SimConnect and STB-DS) cannot share the same port number. Please change one of them to a different value (and do that change on both client and server).

Sion

Link to comment
Share on other sites

Two different applications (SimConnect and STB-DS) cannot share the same port number. Please change one of them to a different value (and do that change on both client and server).

Sion

Hi Simon, Okay I assigned a different port number on STB DATA server and STB display unit. Also, I disabled all firewalls, even Router firewall, there is already no Local Network protection at all. Plus, I realised, I have been configuring all settings in STB DS and STB wrong, so put Client IP address "192.168.0.3" into STB DS, and FSX PC address into STB display unit "192.168.0.2". So after checking double, trible and many more times with ultimate care, I click on CONNECT, and received this error :(

post-20630-0-84569300-1311285183_thumb.j

Link to comment
Share on other sites

I would never recommend disabling the router firewall, the world is full of evil on the other side of that. Please send me the StbDataServer.exe.config from the FSX computer (you can use "Contact us" on the www.supertrafficboard.com site) and I'll have a look.

Simon

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.