Jump to content
The simFlight Network Forums
AoA

FS Commander Remote via WideFS

Recommended Posts

Specification:

FSX Gold/Acceleration

FSUIPC 4.70

WIDEFS 6.86

FSC 8.6 101209

(Sim) Windows 7

(Con) Windows XP

Setup:

Two seperate simulators. One control point.

Instead of sharing folders and having to constantly update paths in FSC according to which sim one wishes to connect to, I compiled the sim database and copied this to the control point. This should not be the cause of my issue but am happy to hear theories on why it is. Plan to alternative WideFS connection to either sim with some scripted magic.

However, I am currently only connecting to one sim and will not progress to the multiple option until I have this working.

Issue:

My network topology et al is setup correctly and WideClient is able to connect and manipulate the simulator from the control point.

Despite the connection being successful, I am not able to piggy-back FSC onto this connection and am greeted with the error:

"Unable to connect to Flight SimulatorMsg #2: FS not running or cannot link to WideClient"

Please could you advise on how best to rectify this.

Best Regards,

AoA

Share this post


Link to post
Share on other sites

Specification:

FSX Gold/Acceleration

FSUIPC 4.70

WIDEFS 6.86

FSC 8.6 101209

(Sim) Windows 7

(Con) Windows XP

Setup:

Two seperate simulators. One control point.

Instead of sharing folders and having to constantly update paths in FSC according to which sim one wishes to connect to, I compiled the sim database and copied this to the control point. This should not be the cause of my issue but am happy to hear theories on why it is. Plan to alternative WideFS connection to either sim with some scripted magic.

However, I am currently only connecting to one sim and will not progress to the multiple option until I have this working.

Issue:

My network topology et al is setup correctly and WideClient is able to connect and manipulate the simulator from the control point.

Despite the connection being successful, I am not able to piggy-back FSC onto this connection and am greeted with the error:

"Unable to connect to Flight SimulatorMsg #2: FS not running or cannot link to WideClient"

Please could you advise on how best to rectify this.

Best Regards,

AoA

Hi AoA,

It's not a FSCommander problem, even if you WideFSClient is working.

The message of the FSCommander informs you, that WideClient or FSX is not visible for the FSC.

Copy the attached program on your client PC. Launch your FSX and also launch your WideClient.

Make sure that the WideClient is connected with the WideServer.

Now start the program UIPCHello on your Client PC.

If the connection is OK, the program shows you the FSUIPC4 version and the current time.

Regards,

Volker

UIPCHello.zip

Share this post


Link to post
Share on other sites

Hello Volker,

It's not a FSCommander problem, even if you WideFSClient is working.
I accept that this may be the case and would appreciate it if you explain why it cannot be FSC at fault, when everything else is setup and working correctly?
Now start the program UIPCHello on your Client PC.

Sim PC+FSX+WideFS + Client PC+WideFS =

WideClient = Functioning Correctly

UIPC Hello = Can't connect: Cannot link to FSUIPC or WideClient

Sim is: N/A

FSUIPC Version: N/A

FS Clock: N/A

Sim PC+FSX+WideFS + Client PC+WideFS+FSX =

WideClient = Functioning Correctly but only locally (as expected)

UIPC Hello = Okay

Sim is: FSYETANOTHER

FSUIPC Version: 4.703

FS Clock: 00:00:00

Thank you for your help so far. I look forward to your reply.

Best Regards,

AoA.

Share this post


Link to post
Share on other sites

Hi AoA,

I accept that this may be the case and would appreciate it if you explain why it cannot be FSC at fault, when everything else is setup and working correctly?

It is my experience and the knowledge that the installation was not done correctly.

The FSCommander is a passive program while it is waiting to receive data from the FSUIPC4 via WideClient.

Unfortunately, no data are received. (see below)

Sim PC+FSX+WideFS + Client PC+WideFS =

WideClient = Functioning Correctly

UIPC Hello = Can't connect: Cannot link to FSUIPC or WideClient

Sim is: N/A

FSUIPC Version: N/A

FS Clock: N/A

Sim PC+FSX+WideFS + Client PC+WideFS+FSX =

WideClient = Functioning Correctly but only locally (as expected)

UIPC Hello = Okay

Sim is: FSYETANOTHER

FSUIPC Version: 4.703

FS Clock: 00:00:00

Both results of UIPCHELLO shows me that the FSUIPC4 was on the WIN7 PC NOT installed as administrator.

Please read here: http://forum.simflight.com/topic/66198-vista-and-windows-7-users-please-read/

Solution:

1. Uninstall the FSUIPC4.

2. Important! Make sure that you install the FSUIPC4 as administrator.

3. After you have started both FSX and WideClient, you can start now the program UIPCHELLO on both PC's.

4. Watch the result.

Regards,

Volker

Share this post


Link to post
Share on other sites

Dear Volker,

I'm afraid that, despite following these instructions for a second time, I still am not able to get anything other that N/A from the client PC. Please advise on how else to troubleshoot this.

Best Regards,

AoA

Share this post


Link to post
Share on other sites

AoA - it is nearly impossible to get Win XP and Win 7 to talk to each other. The fact is Win 7 has greater security than Win XP. Your best solution is do what I did - Install Win 7 on both PCs.

I can't help but wonder if you have sucessfully networked both PCs. If you have not - I would recommend yo doing that 1st before worring about FS Commander.

I have (had) both FS Commander 9(8 too) and REX 2.0 running on a client PC with no install of either application but FSX on the other PC so I know it is possible.

Share this post


Link to post
Share on other sites

Dear Volker,

I'm afraid that, despite following these instructions for a second time, I still am not able to get anything other that N/A from the client PC. Please advise on how else to troubleshoot this.

Best Regards,

AoA

Hi AoA,

if the value of the FS clock on the server PC still displays 00:00:00, FSUIPC was NOT installed as administrator.

As long as this problem is not resolved to your computer will not work a transfer of data between server and client.

Thus, the FSC does not work either.

Regards,

Volker

Share this post


Link to post
Share on other sites

Hi Volker,

Please excuse me, I didn't make clear that the clock was in fact mirroring the FS time correctly.

I appreciate any further advice you can give, as I am absolutely convinced that I have everything setup correctly.

Best Regards,

AoA

Share this post


Link to post
Share on other sites

Hi Volker,

Please excuse me, I didn't make clear that the clock was in fact mirroring the FS time correctly.

I appreciate any further advice you can give, as I am absolutely convinced that I have everything setup correctly.

Best Regards,

AoA

Hi AoA,

on which PC (Server and or Client) shows the program UIPCHELLO the time?

Regards,

Volker

Share this post


Link to post
Share on other sites

Hi Volker,

Server shows time correctly.

Client has all N/A.

WideFS is configured correctly and working.

Cheers,

AoA.

Share this post


Link to post
Share on other sites

Hi Volker,

Server shows time correctly.

Client has all N/A.

WideFS is configured correctly and working.

Cheers,

AoA.

Hi AoA,

to check the settings of WideFS are correct, can you verify that the two screenshots show the same situation (connected) on your computers?

Regards,

Volker

post-6634-0-63157800-1314334581_thumb.jp

post-6634-0-05531000-1314334594_thumb.jp

Share this post


Link to post
Share on other sites

I have Win7-64 server, WinVista-32 client ... test works ok.

FSUIPC 3.997 (FS9.1) / 4.726 (FSX) , Wide 6.899

fsctest.jpg

Share this post


Link to post
Share on other sites

Hello Volker,

Yes, those screenshots are similar to what I have here.

Also I am able to manipulate the FSX using buttons on WideFS - so it is definitely correctly connected and working?

This is a really strange problem, which is why I am grateful for any assistance or suggestions.

Best Regards,

AoA

Share this post


Link to post
Share on other sites

Hello Volker,

Yes, those screenshots are similar to what I have here.

Also I am able to manipulate the FSX using buttons on WideFS - so it is definitely correctly connected and working?

This is a really strange problem, which is why I am grateful for any assistance or suggestions.

Best regards,

AoA

Hi AoA,

the configuration of your PC's must be different than that of other users.

Your problem has been never described here. Here is my last statement because I am then at the end of the possibilities.

Run your FSX and make sure that a connection between WideServer and WideClient exist.

Now run the FSCommander, download the weather and choose next topic -> Connect to FS.

If an error message appears and no connection is made, quit the FSCommander. Now sent the entire contents of the folder \Support on my e-mail address. You can find these at the bottom of our website.

Regards,

Volker

Share this post


Link to post
Share on other sites

Dear Volker,

I cant find the "support" directory that you request. Please give me directions.

Best Regards,

AoA

Share this post


Link to post
Share on other sites

Dear Volker,

I cant find the "support" directory that you request. Please give me directions.

Best Regards,

AoA

Hi AoA,

I expected that your FSCommander is up to date.

I see clearly now that you have version 8.6.

In this case I'm at the end of the possibilities.

Regards,

Volker

Share this post


Link to post
Share on other sites

Hi Volker,

I understand your position, however FSC 8.6 was bought with the expectation that this particular feature, as advertised, was functional.

If we had known that this feature would not function for us, we would not have bought this software.

Therefore I believe that we are entitled to:

-Your support in solving this issue so that the software we have functions as advertised and expected.

or

-A different but fully functional version of the software.

or

-A full refund.

Thank you for your support so far, I hope that we can come to a positive conclusion.

Best Regards,

AoA

Share this post


Link to post
Share on other sites

Hi AoA,

First of all, to clarify matters. The problem you have is NOT one of FS Commander, but rather one of WideFS, i.e. transmission of data. Even though this is the case, we have tried to help you in various ways with detailed descriptions.

Nevertheless we are willing to check you log files in order to know what is going wrong, not with FS Commander, but with WideFS.

Please make a connection between WideServer and WideClient so that in FSX' title bar displays "one client connected" and also the title bar of WideClient shows "connected". Now start your FS Commander and make the connection to FS (menu: GPS - connected to FS") Then close FS Commander and WideClient again.

Please send the following files to Volker:

WideServer.log to be found in your FS folder under folder/modules.

WideClient.log to be found on your client computer where you have installed WideClient

Volker's address can be found on your homepage (www.fscommander.com)

Regards

Volker & Sascha

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.