Jump to content
The simFlight Network Forums

Cockpitsonic brake pressure instrument and fsuipc


Recommended Posts

Hi, I'm having problem with cockpitsonic A320 brake pressure module.

Should be USB and Plug&play style. This module uses manufacturers own driver.

It should read braking values from fsuipc. Needles moves when toe/parking brakes acts.

Well, when I start the driver, needles calibrates oddly. Accu pressure goes full, but left PSI shows

almost 0 and right almost full. None of needles moves after this at all.

Strange is that after starting driver, it forces landing gear up???

How can I setup/see whats goeing with these values?

I'm a bit desperate with this. Any idea?

Thanks,

Markus

Link to comment
Share on other sites

Hi, I'm having problem with cockpitsonic A320 brake pressure module.

Should be USB and Plug&play style. This module uses manufacturers own driver.

It should read braking values from fsuipc. Needles moves when toe/parking brakes acts.

Well, when I start the driver, needles calibrates oddly. Accu pressure goes full, but left PSI shows

almost 0 and right almost full. None of needles moves after this at all.

Strange is that after starting driver, it forces landing gear up???

How can I setup/see whats goeing with these values?

I'm a bit desperate with this. Any idea?

Have you tried Cockpitsonic support? I don't have such a device here so I don't know what they do.

If you want to see what they do in FSUIPC just enable IPC logging. But be sure you don't have any other FSUIPC-using applications, as else the Log will be impossible to analyse for that one program.

Regards

Pete

Link to comment
Share on other sites

Have you tried Cockpitsonic support? I don't have such a device here so I don't know what they do.

If you want to see what they do in FSUIPC just enable IPC logging. But be sure you don't have any other FSUIPC-using applications, as else the Log will be impossible to analyse for that one program.

Regards

Pete

Hi Peter,

Just figured that they had a wrong driver in their site, got it from Thomas Richter from TSR. Brake module needles work now... but I still got this gear up issue. Something forces gear up when I execute both iocard and cockpitsonic driver. I tried different combinations and here is the result of different sequences :

1. FSX - CS driver = gear up by ? after liftoff. Gear goes up when ALT is < 0 feet?

2. FSX - iocard = no problem, but when I launch iocard I can hear gear up sound, but gear stays?

3. FSX - iocard - CS driver = gear up by ? after liftoff. Gear goes up when ALT is < 0 feet?

4. FSX - CS driver - iocard = gear up right away.

Before installing all again I ask if there is a solution to figure what's goeing on here.

Thanks,

Markus

Link to comment
Share on other sites

Before installing all again I ask if there is a solution to figure what's goeing on here.

Sorry, I don't know any of those products.

Go to FSUIPC4's Logging tab, and add the Gear operating offset (0BE8) as an offset to monitor (right-hand side of dialogue). Set the type to U16. Check "Normal Log" below.

Then reproduce the problem. Look in the FSUIPC4.LOG file. You'll see when the Gear was operated, and if this is from a Client PC on WideFs, it will also tell you which PC it was from, and the Process ID of the program responsible. You can then identify the program by its Process ID in the WideClient log file on that PC (assuming you are using a reasonably recent version of WideClient).

Regards

Pete

Link to comment
Share on other sites

Sorry, I don't know any of those products.

Go to FSUIPC4's Logging tab, and add the Gear operating offset (0BE8) as an offset to monitor (right-hand side of dialogue). Set the type to U16. Check "Normal Log" below.

Then reproduce the problem. Look in the FSUIPC4.LOG file. You'll see when the Gear was operated, and if this is from a Client PC on WideFs, it will also tell you which PC it was from, and the Process ID of the program responsible. You can then identify the program by its Process ID in the WideClient log file on that PC (assuming you are using a reasonably recent version of WideClient).

Regards

Pete

Hi Peter,

This is the log. I don't find it there.

********* FSUIPC4, Version 4.703 by Pete Dowson *********

Reading options from "C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\Modules\FSUIPC4.ini"

Trying to connect to SimConnect Acc/SP2 Oct07 ...

User Name="markus makela"

User Addr="markus.makela@localnet.fi"

FSUIPC4 Key is provided

WideFS7 Key is provided

Running inside FSX on Windows 7 (using SimConnect Acc/SP2 Oct07)

Module base=61000000

Wind smoothing fix is fully installed

DebugStatus=255

78 System time = 09/09/2011 15:00:16

78 FLT UNC path = "\\MARKUS-PC\Flight Simulator X Files\"

78 FS UNC path = "\\MARKUS-PC\Microsoft Flight Simulator X\"

391 LogOptions=00000000 00000009

391 SimConnect_Open succeeded: waiting to check version okay

1250 Running in "Microsoft Flight Simulator X", Version: 10.0.61472.0 (SimConnect: 10.0.61259.0)

1250 Initialising SimConnect data requests now

1250 FSUIPC Menu entry added

1281 \\MARKUS-PC\Flight Simulator X Files\eddf.FLT

1281 \\MARKUS-PC\Microsoft Flight Simulator X\SimObjects\Airplanes\Project Airbus A320-211 Lufthansa\pa320-cfm56-2.AIR

1844 Monitor IPC:0BE8 (S16) = 0

29438 Monitor IPC:0BE8 (S16) = 16383

29438 SimRead: 0BE8="GEAR HANDLE POSITION"

FLT64: 1.00000023656

30297 System time = 09/09/2011 15:00:46, Simulator time = 15:00:18 (13:00Z)

30297 Aircraft="Airbus A320-211 CFM Lufthansa"

30391 Starting everything now ...

30484 Advanced Weather Interface Enabled

[Log closed by user request, and continued in new file]

67922 System time = 09/09/2011 15:01:24, Simulator time = 15:00:28 (13:00Z)

67922 *** FSUIPC log file being closed

Average frame rate for running time of 11 secs = 24.2 fps

Average weather filter write interval in that time = 1106.2 msecs

Memory managed: 150 Allocs, 42 Freed

********* FSUIPC Log file closed ***********

Yours,

Markus

Link to comment
Share on other sites

This is the log. I don't find it there.

Here, less than 2 seconds into the session, the Gear was shown to be UP, so it must have been set UP in the Flight you are loading

(i.e. \\MARKUS-PC\Flight Simulator X Files\eddf.FLT)

1844 Monitor IPC:0BE8 (S16) = 0

21 seconds later it is put down, no idea by whom or what.

29438 Monitor IPC:0BE8 (S16) = 16383

29438 SimRead: 0BE8="GEAR HANDLE POSITION"

It looks to me as if you have saved your default flight with the gear already up, so that as soon as you lift off it goes up. This is likely nothing to do with any add-ons whatsoever. Operate the Gear lever, put it in the Down position (or Up and Down if needed), then save your flight! "eddf" again!

Regards

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.