Jump to content
The simFlight Network Forums
baw19

Probelm with FSX FP folder

Recommended Posts

Hi all

I have the FSC v9.1.0.1 that's running under Windows XP SP3. The folders for FSX and FS9 exist and can be written to but I can't seem to save them. When I click the PATHS tab I get the message

"FSX flight plan folder unspecified! Choose <Flight Simulator X Files> manually"

The sequence of events is as follows:-

01. Load any flight plan

02. menu Flight Plan/Save As

03. Click Paths tab

04. (message box says folders are invalid) - the FS folder is set to [drive:]\My Documents

05. Select FSX folder

06. Select different FS9 folder (first create this manually under [program files]\FSC9\Flightplans)

07. Select Save/Load tab and click OK

08. Check folders in Windows Explorer

09. FSX folder has nothing in it, FS9 folder has FSX FP in it (XML format)

10. Go back to FSC9 - menu Flight Plan/Save As

11. Click Path tab

12. Message box appears again - the folder listed for FS9 has reverted to [drive:]\My Documents

The INI file is fully writable so I'm a but puzzled how to fix this - any ideas?

Thanks

Ian

Share this post


Link to post
Share on other sites

SOLVED

======

Ok so this was my fault, I misunderstood what the paths related to in the Flightplan open/save dialog. They should be set as follows:-

Flight Simulator X - should be path Microsoft FSX was installed into

FS Flight Plans - should be the path where Microsoft looks for it's flightplans

Thanks to Volker for the help!

Ian

Share this post


Link to post
Share on other sites

Hi all,

No, it is not clear to me at all.

It is very annoying that every time I will save a fligthplan for FSC and FSX, I have to specify the full path for the FSX flightplan,due to the same error < FSX flight plan forlder unspecified>

I made a directory ..documents\flight simulator X files\fsplan, this is the directory where FSX looks for his flightplans in my situation.

In the FSC9.0 version I was able to specify it once.

In the fsc.ini file the path was specified in a correct way.

In FSC9.11 this specified path is saved for a while in the ini-file.

After a restart of FSC the specified FSX flightplan path in the ini-file is gone and replaced by the default path.

This is a reason for me to deinstall version 9.11 and use the old version 9.0

Can somebody help me ?

Kind regards Kees

Share this post


Link to post
Share on other sites

Hi Kees,

do you have the answer and solution of Ian read?

Publish a screenshot of the PATHS window in your next reply or send your FSC.INI to my e-mail address.

Volker

Share this post


Link to post
Share on other sites

Hey,

I googled my problem and it's exactly this one. FSX flight plan folder unspecified! Choose <Flight Simulator X Files> manually.

May I'm too stupid but I don't understand what to do.

I installed FSC9 into C:/ and FSX is a path of Programm File (x86). Where is the problem? I just want to load the flight plan I created. But after clicking on the flight plan nothing happens. I'm german, so if Volker reads it, please explain to me what to do maybe in German:)

Thanks!

FSX

FSUIPC: 4.0

FSC: 9.2 02 May 2012

Windwos 7 (64 bit)

Edited by Fabian Schulz

Share this post


Link to post
Share on other sites

Hallo Fabian,

schau Dir mal diesen Beitrag an: http://forum.simflight.com/topic/72186-saved-fsc-flight-plans-do-not-load-in-fsc/

Studiere mal den 2.ten Screenshot von Beitrag #3.

Vergleiche mal die ersten 3 Pfad Einträge in der Abbildung mit Deinen Einträgen.

Wenn Du dann nicht siehst was bei Dir anders ist, veröffentliche bitte mit Deiner nächsten Antwort einen Screenshot

von Deinen Einstellungen wie das Muster.

Im aktuellen Handbuch findest Du hierzu ebenfalls ein Beispiel.

Gruss

Volker

Share this post


Link to post
Share on other sites

FS Commander: C:\Aerosoft\FSC9\flightplan\FSC

Flight Simulator X: C:\PROGRAM FILES (X86)\MICROSOFT GAMES\MICROSOFT FLIGHT SIMULATOR X\

FSX Flight Plans: C\Users\Fabian\Documents\

Was muss ich dann tun? FSX ganz neu installieren und direkt auf C:\ spielen, FSC dann in die FSX Files spielen?

Und wie mache ich das dann mit den Flight Plans von Documents in die FSX files?

Danke übrigens für die zügige Antwort, schätze ich sehr!

Grüße, Fabian

Share this post


Link to post
Share on other sites

Hallo Fabian,

die Zeile #3 ist falsch. Die Frage nach dem Pfad lautet: FSX Flight Plans.

Mit "C\Users\Fabian\Documents\" kann weder der FSCommander noch der FSX etwas anfangen.

In Deinem Fall müsste der Pfad lauten:

C:\Dokumente und Einstellungen\Fabian\Eigene Dateien\Flight Simulator X Files

Du wirst sehen, es funktioniert.

Gruss

Volker

P.S. Wir versuchen immer schnell zu sein, aber manchmal machen wir noch etwas Anderes.

Deshalb Danke für Dein Lob.

Share this post


Link to post
Share on other sites

Hallo Volker,

nun habe ich alle 3 Zeilen so, wie sie sollen sein.

vielen Dank, ich kann nun den Plan laden im FSX!

jedoch wird mir im FSC9 immernoch diese Fehlermeldung angezeigt..was hat es mit dieser auf sich? Was für Folgen hat diese?

Gruß Fabian

Share this post


Link to post
Share on other sites

I have a very similar problem with FSC 9.2. I get the message "FSX flight plan folder unspecified! Choose <Flight Simulator X Files> manually." as well. Under load/save I do set it to the correct folder (path tab). Once I switch back to the "LOAD" tab and go back to "Paths" -> same issue. The path will always be reverted to c:\users\my name\Documents.

This is how it looks in the .ini

FPPATH09=

FPPATH10=C:\Users\my name\Documents\

FPPATH11=

FSCPLANPATH=P:\FlightSimulatorAddOns\FSC9\Flightplan\FSC

SQUAWKBOXPATH=P:\FlightSimulatorAddOns\FSC9\flightplan\SquawkBox

IVAOPATH=P:\FlightSimulatorAddOns\FSC9\flightplan\IVAO

FSINNPATH=P:\FlightSimulatorAddOns\FSC9\flightplan\FSInn

I have changed it in the ini directly (P:\FlightSimulatorAddOns\FSC9\Flightplan\FSX) -> no effect. Whatever I do, after I close FSC it is always back to FPPATH10=C:\Users\my name\Documents\

The want-have-path exists, checked several times. FSC runs on a secondary LAPTOP with no FSX on it. But there is a symbolic link to FSX, which is also set in the PATHs tab. I am not talking about a shortcut, is is a real symbolic link making the FSX folder appearing as it was locally installed.

Share this post


Link to post
Share on other sites

Hi ???,

>>>FPPATH10=C:\Users\my name\Documents\<<< ... and then?

I think this is the right solution: FPPATH10=C:\Users\my name\Documents\Flight Simulator X Files

However, this setting should be made in the PATH window, not in the INI file.

Volker

Share this post


Link to post
Share on other sites

Hi Volker,

I want to set it to an arbitrary path, not to C:\Users\my name\Documents\Flight Simulator X Files

When setting it in the path window the changed path settings gets lost - this is my problem.

Klaus

Share this post


Link to post
Share on other sites

Hallo Klaus,

das ist nur unter bestimmten Bedingungen möglich.

Der FSCommander erwartet eine bestimmte Datei in einem anderen Ordner als dem Standardordner /Flight Simulator X Files.

Versuche bitte folgendes. Erstelle mit einem Editor eine leere Datei mit irgendeinem Namen,

aber mit der Endung .BIN. Beispiel: Test.BIN.

Und jetzt versuche es nochmal.

This is only possible under certain conditions.

The FSCommander expects a certain file in a folder other than the default /Flight Simulator X Files.

Try this please. Create with an editor an empty file with any name

but with the extension. BIN. Example: Test.BIN.

And now try again.

Gruss

Volker

Share this post


Link to post
Share on other sites

Hey,

I googled my problem and it's exactly this one. FSX flight plan folder unspecified! Choose <Flight Simulator X Files> manually.

May I'm too stupid but I don't understand what to do.

I installed FSC9 into C:/ and FSX is a path of Programm File (x86). Where is the problem? I just want to load the flight plan I created. But after clicking on the flight plan nothing happens. I'm german, so if Volker reads it, please explain to me what to do maybe in German:)

Thanks!

FSX

FSUIPC: 4.0

FSC: 9.2 02 May 2012

Windwos 7 (64 bit)

Don't know if this will help, but Win 7 ( I have the 64-bit, but the 32-bit is probably the same) tries to control everything you do as far as files are concerned. I had to install FSX on a 2nd drive (drive D) and it's own directory. If you only have a C drive, install FSX in it's own directory (i.e.C:\Microsoft Games\Microsoft Flight Simulator X), and not under the default Program Files (x86). And when you install FSC, besides installing as Administrator, put it in its own folder, too (C:\FSC9).

This will probably solve most of your problems. Windows 7 is too protective of its file system, and puts everything in the Program Files (x86) directory, where it monitors them heavily. With Flight Sim and all of its add-ons, it is best to run another drive just for the FS stuff. Hope this helps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.