Jump to content
The simFlight Network Forums

FSUIPC and WideFS updates


Recommended Posts

Hi,

I installed FSUIPC 305 and WideFS 610, I got many pauses in project magenta displays. I reverted the WideFS to 602 and still with the pauses and stutters, so I reverted the FSUIPC to 304 and it is a lot better, like before. Not sure if the problem is the FSUIPC, but when I installed the 304 no more pauses.

I'm still testing, now I'll update WideFS again to 610 and see what heppens.

Thanks,

ulisses simionato

Link to comment
Share on other sites

I installed FSUIPC 305 and WideFS 610, I got many pauses in project magenta displays. I reverted the WideFS to 602 and still with the pauses and stutters, so I reverted the FSUIPC to 304 and it is a lot better, like before. Not sure if the problem is the FSUIPC, but when I installed the 304 no more pauses.

There really is no difference FSUIPC could make that I know of, and the difference in WideServer 6.02 to 6.10 is only evident when and if you ever got lots of restarts logged in the Server Log file -- they just shouldn't occur any more.

If you turn off all the new visibility options in FSUIPC 3.05 then there is no difference in what FSUIPC is doing either. They are actually off by default of course.

Every time I make a release of new versions, I get many messages like this. And really they cannot be due to the changes I've made, so it is extremely odd. Yet it happens every time. :?

I try to keep the actual number of changes down, to keep things predictable and understandable, and in the developments from 3.00 to 3.05 this has most certainly been the case. The most significant change has been the visibility things in 3.05, and apart from those there is nothing of significance to normal running performance.

And WideFS has not changed significantly since before version 5.50.

Strange.

Pete

Link to comment
Share on other sites

hi Pete,

Strange...I'll try to update everything again. In project magenta forum another user reported the same pauses after the update. Anything that I can change in FSUIPC settings to work like 304 ? I know, I know....but it is just a test, trying to find the problem.

Thanks,

ulisses

Link to comment
Share on other sites

Anything that I can change in FSUIPC settings to work like 304 ?

Yes: don't use visibility smoothing, visibility maxima or graduated visibilty. And enable the option in the Technical page to change FS's own weather, so mucking up the selection of "weather themes".

The only other changes are to support a few extra values in the IPC interface, and some additional facilities for those programs, like FSMeteo 6, which use the NWI.

That's it. You can check the list of changes in the History document.

Really, if there's some minute timing change somewhere in FSUIPC which has an effect on stutters and pauses in Project Magenta on client computers, and I cannot imagine what that could be, your system must have been on a knife edge, ready to fail in such a manner in any case.

Are the WideFS logs reporting problems? Are the frame rates poor (use "F" in PM's PFD) -- the data update rates should in general, match FS's own frame rates? Is the frame rate limiter set 'wisely' in FS?

What exactly are these symptoms of stutters and pausing? I find it very difficult to imagine anything I've done for many months having any affect on this in the first place. It just doesn't make any sense.

Pete

Link to comment
Share on other sites

Ulisses,

If the displays which are "jerky" are the engine read-outs in the EICAS, not the PFD or ND displays, then I can probably offer some adjustable parameters to make those scan, in FSUIPC, faster or slower. Generally they do take a lower priority. It's a performance thing -- a lot of the engine values have to be derived by my code on every frame. for some of them, to avoid the overheads, I don't do it on every frame, but only perhpas 3 or 4 or 5 times a second. This is in order to provide maximum fluidity to the important stuff like the attitude indications - pitch, bank, heading -- airspeed, vertical speed, altitude, and so on.

Check things out, see what it is you are really seeing, check the WideFS logs, and so on. Then write to me on petedowson@btconnect .com -- not before Monday, please, and maybe I'll get you a Beta to try with some parameters to set scan rates.

Regards,

Pete

Link to comment
Share on other sites

Hi Pete,

I re-installed FSUIPC and WideFS in all machines, booted everything and now it looks good, but I did a short flight, so I'll fly more tomorrow and if i still have problems I send you an e-mail.

Here are some logs that looks good (I think):

********* WideServer.DLL Log [version 6.10] *********

Using blocksize guide of 4096 bytes

Date (dmy): 23/08/03, Time 20:10:20.483: Server name is FS

54359 Initialising server socket now

98078 Restarting service due to total lack of use

139625 Incoming connection Accepted ok (skt=5004)

140031 Connected to computer "PFD" (skt=5004)

142515 Incoming connection Accepted ok (skt=5024)

143062 Connected to computer "EICAS" (skt=5024)

1141672 Shutdown request received!

1143469 Client socket disconnected at Client: removing (skt=5024)

1143750 Client socket disconnected at Client: removing (skt=5004)

1161015 Closing down now ...

Memory managed: Offset records: 269 alloc, 269 free

Throughput maximum achieved: 84 frames/sec, 18883 bytes/sec

Throughput average achieved for complete session: 29 frames/sec, 5249 bytes/sec

********* Log file closed *********

********* WideClient.DLL Log [version 6.10] Class=FS98MAIN *********

Date (dmy): 23/08/03, Time 21:27:02.247: Client name is PFD

320 Attempting to connect now

360 Connection made okay!

3905 New Client Application: "mcp747" (Id=1852)

8392 New Client Application: "pfd" (Id=1836)

11076 New Client Application: "MCP" (Id=1820)

1002361 Shutdown request received!

1004544 Reception maximum achieved: 42 frames/sec, 10201 bytes/sec

1004544 Reception average achieved whilst connected: 33 frames/sec, 2191 bytes/sec

1004544 Max receive buffer = 594, Max send depth = 2

1004544 ********* Log file closed (Buffers: MaxUsed 3, Alloc 126289 Freed 126289 Refused 0) *********

Thanks so much for your support !

ulisses

Link to comment
Share on other sites

Here are some logs that looks good (I think):

Throughput maximum achieved: 84 frames/sec, 18883 bytes/sec

Throughput average achieved for complete session: 29 frames/sec, 5249 bytes/sec

Reception maximum achieved: 42 frames/sec, 10201 bytes/sec

Reception average achieved whilst connected: 33 frames/sec, 2191 bytes/sec

Wow! How do you get such fantastic performance? What processor/video are you using on the FS PC? I'm lucky to get 20 fps (average much less) on my P4 2.4GHz!

Time I upgraded again I think!

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.