Jump to content
The simFlight Network Forums
frazer84

"FSUIPC4 installer for FSX has stopped working"

Recommended Posts

Hi!

I tried to install FSUIPC4 into a new fresh Prepar3d installation yesterday, but it crashed all times.

I tried several times, both with "Run as administrator" and without, no luck.

Quick info:

Win 7 Pro x64

Prepar3d 1.2 installed into D:\Prepar3d

post-8688-0-38565600-1326130147_thumb.pn

Share this post


Link to post
Share on other sites

I tried to install FSUIPC4 into a new fresh Prepar3d installation yesterday, but it crashed all times.

Hmm. that's a new one. Unfortunatey there's no useful information in the fancy picture you posted. I might have seen more if you moved the top window away from the log, but far better to actually paste the Log itself into your message. That's what it is for. If will be in the Prepar3D modules folder.

The other information desperately needed is the location of the crash, whch is hidden in the picture further down in the Windows crash data -- it realy is pointless providing such pretty pictures when essential information is hidden like that. If you must post pictures please show the WHOLE set of information. Probably much easier just to write down the details -- Module Name, Exception Code and Offset or Location (the most important part, missing off the bottom of the display).

BTW, from what I can see of the Log it has actually finished the installation part -- it looks like it is crashing just before providing the Registration dialogue.

Regards

Pete

Share this post


Link to post
Share on other sites

Hi Pete!

Thanks for a quick response.

I tried this again today, and this time I didn't get a crash. After the registration windows was filled in and I pressed the confirm two times (one for FSUIPC and one for WideFS) nothing more showed than the windows popup informing me that the installation might have been faulty (but not sure).

Here's pictures of all the steps in the installation process:

post-8688-0-72941600-1326151315_thumb.pn

post-8688-0-79014700-1326151322_thumb.pn

post-8688-0-43516400-1326151329_thumb.pn

post-8688-0-27849300-1326151338_thumb.pn

post-8688-0-48711300-1326151344.png

post-8688-0-10483700-1326151349.png

post-8688-0-38549500-1326151443.png

Here's the information in the FSUIPC4.log-file:

********* FSUIPC4, Version 4.751a by Pete Dowson *********

User Name=""

User Addr=""

FSUIPC4 not user registered

WIDEFS7 not user registered, or expired

Running inside Prepar3D on Windows 7

Module base=61000000

32 System time = 10/01/2012 00:11:48

32 FLT path = "C:\Users\Daniel\Documents\Prepar3D Files\"

32 Trying D:\Prepar3d\Modules\SimConnectP3D.dll

32 Found it: trying to connect

32 FS path = "D:\Prepar3d\"

375 LogOptions=00000000 00000001

375 Wind smoothing fix is only partially installed

375 SimConnect_Open succeeded: waiting to check version okay

375 Trying to use SimConnect Prepar3D

4790 Running in "Lockheed Martin® Prepar3D®", Version: 1.2.3253.0 (SimConnect: 1.2.0.0)

4790 Initialising SimConnect data requests now

4790 FSUIPC Menu entry added

4868 D:\Prepar3d\FLIGHTS\OTHER\Prepar3D.FLT

4868 D:\Prepar3d\SimObjects\Airplanes\Mooney_Bravo\Mooney_Bravo.AIR

33120 System time = 10/01/2012 00:12:21, Simulator time = 11:00:00 (15:00Z)

40920 Starting everything now ...

42246 Advanced Weather Interface Enabled

58735 Sim stopped: average frame rate for last 20 secs = 70.9 fps

98765 D:\Prepar3d\SimObjects\Airplanes\B737_800\Boeing737-800.AIR

98765 Weather Mode now = Theme

98765 C:\Users\Daniel\Documents\Prepar3D Files\Flott.FLT

193442 Sim stopped: average frame rate for last 67 secs = 39.7 fps

Thanks!

Share this post


Link to post
Share on other sites

I tried this again today, and this time I didn't get a crash. After the registration windows was filled in and I pressed the confirm two times (one for FSUIPC and one for WideFS) nothing more showed than the windows popup informing me that the installation might have been faulty (but not sure).

All that is okay. Windows very often asks for confirmation of an install. You just tell it it was okay.

Here's pictures of all the steps in the installation process:

You do have an inordinate fondness for pictures, don't you? I have no need for them, or interest in them. If you want me to view the Install log, just paste the install log text in your message -- that's why it is created, as I told you already! However, it won't tell me anything for a success. The opportuntiy to find the original problem has now passed unless you can find the details in the Windows event logs.

Here's the information in the FSUIPC4.log-file:

What for? Do you have a problem running Prepar3D with FSUIPC? That is not the Instal log.

Regards

Pete

Share this post


Link to post
Share on other sites

You do have an inordinate fondness for pictures, don't you? I have no need for them, or interest in them. If you want me to view the Install log, just paste the install log text in your message -- that's why it is created, as I told you already! However, it won't tell me anything for a success. The opportuntiy to find the original problem has now passed unless you can find the details in the Windows event logs.

You told me to paste the install-log here, and that it's located in the modules-folder contained in the Prepar3d-folder. As you can see in my "fancy" picture at the end, there is only a FSUIPC4.log there, no other log is available to me.

Share this post


Link to post
Share on other sites

You told me to paste the install-log here, and that it's located in the modules-folder contained in the Prepar3d-folder. As you can see in my "fancy" picture at the end, there is only a FSUIPC4.log there, no other log is available to me.

Hmm. Interesting. I wonder if this is related to the error you originally got. The log being displayed on screen as the installer works is saved on completion to a file called 'FSUIPC4 Install.Log', to the same folder used to save all the other files including the 'FSUIPC Documents' subfolder. Seems that even though you got no error message it didn't terminate correctly. I really do need to find out why.

There is a "Save" menu entry in the on-screen copy window (you can see it in your pictures), which could have been used to obtain a text file copy elsewhere once you realised there was no such file, but I've not seen a case where the file could not be saved, except where there's no installation of a supported simulator to save it into.

I don't suppose you managed to find the entry for the original error in the Widows event logs? That would really be the most useful data.

Regards

Pete

Share this post


Link to post
Share on other sites

Hmm. Interesting. I wonder if this is related to the error you originally got.

Okay, I managed to reproduce it. It was only the saving of the log at the end which had the problem, and it only occurs when Prepar3D is the only supported Simulator installed on your PC. Of course I have FSX and ESP installed as well. i had to edit the Registry to make them appear missing in order to see what was going on.

Anyway, it is fixed in the 4.756 installer now available in the Download Links subforum. Thanks for your assistance. Seems there aren't many Prepar3D users who wish to use FSUIPC4 but don't already have FSX or ESP installed.

If you were trying to Register FSUIPC4 and/or WideFS as well, you will need to download this and run it again to do so, as the same problem stops the correct KEY file being written too. Without the key file your copy will appear unregistered.

Regards

Pete

Share this post


Link to post
Share on other sites

Okay, I managed to reproduce it. It was only the saving of the log at the end which had the problem, and it only occurs when Prepar3D is the only supported Simulator installed on your PC. Of course I have FSX and ESP installed as well. i had to edit the Registry to make them appear missing in order to see what was going on.

Anyway, it is fixed in the 4.756 installer now available in the Download Links subforum. Thanks for your assistance. Seems there aren't many Prepar3D users who wish to use FSUIPC4 but don't already have FSX or ESP installed.

If you were trying to Register FSUIPC4 and/or WideFS as well, you will need to download this and run it again to do so, as the same problem stops the correct KEY file being written too. Without the key file your copy will appear unregistered.

That's just great Pete, thanks!

For your information I have FS9 installed as well, but this problem might be just if you don't have P3D and FSX/ESP at the same time? The FS9 install method is a bit different so I guess that's why.

Anyway, great that you found it, I'll try it later tonight.

Share this post


Link to post
Share on other sites

For your information I have FS9 installed as well, but this problem might be just if you don't have P3D and FSX/ESP at the same time? The FS9 install method is a bit different so I guess that's why.

FS9 and before ( ie FS2000, FS2002, FS2004 and even CFS1 and CFS2) are supported by FSUIPC3 which is a separate, program with its own installer.

Regards

Pete

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.