Jump to content
The simFlight Network Forums
Sign in to follow this  
Hong

FSUIPC stops working while flying

Recommended Posts

I have the Citation X from Eaglesoft. This plane works only properly with FSUIPC. Everything is fine as long as I do not start my Electronic Flightbag from AivlaSoft. If I use FSX together with that programm FSUIPC stops working latest during cruise flight, sometimes earlier but it starts always correct at the beginning. When the problem occurs the thrust does not work anymore with my Joystick (only thrust commands via Keybord work) and radios either. To open FSUIPC after that happened it is not possible. I can click on the "FSUIPC Button" at the task menu of FSX but it does not open.

I don`t know if FSUIPC or Eaglesoft or the Electonic Flightbag is causing that. I updated my FSUIPC version from 4.761 to 4.80 but the problem remains.

Regards

Axel

Share this post


Link to post
Share on other sites

I have the Citation X from Eaglesoft. This plane works only properly with FSUIPC. Everything is fine as long as I do not start my Electronic Flightbag from AivlaSoft. If I use FSX together with that programm FSUIPC stops working latest during cruise flight, sometimes earlier but it starts always correct at the beginning. When the problem occurs the thrust does not work anymore with my Joystick (only thrust commands via Keybord work) and radios either. To open FSUIPC after that happened it is not possible. I can click on the "FSUIPC Button" at the task menu of FSX but it does not open.

I don`t know if FSUIPC or Eaglesoft or the Electonic Flightbag is causing that. I updated my FSUIPC version from 4.761 to 4.80 but the problem remains.

I use EFB with no problems, but I don't have the Citation. I'll need you to show me the FSUIPC4 log file, from the FSX Modules folder, to stand any chance of understanding what might be happening. Until you stated that the Menu bar still had "FSUIPC" in the Add-Ons menu entry (that IS what you meant, was it not?) I'd have assumed that SimConnect was quitting on FSUIPC. Does the Aivlasoft system still carry on okay, connected to FSX?

Reproduce the problem then show me the Log. You can paste it into a message here, it is all text. We might need to get a SimConnect log too, but that will be huge, so let's leave that till we know more.

Regards

Pete

Share this post


Link to post
Share on other sites

Pete,

I have that problem only in combination with EFB and the Citation. Apart from that EFB works without any problem.

When FSUIPC stops work the EFB from AivlaSoft is still running and works without a fault. Below you see my FlightLog (I hope it is what you asked for). I started a flight from Innsbruck to Munich. Parking, Engine start, Taxiing and Climb was ok but on cruise level and cruise thrust FSUIPC stopped working.

Regards

Axel

********* FSUIPC4, Version 4.80 by Pete Dowson *********

User Name="Axel Lenhart"

User Addr="ALenhart66@aol.com"

FSUIPC4 Key is provided

WIDEFS7 not user registered, or expired

Running inside FSX on Windows 7

Module base=61000000

78 System time = 12/02/2012 10:24:43

78 FLT path = "C:\Users\Axel\Documents\Flight Simulator X-Dateien\"

110 Trying to connect to SimConnect Acc/SP2 Oct07 ...

110 FS path = "J:\Flusi\"

328 LogOptions=00000000 00000001

328 Wind smoothing fix is fully installed

328 G3D.DLL fix attempt installed ok

328 SimConnect_Open succeeded: waiting to check version okay

328 Trying to use SimConnect Acc/SP2 Oct07

1966 Running in "Microsoft Flight Simulator X", Version: 10.0.61472.0 (SimConnect: 10.0.61259.0)

1966 Initialising SimConnect data requests now

1966 FSUIPC Menu entry added

1997 J:\Flusi\FLIGHTS\OTHER\FLTSIM.FLT

1997 J:\Flusi\SimObjects\Airplanes\Aircreation_582SL\Aircreation_582SL.AIR

199370 System time = 12/02/2012 10:28:02, Simulator time = 12:29:19 (11:29Z)

199370 Aircraft="Aircreation582SL red"

200212 Starting everything now ...

200212 AES Link established

203675 Advanced Weather Interface Enabled

217216 J:\Flusi\SimObjects\Airplanes\Eaglesoft Citation X 2.0 X\CitationX.AIR

217918 Aircraft="German airlines Eaglesoft Citation X 2.0 blau"

1094847 Sim stopped: average frame rate for last 860 secs = 40.6 fps

1210677 .PLN

1246511 Sim stopped: average frame rate for last 150 secs = 52.3 fps

Share this post


Link to post
Share on other sites

I have that problem only in combination with EFB and the Citation. Apart from that EFB works without any problem.

Hmmm. The problem could be within the Citation code or within FSUIPC. We may need Eaglesoft's support to help with this. I've no other similar reports at all, not with FSUIPC effectively hanging.

When FSUIPC stops work the EFB from AivlaSoft is still running and works without a fault.

Can you confirm, please, that EFB's moving map is still following the FS aircraft position and showing the AI traffic moving as normal? It isn't whether EFB does it's normal job, but whether it is actually still connected to and getting information from FSX.

This is important to know because if it isn't then it would point more towards a SimConnect hang. The fact that the FSUIPC dialogue isn't being brought up when you select it might also indicate this.

Below you see my FlightLog (I hope it is what you asked for). I started a flight from Innsbruck to Munich. Parking, Engine start, Taxiing and Climb was ok but on cruise level and cruise thrust FSUIPC stopped working.

Is this the complete log AFTER you closed FSX down? Did FSX close properly? Check by looking in the Process list in Task Manager -- ensure FSX.EXE is no longer listed. You cannot tell from the absence of any FSX windows.

This is where your flight loaded:

217216 J:\Flusi\SimObjects\Airplanes\Eaglesoft Citation X 2.0 X\CitationX.AIR

217918 Aircraft="German airlines Eaglesoft Citation X 2.0 blau"

Then, just under 15 minutes later, FSUIPC detects a stop -- usually meaning a Menu was called up, or you pressed ESCape and the End Flight? query appeared. Can you tell me exactly what happened, what you did?

1094847 Sim stopped: average frame rate for last 860 secs = 40.6 fps

The point here is that if you did this after FSUIPC appeared to stop, it couldn't have actually been FSUIPC that had hung -- if it was it couldn't have logged the message.

Then, further, nearly two minutes later, an attempt was made to load a PLaN with no name:

1210677 .PLN

and then another stop 16 seconds later:

1246511 Sim stopped: average frame rate for last 150 secs = 52.3 fps

Were all these events long before the problem appeared? If so they are presumably irrelevant. If you did close FSX down and this is the complete log then I would have expected the FSX.EXE process to still be running, waiting for at least FSUIPC to close down.

We might nee a Simconnect log and more logging in FSUIPC, but those will be huge to I need to try to understand what is happening in more detail first.

Regards

Pete

Share this post


Link to post
Share on other sites

Pete,

What I sent to you was the complete Flight Log but FSX didn´t close properly. It closed with the Error message "Flight Simulator not responding". I didn`t finnish the flight because I closed FSX more or less immediately after FSUIPC stopped working.

I did another flight yesterday and again everything was fine until I reached my flight level and FSUIPC stopped working. I checked if EFB´s moving map was still following the aircraft. It was and it switched properly from cruise to arrival and approach.

The LogFile below is from that full flight from Innsbruck to ramp in Munich with engine shut down. At the end I finnished the flight, quit EFB (DataProvider and DisplayUnit) at last I quit FSX. FSX didn´t close properly but had again the failure message "FlightSimulator not responding". After closing the FSX window I checked the task manager but FSX.exe was not visible. Then I took the flight log.

That`s all I have so far.

Regards

Axel

********* FSUIPC4, Version 4.80 by Pete Dowson *********

User Name="Axel Lenhart"

User Addr="ALenhart66@aol.com"

FSUIPC4 Key is provided

WIDEFS7 not user registered, or expired

Running inside FSX on Windows 7

Module base=61000000

156 System time = 12/02/2012 15:59:02

156 FLT path = "C:\Users\Axel\Documents\Flight Simulator X-Dateien\"

765 Trying to connect to SimConnect Acc/SP2 Oct07 ...

780 FS path = "J:\Flusi\"

1014 LogOptions=00000000 00000001

1014 Wind smoothing fix is fully installed

1014 G3D.DLL fix attempt installed ok

1014 SimConnect_Open succeeded: waiting to check version okay

1014 Trying to use SimConnect Acc/SP2 Oct07

3635 Running in "Microsoft Flight Simulator X", Version: 10.0.61472.0 (SimConnect: 10.0.61259.0)

3635 Initialising SimConnect data requests now

3635 FSUIPC Menu entry added

3666 J:\Flusi\FLIGHTS\OTHER\FLTSIM.FLT

3666 J:\Flusi\SimObjects\Airplanes\Aircreation_582SL\Aircreation_582SL.AIR

73539 J:\Flusi\SimObjects\Airplanes\Eaglesoft Citation X 2.0 X\CitationX.AIR

126673 System time = 12/02/2012 16:01:09, Simulator time = 12:28:41 (11:28Z)

126689 Aircraft="German airlines Eaglesoft Citation X 2.0 blau"

126814 Starting everything now ...

126814 AES Link established

130339 Advanced Weather Interface Enabled

783593 .PLN

2376348 Sim stopped: average frame rate for last 2226 secs = 36.7 fps

2379218 Weather Mode now = Theme

2379218 C:\Users\Axel\AppData\Roaming\Microsoft\FSX\Vorheriger Flug.FLT

Edited by Hong

Share this post


Link to post
Share on other sites

What I sent to you was the complete Flight Log but FSX didn´t close properly. It closed with the Error message "Flight Simulator not responding". I didn`t finnish the flight because I closed FSX more or less immediately after FSUIPC stopped working.

Okay. It still insn't clear then whether it is really FSUIPC, or the aircraft, ot SimConnect which is "stopping working". And if you tried to close FS immediately, how could you tell that EFB was still getting good data about your aircraft position and the AI Traffic? It's importannt to know this because if that stops receiving too is points more towards SimConnect.

Nothing new in the Log. Still have that strnage .PLN being loaded with no name.

I think now you need to do some serious logging. First, set the Simconnect.INI file to ake a SimConnect log file. You'll find instructions for that in the FAQ subforum (see FSX HELP: Logging SimConnect). Then run FSX. Before you get to cruise or whatever it is which appears to cause the problem, go into fSUIPC options and check the "IPC Writes" optin. Nothing else, just that. Okay out. Carry on till you are sure its stopped.

ZIP up the SimConnect log file and the FSUIPC4.LOG file (do NOT paste them here, they'll be huge), and send as an email attachment to petedowson AT btconnect DOT com. (Convert that to an email address first of course).

Are you dealing with Eaglesoft support on this as well, BTW, for the Citation? I may need them to work on this.

Regards

Pete

Share this post


Link to post
Share on other sites
And if you tried to close FS immediately, how could you tell that EFB was still getting good data about your aircraft position and the AI Traffic?

I did that only for the first flight. Yesterday I did a complete new flight from Start up to shut down observing EFB.

I am not yet in contact with Eaglesoft but I will do that if it helps. I will send you the rest you asked for as well.

BTW, in GB it is 2 AM, isn´t it :mrgreen: ?

Regards

Axel

Edited by Hong

Share this post


Link to post
Share on other sites

Yesterday I did a complete new flight from Start up to shut down observing EFB

Isn't a working FSUIPC needed, then, for that aircraft? I thought it was using FSUIPC. How did you complete the flight -- changing aircraft?

I am not yet in contact with Eaglesoft but I will do that if it helps

I think it is necessary. We need to understand what is happening to cause this problem, and maybe it is related to something the aircraft does (or you request it to do) at that stage of flight -- after all you seem to be implying it is always happening at cruise level -- immediately you are in cruise mode? What actually happens then which is different, what action are you taking after which it (immediately?) 'stops' working.

BTW, in GB it is 2 AM, isn´t it :mrgreen: ?

It was 2:20 when you replied but I'd gone to bed half an hour before. ;-)

Regards

Pete

Share this post


Link to post
Share on other sites
Isn't a working FSUIPC needed, then, for that aircraft? I thought it was using FSUIPC. How did you complete the flight -- changing aircraft?

Here is a quotation from the official Features list of the Citation page: "Full Authority Digital Engine Control [FADEC] Requires registered version of FSUIPC"

I completed the flight not with an aircraft change but with keyboard commands. The thrust lever of my joystick does not work anymore if FSUIPC stopped but the buttons F1, F2, F3, F4 work.

...it is always happening at cruise level -- immediately you are in cruise mode?

I checked it again and FSUIPC stops working not by reaching cruise level but by reducing the thrust with my joystick when I reached cruise level (to avoid overspeed). It seems to be related to thrust or FADEC or whatever.

What actually happens then which is different, what action are you taking after which it (immediately?) 'stops' working.

When FSUIPC stopped working apart from thrust adjustment with the joystick the FMC does not work properly (VNAV) and radios are not taking new frequencies. Maybe there is more what I have not noticed so far because it is a new aircraft for me.

I asked Eaglesoft for advise and here is the answer:"The obvious challenge is to run EFB while flying the CX2.0 with FSUIPC.

As you state everything is fine without EFB we can only suggest a possible memory starvation issue."

A memory starvation is very unlikely because I have 8 GB Ram and the problem is not related to flight duration but to flight phase/ using throttle. Not a very helpful answer.

At least I have a question about the SimConnect LOG. I did everything as it was explained and did two FSX flights to test if it works. After that flights I should have "SimConnect1.Log" and "SimConnect 2.Log" in the FSX modules folder. But there is only "SimConnect0". Is that correct or did I something wrong. I only want to ensure that I will send the right file to you.

Regards

Axel

Share this post


Link to post
Share on other sites

I checked it again and FSUIPC stops working not by reaching cruise level but by reducing the thrust with my joystick when I reached cruise level (to avoid overspeed). It seems to be related to thrust or FADEC or whatever.

Okay, so the logs I asked for should be very useful.

A memory starvation is very unlikely because I have 8 GB Ram and the problem is not related to flight duration but to flight phase/ using throttle. Not a very helpful answer.

FSX can only use up to just over 3Gb memory -- it is a 32-bit program, not 64, so cannot take advantage of your 8Gb. Hoever, there's another use of memory external to FSX and that is for TCP/IP buffers, used by SimConnect. And those can certainly clog up the rest. However, that would affect EFB too so it is unlikely.

Certainly there are known issues with FSX when it gets near filling its 3Gb -- corruptions occur, as noted in the G3D.DLL crash threads in the AVSIM FSX Forum. The corruptions occur before FSX flags "out of memory", so it is certainly a possibility,

At least I have a question about the SimConnect LOG. I did everything as it was explained and did two FSX flights to test if it works. After that flights I should have "SimConnect1.Log" and "SimConnect 2.Log" in the FSX modules folder. But there is only "SimConnect0". Is that correct or did I something wrong. I only want to ensure that I will send the right file to you.

Did the Simconnect INI file you put into the Flight Simulator X Files folder look exactly like this:

[SimConnect]
level=Verbose
console=No
file=path to FSX\Modules\SimConnect%01u.Log
file_max_index=9[/CODE]

If so then, yes, each time you start FSX again it should make a new log, till it gets to 9 then is starts overwriting the oder ones.

But just go by the date and time of the log. Don't worry too much.

Regards

Pete

Share this post


Link to post
Share on other sites

Thanks for the FSUIPC and SimConnect logs.

It most definitely looks like SimConnect is stalling, possibly due to memory problems, but I cannot tell.

You have a lot of SimConnect clients running simultaneously. Here's this list of those connected with open transactions: I don't know which programs some of them are related to, though. The number on the left is the SimConnect-assigned ID. This list is the order they connect:

64 System Event

65 Couatl

66 Aivlasoft

67 Addon Manager

68 VimaCore

69 PMDG Options

70 PMDG Events

71 PMDG Sounds

191 Squawkbox AI control

190 <one with no name!>

72 IVAO Ivap bootstrap

73 FSUIPC4

189 Squawkbox Transponder

I find it a little odd that you have both IVAP and Squawkbox running, though I suppose they shouldn't conflict.

The time SimConnect records for FSUIPC4's connection is 18.15 seconds after SimConnect starts. This equates to something between 13.16 and 13.65 seconds in the FSUIPC4 log.

Going then to the end of the logs, which you say should take us to a couple of seconds after it appeared FSUIPC stopped, the SimConnect log finishes at 1105.49 seconds whilst FSUIPC is continuing to operate, receiving and logging Writes from the aircraft, at 1163.48 seconds, -- actually 63 seconds AFTER Simconnect appears to have stopped logging, allowing for the 5 seconds difference in the two timings as noted above.

Scanning back in the FSUIPC log I note that the aircraft writes had been looping doing the same thing -- disconnecting both throttles and setting both to almost idle. It had been doing that since time 1093.26 seconds, before which the throttles were still disconnected but being slowly reduced from their previous maximum at 1084.64 seconds. These times relate to times 1088 and 1079 seconds in the Simconnect log, whilst Simconnect was still actively logging.

Hence my conclusion that Simconnect is actually stalling, which makes me again question the activity of the Aivlasoft EFB, which you claim is still registering the positions of the user aircraft and the AI traffic even after this apparent stall. The SimConnect log records the last interaction with the EFB at 1104.64 seconds, shortly before the stall.

What I don't understand, however, is why, when SimConnect stalls, FSUIPC doesn't time out the arrival of data from it and log this and attempt to reconnect. That's what it normally does. So, to determine what FSUIPC sees of SimConnect from its viewpoint, could you possibly do another FSUIPC4 log please?

Edit the FSUIPC4.INI file 9with Notepad or a basic text editor), remove the "LogWrites=Yes" line and instead add these lines:

Debug=Please

LogExtras=x4411

Let FS run a bit longer after the apparent stoppage -- say a minute, not 2 seconds -- and again please ZIP the resulting FSUIPC4 log and SimConnect files and send them as before.

Thanks,

Pete

Share this post


Link to post
Share on other sites

I don`t know why some programms are running. I didn`t start PMDG, SB or IVAO but I have no idea what`s happening in the background automaticly.

Edit the FSUIPC4.INI file 9with Notepad or a basic text editor), remove the "LogWrites=Yes" line and instead add these lines:

Debug=Please

LogExtras=x4411

I don`t have the line "LogWrites=Yes". Does it matter anything and can I write the new lines anywhere else in the FSUIPC.INI?

Axel

Share this post


Link to post
Share on other sites

I don`t know why some programms are running. I didn`t start PMDG, SB or IVAO but I have no idea what`s happening in the background automaticly.

If you've installed a PMDG aircraft, Squawkbox and IVAP, their modules are always loaded. They are running all the time whether you decide to use them or not. They are not like Gauges, loaded with the aircraft. They probably don't do a lot whilst their targets aren't enabled, but they are interfacing to Simconnect. That's all I meant.

I don`t have the line "LogWrites=Yes".

You did when you did the last test, as IPC writes were logged, as I requested.

Does it matter anything and can I write the new lines anywhere else in the FSUIPC.INI?

In the [General] section, anywhere in there, but no where else.

Regards

Pete

Share this post


Link to post
Share on other sites

From your recent results, partially received via email, it does more and more look like some sort of memory corruption.

The problems with memory corruption are really completely unpredictable. All I wanted that full FSUIPC log for was to see if it was still receiving messages from SimConnect – because the previous log most certainly showed it was still receiving them, and logging them, from the aircraft. If it stops receiving messages from SimConnect it should log the fact and reconnect, which it didn’t, so I wanted to see why. But possibly it is receiving messages from SimConnect but SimConnect is not receiving them from FSUIPC – that could explain why EFB still gets the user aircraft position, but not AI aircraft updates. It would be notified of existing AI aircraft data at the time SimConnect stopped working correctly, and it would be notified of additions and removals, but its requests for data on additions wouldn’t reach SimConnect.

This is the only explanation I can come up with – I just needed the FSUIPC log to verify. If you can’t send it all just send the last part, whatever size you can manage. It will show what was happening in the last minutes.

I am taking a look to see if there’s any way I can detect whether SimConnect receives my requests, and log those failures too, and maybe try reconnecting. I’ll let you know – but it would be a waste of effort if the log shows not receipts. I’d have to look elsewhere.

Either way it looks like there’s no solution except to avoid the combination of add-ons which is resulting in the corruption. Maybe you could try disabling some of those additional SimConnect users I listed.

You could also see if Prepar3D suffers from the same problem, but you’d need to subscribe to it.

Regards

Pete

Share this post


Link to post
Share on other sites

Pete,

Yes I use the latest EFB version 1.3.2 (DataProvider 1.3.2.26445 and Display Unit 1.3.2.26442) running on one PC together with FSX.

Maybe you could try disabling some of those additional SimConnect users I listed.

I will do that but how can I do it without deleting them?

If the disabling won`t be successful I will change to an older EFB version to check if the problem remains or not. I`ll let you know the result.

Axel

Share this post


Link to post
Share on other sites

I will do that but how can I do it without deleting them?

The ones which are loading automatically are doing so because of entries in the DLL.XML and EXE.XML files, located in the same folder as your FSX.CFG file. You can disable them individually be changing a "disabled" parameter from FALSE to TRUE. For example, here is one section in the DLL.XML file:

  <Launch.Addon>
<Name>Addon Manager</Name>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Path>bglmanx.dll</Path>
</Launch.Addon>[/CODE]

If that <Disabled>False</Disabled> line read <Disabled>True</Disabled> instead, it wouldn't load.

Save copies of those files first in case you make a mistake.

Regards

Pete

Share this post


Link to post
Share on other sites

I couldn`t wait and deleted my current EFB version 1.3.2 and replaced it with version 1.3.1. No problems at all :razz:. I will do further checks what EFB version/update is causing the problem.

Axel

Share this post


Link to post
Share on other sites

I couldn`t wait and deleted my current EFB version 1.3.2 and replaced it with version 1.3.1. No problems at all :razz:

Ouch! I just updated from 1.3.1-5 to 1.3.2. Does that mean I'll start to get problems, I wonder? When you've narrowed it does please do report it to Aivlasoft.

Regards

Pete

Share this post


Link to post
Share on other sites

I installed and uninstalled a couple of hours the several EFB versions to figure out which version causes the FSUIPC problems while using Citation X. On my computer it is the latest version 1.3.2. I checked the previous version 1.3.1- SP5 and everything was ok.

Does that mean I'll start to get problems, I wonder?

I don`t assume that because you said you don`t have the Eaglesoft Citation X. And that is the only aircraft I have that problem.

I will get in contact with AivlaSoft and tell them that issue.

Pete, Thank you very much for your outstanding support!

Regards

Axel

Share this post


Link to post
Share on other sites

I installed and uninstalled a couple of hours the several EFB versions to figure out which version causes the FSUIPC problems while using Citation X. On my computer it is the latest version 1.3.2. I checked the previous version 1.3.1- SP5 and everything was ok.

Ah, so it is only something in the very latest update.

I don`t assume that because you said you don`t have the Eaglesoft Citation X. And that is the only aircraft I have that problem.

I was concerned because my last two flights have suffered Out Of Memory (OOM) errors on approaching London. This is with a standard test flight I've flown many many times, never before with an OOM. In fact I've never before experienced an OOM with Windows 7-64. I am trying to track it down this weekend, by a process of elimination, and your experience does suggest EFB as being a possible canddate. However, I was using 1.3.1- SP5 when I get the first OOM and 1.3.2 when I got the second.

Regards

Pete

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.