Jump to content
The simFlight Network Forums
Sign in to follow this  
alpha117

Aircraft Profiles

Recommended Posts

I'm going to reassign my buttons and leave it at that, until you come back to me Pete later on today.

If you want me to check anything then let me know

Clive

Share this post


Link to post
Share on other sites

been flying around, everything works just great, buttons, rotaries and axes; are a dream and much more responsive.

But......no profiles used :cry:

Share this post


Link to post
Share on other sites

It looks like it has automatically added ALL the axes to the profile and no buttons

I'm just abut to try to test the way you have listed, but before I do that the first question is:

Why do you expect there to be any Profile Specific buttons in the INI when you didn't assign any? All the assignments are in the generic section, which applies to all aircraft. Assignments made Profile Specific are just the extra ones or overrides for the psecific profile, yet, according ytoy your sequence ofg actions you never actually made any such assignments. That's why there's no Profile specific buttons section.

Now FSUIPC doesn't find joystick, still plugged into same USB

You have something else going on there, then. Detection of joysticks is nothing at all to do with profiles and hasn't been changed in years. If that sort of thing persists we'll need to investigate it separately.

Went to check ini file and it had added

[buttons]

ButtonRepeat=20,10

Why's that and what does it do?

As documented, is sets the button repeat and delay to repeat timings. See the Advanced Users guide. That is the standard default setting.

been flying around, everything works just great, buttons, rotaries and axes; are a dream and much more responsive.

But......no profiles used :cry:

I'm starting to get the feeling that much of what you are reporting an a problem is in fact a result of a misunderstanding of how Profiles work.

Generic (non-profile specific) assignments to buttons and keys apply to ALL aircraft unless explicitly overridden by Profile-specific assignments. You only need to assign the differences, not reassign everything. All of the more generally applicable buttons or keys will therefore be easy to do.

Axis assignment and joystick calibration is different. It would be wrong to apply generic settings to specific aircraft if those settings are not overridden, because axes, unlike keys and buttons, are effectively always active. You wouldnt want a yoke used in a helicopter if you had a profile specific G-stick assigned for it instead, because the yoke could interfere quite easily.

Anyway, the only problem I've found is that if you select Profile specific for Buttons, Keys or Calibrations, it automatically selects Profiles for Axis assignments as well, with a copy of your generic assignmnents. This happened to you, and it is wrong -- they should be individually selectable (not to different Profiles, but whether they are specific or not). I'll fix that now.

Everything else works fine here.

Regards

Pete

Share this post


Link to post
Share on other sites

hi Pete

6. OPen up FSUIPC

7. Selected button and switches tab

8. Pressed already assigned button

9. clicked in profile specific white box

10. selected new from dropdown

11. Typed in C337 in box

12. Clicked OK

13. Profile specfic? now has tick in box

14. Clicked OK

15. Back in cockpit..rechecked ALL axes and buttons. All still work OK

Carried out 6-15 for another button. No problems

at the end of this stage I had assigned TWO buttons to the C337 profile, but NO axes

therefore:

[Profile.C337]

1=C337 Skymaster RED

[Axes.C337]

0=0X,256,D,1,0,0,0

1=0Y,256,D,2,0,0,0

2=0Z,256,D,4,0,0,0

3=0U,256,D,5,0,0,0

4=0V,256,D,3,0,0,0

5=0S,256,D,6,0,0,0

why no buttons assigned to profile, but axes have been

Share this post


Link to post
Share on other sites

I also fully understand that theres are 'Generic' assignments which will apply across all aircraft

[JoyNames]

AutoAssignLetters=No

0=Saitek X52 Flight Controller

0.GUID={E0184170-C2B5-11E0-8002-444553540000}

[buttons]

ButtonRepeat=20,10

1=R0,3,K35,8

2=R0,2,K36,8

3=P0,8,K190,10

4=R0,14,K190,8

5=P0,6,K66,8

6=P0,19,K117,8

7=P0,21,K118,8

8=P0,5,K71,8

9=R0,10,K78,8

10=R0,11,K77,8

11=P0,1,K90,8

[Axes]

0=0X,256,D,1,0,0,0

1=0Y,256,D,2,0,0,0

2=0Z,256,D,4,0,0,0

3=0U,256,D,5,0,0,0

4=0V,256,D,3,0,0,0

5=0S,256,D,6,0,0,0

Share this post


Link to post
Share on other sites

So is this valid :

[JoyNames]

AutoAssignLetters=No

0=Saitek X52 Flight Controller

0.GUID={E0184170-C2B5-11E0-8002-444553540000}

[buttons]

ButtonRepeat=20,10

1=R0,3,K35,8

2=R0,2,K36,8

3=P0,8,K190,10

4=R0,14,K190,8

5=P0,6,K66,8

6=P0,19,K117,8

7=P0,21,K118,8

8=P0,5,K71,8

9=R0,10,K78,8

10=R0,11,K77,8

11=P0,1,K90,8

[Axes]

0=0X,256,D,1,0,0,0

1=0Y,256,D,2,0,0,0

2=0Z,256,D,4,0,0,0

3=0U,256,D,5,0,0,0

4=0V,256,D,3,0,0,0

5=0S,256,D,6,0,0,0

[Profile.C337]

1=C337 Skymaster RED

[Axes.C337]

0=0X,256,D,1,0,0,0

1=0Y,256,D,2,0,0,0

2=0Z,256,D,4,0,0,0

3=0U,256,D,5,0,0,0

4=0V,256,D,3,0,0,0

5=0S,256,D,6,0,0,0

[buttons.C337]

2=R0,2,K36,8

10=R0,11,K77,8

Share this post


Link to post
Share on other sites

hi Pete

Why are you repeating yourself?

at the end of this stage I had assigned TWO buttons to the C337 profile, but NO axes

No, you had NOT! You assigned the buttons BEFORE clicking the Profile Specific checkbox, so those buttons are in the generic assignments, applied to all aircraft. with buttons and keys you can switch back and forth as you like, changing the generic or specific assignments, because they all apply -- except that the same button or key assigned specifically overrides one assigned generically.

why no buttons assigned to profile, but axes have been

No buttons assigned because you assigned none. As I've explained before, and the axes were wrongly profile assigned because of a bug I've just fixed here and will be okay in 4.804 as soon as i can get around to uploading it!

can assignments appears both in 'Generic' and 'profile'

Of course they can! And for buttons and keys, both apply, with Profile ones taking precedence on duplicates. I've said all this before!

With axes and calibrations, for the reasons i explained already, only the profile ones apply if both are present.

So is this valid :

Yes, of course it is valid, but your axes probably won't work in any aircraft, profile or not, because you've assigned them all "Direct to FSUIPC Calibration" but haven't (yet?) calibrated any of them.

Pete

Share this post


Link to post
Share on other sites

I will wait for the next update and try again :oops:

The only thing wrong with what you have is the automatic axis assignments to the profile. That should be optional. There's really no reason to start again each time. Anyway, 4.804 is up, now.

http://fsuipc.simflight.com/beta/FSUIPC4804.zip

I'm just updating the announcement.

Regards

Pete

Share this post


Link to post
Share on other sites

just 'profiled' another aircraft from another profile and made changes to the new profile.

Hey this is easy when you know how :mrgreen: :mrgreen:

Share this post


Link to post
Share on other sites

I just had this happen to me. Lost control of the yoke axises as well as a number of its buttons, after assigning within a profile, a spoiler and flap axis to the quadrant. I was going to post, but glad its fixed already!

* Orest

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.