Jump to content
The simFlight Network Forums
Sign in to follow this  
Heron 1B

Steering Tiller

Recommended Posts

- LINDA GUI (linda.exe) - is the only part of the system which is dealing with HID-devices directly.

- Lua scripts in LINDA are only using COM-port interactions.

- actions.lua script is just a collection of Lua functions which are called only when some button is pressed. There is also a little part of it which is executed by timer, but it's not really big to cause any problems.

So if all the devices are handled that way, wouldn't it be best for users to stop FSUIPC scanning them all the time?

So, if error is still there without linda.exe running, then this is Lua scripting problem.

Actually, although that was tested (i.e. no LINDA.EXE running) once, it was with an earlier test version of FSUIPC which had a bug in the extra bits, so it needs checking again with 4.811d. Derek, can you do that please? See if the crash still occurs with the Run command for LINDA.EXE removed from the INI file?

And the only idea I have, is some kind of memory limitation for Lua scripts in FSUIPC.

No, there is no memory limitation as such, other than the 4Gb total process memory of a 32-bit process -- obviously all the Lua threads are part of the FSX process. And the fact that the crash doesn't hasppen when I use more logging -- specifically Lua tracing, with a message per line occurring -- which will use MORE memory, not less, realy indicates some sort of timing problem

That the crash occurs in DINPUT.DLL, and only when using the FSUIPC options, is really weird. It smalls of a bad device driver or a clash.The only think different about entering/exiting the FSUIPC options (i.e. where it is crashing) to its normal device scanning is it closing and re-scanning of each of the DirectInput devices it is using. Apart from the options, the only other time it does these things is on initial loading -- before LINDA is running -- and on closing FSX.

The constantly changing values which Derek sees in the FSUIPC axis assignments dialogue is rather odd. Is this likely to be LINDA or something to do with one of the devices, like the Leo Bodnar boards?

If only I could reproduce it here we might make some progress. But the fact that Derek seems to be the only one with the problem is pointing rather to a special combination of things which is going to be difficult if not impossible to recreate sufficiently well.

Regards

Pete

Share this post


Link to post
Share on other sites

Pete,

Email sent with latest log and axis test.

Artem, this time round I removed the [Program] RunIf1=D:\FSX\Modules\linda.exe and emptied actions.lua folder like before. This time round had crash attempting to open FSUIPC in PMDG737NGX. Only difference is new FSUIPC4.dll version 4.811d.

Derek

Share this post


Link to post
Share on other sites

Pete,

In addidtion, I have just unplugged all three BU0836X boards, started FSX, PMDG737NGX and attempted to open FSUIPC, the crash is still there. Went back into FSX to default Cessna 172 and FSUIPC Axis Assignments page and the numerals are spinning.

Regards,

Derek

Share this post


Link to post
Share on other sites

Email sent with latest log and axis test.

And you said:

Ran through each axis using ignore and rescan found the following:

Note the Joy# does not change, always 5.

Joy#5 Axis X

S

Y

All had the numerals spinning

Joy#5 is this device:

5=Plasma-MM2

5.GUID={1D2B17C0-C7E0-11E0-800F-444553540000}

I've no idea what that is, but it is certainly misbehaving. could you re-test without it connected, please?

I'm about to release 4.812 which has some other changes, not connected with your problems, but one of the things I've put into it is a new INI file parameter "AutoScanDevices=Yes" (in the [General] section). If you change that to "No" then FSUIPC will not re-scan the DirectInput devices each time you enter the FSUIPC options. Instead, if you make a change to connections, you would need to click the "Reload" button in either the Axes or Buttons tabs. Since you've no need to do that (because LINDA is doing it all, it seems), this might hopefully avoid your problem. FSUIPC will still be scanning buttons, though, unless you also set PollInterval=0 in the main [buttons] section.

Maybe you could try these things later ... 4.812 will be up in a couple of hours, maybe less. See the Download Links subforum.

Just saw your last message. You say

, I have just unplugged all three BU0836X boards

but in fact the problem seems to be Joy#5, the Plasma-MM2, whatever that is.

Regards

Pete

Share this post


Link to post
Share on other sites

Pete,

That Plasma-MM2 is the 737 yoke.......had it since 2008..............it is from here.....http://www.737yoke.com/

Just unplugged the yoke and been back into FSX, PMDG737NGX still has crash problem attempting to open FSUIPC. Going back into FSX and the Cessna 172 whereby I can access FSUIPC\ Axis Assignments page...... the page is greyed out, no Joy # detail. Still have LINDA.exe uninstalled.

Will re-run PMMR 123 and Device Manager for the yoke.....driver update

Regards

Derek

Share this post


Link to post
Share on other sites

Pete,

The driver update did not fix the situation although the yoke seems to be fully functional. Been into Windows Games Controller, during test found one of the "Slider" unstable. It does not give any indication what slider that is, has two.

Will contact 737Yoke, the company that produce the unit. Maybe not the driver but pot problem in the yoke.

Would you like another .log reading with yoke disconnected?

Will keep eye out for the new FSUIPC4 download

Regards,

Derek

Share this post


Link to post
Share on other sites

Just unplugged the yoke and been back into FSX, PMDG737NGX still has crash problem attempting to open FSUIPC

Strange. no idea then. Have you tried that new option to stop the re-scanning of DirectInput devices?

Going back into FSX and the Cessna 172 whereby I can access FSUIPC\ Axis Assignments page...... the page is greyed out, no Joy # detail.

There's nothing in FSUIPC to "gray out" any "page" (tab?). If you mean no joy# axis# data, do you mean no spurious changes or no recognition of anything at all? Do none of your other USB devices have any axes on them? No throttles pedals or anything?

Would you like another .log reading with yoke disconnected?

No thank you.

Will keep eye out for the new FSUIPC4 download

It was up within the two hours i stated -- four hours before you posted that you were going to keep an eye out!

Pete

Share this post


Link to post
Share on other sites

Will download the 4.812 again.......thought I had it but obviously not as "AutoScanDevices=Yes" does not appear in the .ini.

Downloading now.

Derek

Share this post


Link to post
Share on other sites

Pete,

Have it installed now, the "AutoScanDevices=Yes" set to No fixed the crash issue in PMDG737NGX.

Disregard my previous comment ref greyed out screen, I meant no Joy# Axis # data but that is how it should be with Joy#5 disconnected, just my pea brain I guess.

Once again, many thanks for all the time you have spent on this, it is VERY much appreciated.

Regards,

Derek

Share this post


Link to post
Share on other sites

So if all the devices are handled that way, wouldn't it be best for users to stop FSUIPC scanning them all the time?

Not sure what do you mean. But you should note that most of LINDA users also have several joystick assignments made within FSUIPC and ALL the axes assigned through default FSX input or/and FSUIPC calibration/assignment fascility.

Another idea! Derek, try to remove any assigments done in LINDA for NGX and Default FSX aircrafts. May be this is some kind of flood problem when some button sends to many presses/releases in a short period of time.

Share this post


Link to post
Share on other sites

Artem,

All my LINDA assignments are for PMDG737NGX forward overhead, autobrake,landing gear via three BU boards. My TQ is a Throttletek and the only LINDA assignments there are the two fuel control/cut off switches. All for the PMDG NGX

Just been through to double check anyway and can confirm no default FSX aircraft are involved. Also started FSX, went to the NGX and all my LINDA assigned switches function normally as does the autobrake, landing gear and fuel cutoff controls.

Pete did find problems with my Yoke (Joy#5) appears to have a fault slider but there again the aileron and elevator seems normal.

Expecting email from 737Yoke support ref poss new driver update since 2008.

Regards,

Derek

Share this post


Link to post
Share on other sites

Not sure what do you mean. But you should note that most of LINDA users also have several joystick assignments made within FSUIPC and ALL the axes assigned through default FSX input or/and FSUIPC calibration/assignment fascility.

I must have misunderstood something. When you said "LINDA GUI (linda.exe) - is the only part of the system which is dealing with HID-devices directly.", and earlier said that the joysticks would not work without LINDA.EXE running, I deduced that everything connected was going through LINDA, not FSX or FSUIPC assignments. Is that not in fact the case?

The FSUIPC calibration is quite distinct from assignment. It calibrates control values inside FS no matter how or where they emanate.

Anyway, Derek's conflict is certainly to do with the re-scanning of DirectInput/HID devices which is normally performed each time the Options are entered. I don't understand how that is occurring. I'd like to narrow it down to the actual Lua library function calls being used at that time so that I can implement some sort of specific interlock. However, the problem doesn't appear to occur if I switch on Lua tracing -- evidently that slows things down enough to avoid the clash.

Possibly you could point me to the specific places in all the Lua being run which may be doing something on a HID or Joystick and at which I could maybe add a debug call?

Alternatively I could, perhaps, just ruthlessly suspend (temporarily) all Lua threads whilst the re-scanning was happening, then let them carry on afterwards.

I'll think about that. Meanwhile I will be too busy here until next Tuesday.

Regards

Pete

Share this post


Link to post
Share on other sites

Have it installed now, the "AutoScanDevices=Yes" set to No fixed the crash issue in PMDG737NGX.

Okay. I managed to get back on the case today, and I've added code now to suspend Lua program execution temporarily whilst FSUIPC re-scans joystick devices. Basically this should eliminate the need to use the AutoScanDevices=No setting and will enable you to reload assignments in FSUIPC options without crashing. At least this is what I think.

FSUIPC4812a

Could you please test it for me and let me know? I've not released it yet, so just download FSUIPC 4.812a, change the AutoScanDevices=No line back to 'Yes', and see if the crash is still avoided.

Thanks!

Regards

Pete

Share this post


Link to post
Share on other sites

Crash is back with 4.812a and AutoScanDevices=Yes.........

Ouch ouch ouch! So suspending all the Lua threads whilst the part otherwise avoided by AutoScanDevices=No doesn't stop something going on still. I can only think that LINDA or its Lua plug-ins start other threads which, of course, FSUIPC is not aware of and therefore cannot suspend.

I don't think I've any other things i can try. Looks like the AutoScanDevices=No is here to stay for LINDA users, or at least those with the more complex setups. I suppose it isn't too disadvantageous -- it simply means you can't add or move devices whilst Linda and PMDG NGX are running, but you can otherwise by using the reload buttons.

If i do think of anything else I'll add details here.

Regards

Pete

Share this post


Link to post
Share on other sites

Thanks Pete,

Over the weekend I installed the SimParts steering tiller and used FSUIPC Axis Assignment and Joystick Calibration. I now have tiller up to 60kts then the rudder has authority.

Surprised as I have Saitek Pro Pedals which has its own driver and utilises FS Rudder axis which I thought would conflict if I set up the tiller with FSUIPC.

I had FSUIPC 4.812 and AutoScanDevices=No with PMDG NGX and LINDA running.

This is my .ini file as it is now but with 4.812a installed.

[General]

UpdatedByVersion=4812a

History=X2N5NSVTT3SK7JMPG5YJW

MouseWheelMove=No

MouseWheelTrim=No

MouseWheelTrimSpeed=1

JoystickTimeout=20

PollGFTQ6=Yes

BlankDisplays=No

FixControlAccel=No

FixMachSpeedBug=No

DeleteVehiclesForAES=Yes

VisibilityOptions=No

OneCloudLayer=No

CloudTurbulence=No

CloudIcing=No

GenerateCirrus=No

SuppressCloudTurbulence=No

MaxIce=-4

MinIce=-4

UpperWindGusts=No

SuppressWindTurbulence=No

SuppressWindVariance=No

WindTurbulence=No

TurbulenceRate=0.5,2.5

TurbulenceDivisor=40,40,80,80

SuppressAllGusts=No

MaxSurfaceWind=0

WindLimitLevel=200

WindDiscardLevel=400

WindAjustAltitude=No

WindAjustAltitudeBy=2000

SmoothBySimTime=No

WindSmoothing=No

WindSmoothness=2

WindSmoothAirborneOnly=Yes

PressureSmoothness=0

TemperatureSmoothness=0

DisconnTrimForAP=No

ZeroElevForAPAlt=No

ThrottleSyncAll=No

WhiteMessages=No

ShowPMcontrols=No

SpoilerIncrement=512

MagicBattery=Yes

RudderSpikeRemoval=Yes

ElevatorSpikeRemoval=Yes

AileronSpikeRemoval=Yes

ReversedElevatorTrim=No

ClockSync=No

ClockSyncMins=3

ClearWeatherDynamics=No

OwnWeatherChanges=No

TimeForSelect=4

LoadFlightMenu=No

LoadPlanMenu=No

PauseAfterCrash=No

BrakeReleaseThreshold=75

SaveDataWithFlights=No

ZapSound=firework

ShortAircraftNameOk=Substring

UseProfiles=Yes

EnableMouseLook=No

AxesWrongRange=No

TCASid=Type

TCASrange=40

AxisCalibration=No

DirectAxesToCalibs=No

ShowMultilineWindow=Yes

SuppressSingleline=No

SuppressMultilineFS=No

AxisIntercepts=No

DontResetAxes=No

InitDelay=0

GetNearestAirports=Yes

WeatherReadFactor=2

WeatherRewriteSeconds=1

CustomWeatherModify=No

SimConnectStallTime=1

LuaRerunDelay=66

Console=No

AutoScanDevices=No

FSVersionUsed="Microsoft Flight Simulator X",10.0.61472.0

SimConnectUsed=10.0.61259.0

[JoyNames]

AutoAssignLetters=No

0=BU0836 Interface

0.GUID={6F1513C0-6F73-11E1-8001-444553540000}

1=G-Throttles

1.GUID={C83F4640-C678-11E0-8006-444553540000}

2=Saitek Pro Flight Rudder Pedals

2.GUID={1D234F90-C7E0-11E0-8001-444553540000}

3=BU0836X Interface

3.GUID={1D2B65E0-C7E0-11E0-8011-444553540000}

4=BU0836X Interface

4.GUID={1D2B8CF0-C7E0-11E0-8012-444553540000}

5=Plasma-MM2

5.GUID={1D2B17C0-C7E0-11E0-800F-444553540000}

6=BU0836X Interface

6.GUID={530B85E0-1B60-11E1-8001-444553540000}

[buttons]

ButtonRepeat=20,10

3=R1,1,C65602,0

4=U1,1,C65697,0

5=P1,5,C65853,0

6=U1,5,C65786,0

11=P4,12,CM3:1,0

[Auto.PMDG 737]

1=Lua NGX_AUTO

[Auto.Boeing 737]

1=Lua NGX_AUTO

[MacroFiles]

1=0_PMDG_ATTN

[LuaFiles]

1=ipcReady

2=linda

3=NGX_AUTO

[AutoSave]

Next=1

Interval=60

Files=10

SaveOnGround=No

AutoSaveEnabled=No

[GPSout]

GPSoutEnabled=No

[GPSout2]

GPSoutEnabled=No

[WideServer]

WideFSenabled=Yes

[sounds]

Path=D:\FSX\Sound\

Device1=Primary Sound Driver

Device2=Speakers (Sound Blaster X-Fi Xtreme Audio)

Device3=Speakers (10- USB audio CODEC)

Device4=Realtek Digital Output(Optical) (Realtek High Definition Audio)

Device5=Digital Audio (S/PDIF) (Sound Blaster X-Fi Xtreme Audio)

Device6=Realtek Digital Output (Realtek High Definition Audio)

[Window.LUA display]

Docked=7398, 3310, 3524, 2430

Undocked=535, 252, 230, 140

[Programs]

RunIf1=D:\FSX\Modules\linda.exe

[Profile.PMDG 737]

1=PMDG 737

[Profile.Boeing 737]

1=Boeing 737

[Axes]

0=0X,1,F,66818,0,0,0

[JoystickCalibration]

AllowSuppressForPFCquad=Yes

ExcludeThrottleSet=Yes

ExcludeMixtureSet=Yes

ExcludePropPitchSet=Yes

SepRevsJetsOnly=No

ApplyHeloTrim=No

UseAxisControlsForNRZ=No

FlapsSetControl=0

FlapDetents=No

ReverserControl=66292

Reverser1Control=66422

Reverser2Control=66425

Reverser3Control=66428

Reverser4Control=66431

MaxThrottleForReverser=256

AileronTrimControl=66731

RudderTrimControl=66732

CowlFlaps1Control=66162

CowlFlaps2Control=66163

CowlFlaps3Control=66164

CowlFlaps4Control=66165

SteeringTillerControl=0

MaxSteerSpeed=60

SteeringTiller=-16380,-512,512,16380

Share this post


Link to post
Share on other sites

Over the weekend I installed the SimParts steering tiller and used FSUIPC Axis Assignment and Joystick Calibration. I now have tiller up to 60kts then the rudder has authority.

Surprised as I have Saitek Pro Pedals which has its own driver and utilises FS Rudder axis which I thought would conflict if I set up the tiller with FSUIPC.

Since you have no axes at all assigned in FSUIPC except to the FSX "steering set" control, which FSUIPC doesn't process (because it has its own tiller control-- there was no FS steering control till FSX), FSUIPC is not at all involved. The calibration you've done for steering tiller there isn't going to be used because there's no input for it, unless it is coming from some LINDA action.

So, sorry, you are asking the wrong person. What you are seeing and using is not FSUIPC itself.

Regards

Pete

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.