Jump to content
The simFlight Network Forums
Sign in to follow this  
luker23

Problem running WideClient ver 6.9.4

Recommended Posts

Hi All,

I recently upgraded from using FS2004 to using FSX so I upgraded to a registered version FSUIPC4 4.80 and WideFS7 as well as WideClient version 6.94.

I installed as per documentation and ensured network was operating correctly. My server PC with FSX installed is Win 7 Home Premium, my client PCs are 2 x Win XP (Professional) SP3 and 1 x Win XP (Professional) machine - old machine.

Everything works as advertised except on the older Win XP machine. This machine has not been upgraded for many years (unlike the other two which have Service Pack 3 installed) and runs legacy programs hence my reluctance to upgrade it lest I break something... Anyhow on this machine when I click on WideClient.exe nothing happens and WideClient does not even appear in the Task Manager window. Furthermore no log is produced by WideClient which is frustrating.

When I used the older version of WideClient I was using with my FS2004 setup (version 6.78) it works and WideClient connects happily and no side-effects are evident. I am happy with the workaround for now.

However I'd like to know what could be causing me the problem with version 6.94 of WideClient as at some point in time I may not be able to use that older version and would like to use consistent versions across my environment, that is, have every client PC using 6.94 instead of the present situation whereby one of them is still using version 6.78 due to the problem mention above.

Thank you

Cheers,

Lucas

Share this post


Link to post
Share on other sites

Everything works as advertised except on the older Win XP machine. This machine has not been upgraded for many years (unlike the other two which have Service Pack 3 installed) and runs legacy programs hence my reluctance to upgrade it lest I break something... Anyhow on this machine when I click on WideClient.exe nothing happens and WideClient does not even appear in the Task Manager window. Furthermore no log is produced by WideClient which is frustrating.

It'll be because of some facilities I've added which weren't supported in the original XP. I'm afraid I can't work out what those might be. it could be related to the Lua plug-in facilities for HID devices, or the DirectX sound playing facilities. Without being able to debug the cause of it not being loaded I can't tell -- and it might be more than one thing.

When I used the older version of WideClient I was using with my FS2004 setup (version 6.78) it works and WideClient connects happily and no side-effects are evident. I am happy with the workaround for now.

The basic protocols WideFs uses haven't changed and won't change, and that version will still work with any version of FS and the Server in FSUIPC4 for FSX, so it isn't a problem. I can't support old versions, of course, but there should be no need.

However I'd like to know what could be causing me the problem with version 6.94 of WideClient

I don't have an XP installation here older than SP2, which is fine, and at present i can't think of any way to determine the dependencies which aren't being met without installing a development system with its debugger. If I can think of a way of finding out what it is needing to load, I could make those elements link dynamically, optionally, at run time rather than statically as at present. But it would be a lot of work in any case and I really don't have time right at this moment I'm afraid.

Regards

Pete

Share this post


Link to post
Share on other sites

Pete,

Thank you for your prompt reply.

I am relieved to hear that I should have no problems by continuing to use the older version on my older "legacy" PC. Your answer makes a lot of sense and I had (logically) suspected that may have been the cause but its good to have it confirmed. At least this buys me some time while I experiment on another PC (when I acquire it) and I move to a more modern O/S which I should've of done some time ago !!!

I will keep my older version of WideClient under lock and key as it is the only one that will work on my legacy PC now, until I manage to upgrade the O/S.

Thanks again for your support and your great product.

Cheers,

Lucas

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.