Jump to content
The simFlight Network Forums

The Dreaded NTDLL & Terrain Error


Flapsup
 Share

Recommended Posts

Hi Burkhard,

As the topic tiltle suggests, I have been trouble shooting this for quite some time ( see link below ). The difference between mine and the user who posted in the link, http://forum.simflig...page__hl__ntdll

is that I get a CTD anywhere within USA airspace. Random, when airborne, and at most US major airports.

No issues in the rest of the world. One airport that I use to test is Flytampa KTPA, I can gurantee one there. Mostly Southwest, Jetblue, Delta and United etc.

I am guessing it is mroe then one rouge aircraft, but cannot nail it down which one it is.Also it must be a frequent flyer as it appears to be at most major airports.

I have done all the neccessary troubleshooting techniques, but to no avail.

I have MTX 5.4a plus latest patch installed, and I even downloaded a fresh copy from Simmarket today, just to make sure nothing was missed during installaion.

I have had MTX installed since release with no issues, this has happened since 5.4a. Have even put FSX back to bare bones, so no addon airports or afcads, and still get the Ntdll and terrain.dll. (double wammy) error. If I disable MTX in the scenery library, I do not get the error(s).

Would appreciate any help.

Cheers

Julian

Link to comment
Share on other sites

I went around the clock in TPA, every two hours, so twelve loads without a crash. I would feel better if I could reproduce this. You applied the patches to version 5.4a?

I downloaded 5.4a yesterday. A clean install of "A". Before yseterday, I had 5.4 installed with the "A" patch applied. I have also applied the small patch that was released several weeks ago.

Whatever it is, it only flies in the US, so it is either military or a domestic carrier ? Sometimes I have been able to depart from Tampa, to say fly to Midway, only to CTD halfway. What is more perplexing is no one else seems to be experiencing this. Including yourself :)

If I am able to load Tampa, if I change to KPHL, I get a CTD.

Edit: I use MTX LIVE/UT2 schedules. In Manage aircraft, I use wide.

Link to comment
Share on other sites

Ah - you changed the models to wide screen models? That changes myriad of possibilities, or at least 1000....

If you use MyTraffic as it comes, do you also get the CTD? Since that is what I tested up to now...

Actualy, I have not tested as it comes. Thanks for the tip, will try that and see what happens. Will report back.

Link to comment
Share on other sites

Ah - you changed the models to wide screen models? That changes myriad of possibilities, or at least 1000....

Well, my friend, that fixed my problem. Interesting what happens when you tick a box, and forget it. The last thing I would have thought of.

What is the purpose or function of the "Wide" option ? Just curious.

Link to comment
Share on other sites

Seems I spoke too soon Burkhard. I was wondering if I can e-mail you my scenery.cfg to check the structure for me. I am puzzled as to why MTX works great everywhere but the USA. I can even fly around Canada no problem. I can fly within the USA, but only with MTX disabled.So I am starting to think scenery layering maybe ? Also it can CTD insatant it loads ( Use KTPA ) or 20 or 30 mins later.

Edit: I have moved MTX up the scenery.cfg ladder above UTX, and so far no CTD. Will see how it goes after a few flights and let you know.

Link to comment
Share on other sites

When it loads and the CTD appears, does this happen during "loading AI traffic", typically between 87 and 90%, or at other percentages? There is one way an AI traffic addon can cause FSX to crash, and that is if the aircraft.cfg calls a model=xxxx and the corresponding model.xxxx folder does not exist. While we spent a lot this not to happen, one never knows if something is wrong on a very rare plane. The wide option now makes a change to the model=entry, and if something goes wrong there then it can introduce the crashes. But these either happen at 87 to 90 %, or in flight when this aircraft is supposed to come into the visibility box and the model does not exist - so at some point are somehow typical, and once one has identidied one it is possible to find the culprit.

Link to comment
Share on other sites

The CTD can happen the instant the airport loads, never during the loading sequence. Any aircraft, NGX, default as well. 30 seconds even upto 30 mins. Sometime when you get near the threshold after taxi. Sometimes in mid air. Sometimes you think you have fixed the issue, then it happens again.

Going to be moving house, so will be grounded for a few days, so will try with MTX moved up the scenery.cfg layer when I am up & running again. Will let you know how it goes.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.