Jump to content
The simFlight Network Forums

Buildings Disappear


Recommended Posts

Hi All,

The following thing is happening to me: I'm using FSX Acceleration, FSDT PHNL with MyTraffic X and if I "FOLLOW AI" in SuperTrafficBoard (v.3.1.10.1) to another aircraft parts of the scenery disappear, if not all. When buildings, hangars, etc. disappear in FSDT PHNL all I see are black shadows in the ground. It won't happen if I use the built in "AIR TRAFFIC" option in FSX. I did the "Rerun First Time Configuration Wizard" to recompile the sceneries I had added, but to no avail.

Since the searches I made didn't come with an answer, I must presume that the "problem" is at my end. Any suggestions of what it might be?

Thanks,

Joe.

PS.: It won't happen if I "SHADOW AI" or "CHASE AI". With "FOLLOW AI" the scenery briefly shows and then disappears.

Link to post
Share on other sites

Perhaps a question for FSDT. I understand their scenery elements are closely geared to the location of the user aircraft. In Follow AI the user aircraft is positioned some distance away from the AI aircraft, as configured in the settings notebook. In most cases I imagine this is too far away for the scenery to be fully drawn. Both Shadow and Chase put the user much closer, but are different animals.

Simon

Link to post
Share on other sites

Hi Simon,

Here is what I did: Since the distance from my aircraft from that of the AI aircraft might be huge, since FSDT PHNL is a big airport, I positioned, using SLEW, my user aircraft right next to the AI aircraft I wanted to see. Turned off SLEW and I "FOLLOW AI" to that aircraft and the scenery disappeared. I "RETURN TO BASE" and the scenery reappeared. The AI and my user aircraft are side by side, so there's no distance between them. The same thing happens with other FSDT sceneries. This won't happen if I "VIEW AI". From my searches I found this at the FSDT Forum:

Quote from: phenocom on January 01, 2010, 01:49:46 PM

I have a strange problem in FSX. If I go to one of your airports the scenery displays perfectly. However if Super Traffic Board is operating and I choose one of the AI at a gate, the buildings all disappear then sometimes reappear. I was wondering if this had anything to do with the anti pop-up settings in addon manager.

Quote from: virtuali on January 01, 2010, 03:19:13 PM

It surely doesn't have anything to do with the anti pop-up, because that is a setting that it's internal to the Addon Manager so, it's not really possible the Super Traffic Board can have any effect on it. Also, if what disappears are the main buildings, they are not handled by the anti pop-up setting, because buildings already have a range equal to the whole scenery area: the Anti Pop-up is only meaningful for smaller objects that by default have less visual range, which usually is ground clutter details like baggage carts, boxes, static vehicles or vertical taxisigns, etc. What might happen, instead, could be that Super Traffic Board is sending so many commands to the Simconnect system, that is clobbering it. This is just a guess based on your description that the scenery works fine, until you enable the Traffic Board. If this is the case, I'm afraid there's nothing we can fix from our own side.

And from another user that didn't receive a reply:

Quote from: diceflo on May 01, 2010, 05:01:21 AM

It seems that Super Traffic Board doesn't play well with the FS Dream Team sceneries. If I use Traffic Tools to watch AI planes all is well. But when I turn on Super Traffic Board, then the buildings disappear. If I turn off Super Traffic Board, then the buildings come back. I love both programs and I would love to have them work together. Has anyone else noticed this and if so how did you solve the problem. By the way, both programs are installed and running fine, except with each other. Thanks

I changed the FSDT AntiPopUp to 30 and STB Follow AI distance to 30nm, but nothing happened. So this appears to be an old "problem". I'm slowly crawling towards FSX, coming from a long time in FS9, so I haven't tested in other payware sceneries. Any hint?

Best Regards,

Joe.

Link to post
Share on other sites

I have PHNL, and will look tonight.

"What might happen, instead, could be that Super Traffic Board is sending so many commands to the Simconnect system, that is clobbering it. This is just a guess based on your description that the scenery works fine, until you enable the Traffic Board. If this is the case, I'm afraid there's nothing we can fix from our own side."

I doubt this is the case. When I have STB connected, FSUIPC works fine, Ultimate Traffic 2 works fine, Plan G works fine, Flight1 Airliner Sounds works fine, all of which are SimConnect applications.

Simon

Link to post
Share on other sites

So here is what I discovered. First test case, with STB connected:

  • User aircraft flying around Honolulu, no problems with airport buildings;
  • User aircraft parked at airport, view AI on any aircraft shows buildings. However for most AI, no pop up objects like cargo containers, etc, are shown;
  • Shadow AI. Buildings and pop up objects shown;
  • User Aircraft moved 11nm away from airport. View AI no longer shows buildings (or popups);
  • Follow AI with user aircraft 9nm from target AI, buildings shown but no pop ups;
  • Follow AI with user aircraft 20nm away from target, no buildings shown;
  • Disconnecting STB made no difference;

Next, STB not connected and all AI actions through TrafficToolbox:

  • User aircraft within 10nm of airport, View AI through TT shows buildings only;
  • User aircraft greater than 10nm away from airport, no buildings shown;

Conclusions:

At least for me, everything seems to be working normally. The FSDT pop up objects are closely tied to the location of the user aircraft, and the buildings require the user to be within 10nm of the airport. The latter case is slightly different to default airports and other 3rd party, where the airport buildings are always shown when viewing AI irrespective of the location of the user aircraft.

So what does this mean for Follow AI? A much shorter distance is required in the settings notebook for "FolIow AI Distance" to keep the user aircraft within 10nm of the airport. Depending on the size of the airport concerned, values around 8 to 9nm should work.

Could you give this a try and see if it improves the situation?

Simon

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.