Jump to content
The simFlight Network Forums

Unable to connect to flight simulator


Pod265
 Share

Recommended Posts

I have had STB working fine on separate computers and then suddenly I get the message 'Unable to connect to flight simulator'. I also see the message 'Watchdog reports that UT2 service state is now open'.

I have installed beta 3.2 but still get the same message.

Any advice would be appreciated.

Bill

Link to comment
Share on other sites

That's usually an issue with simconnect or firewalls. Let's check simconnect first of all. Can you send me the simconnect.xml from the FSX application data folder on the FSX PC, and the SimConnect.cfg from MyDocuments on the STB computer please? Or just upload them or copy and paste them here.

The configuration wizards in the 3.2 beta won't make adjustments to an existing configuration, so another approach is to delete those simconnect files and let the wizards go to work.

Simon

Link to comment
Share on other sites

Just wanted to add that I had exactly this problem also, must frustrating. I downloaded the new beta server and client, removed the simconnect.cfg/xml files from each and let the new wizards do their job. AWESOME :) Worked first time, like a charm. I'd already spent an afternoon debugging it :( Much time saved, thanks

Si

Link to comment
Share on other sites

Thanks - one of the goals of the latest version is to make the client/server configuration easier.

Funnily enough I had problems connecting last night, and I ran into the other common area here which is simulator crashes. When that happens, it corrupts the network ports and a reboot of your simulator computer is necessary to recover (or change the port numbers in the configuration files).

Simon

Link to comment
Share on other sites

  • 8 months later...

I see I am not alone on it being very frustrating to not connect from a remote computer. I have disabled my zonealarm program, de-installed and re-installed 3 times and still it does not connect. Works find on the FSX computer but I brought this program to run on one of my remote computers. All other programs running remotely work fine. Its just this one. I am using the default ports using a DLink DIR-825 router. Are there any special instructions for that router?

Link to comment
Share on other sites

I'll be glad to help but need a little more to go on.  There are no special instructions required for the router as you are running on a local network and it's unlikely the router would be configured to block anything.  What version of STB do you have, and please provide a summary of what you did to set up the remote connect.

 

Simon

Link to comment
Share on other sites

Thanks for getting back to me.

 

I started out with a fresh just purchased version and installed the program on an XP Pro system using FSX Deluxe with all the updates.

After installing the upgrade check advised a new version was available so I upgraded.  The STB version is 3.2.0.40 and the data server on the FSX computer is 3.2.0.43. I already had other programs running on 1 other remote XP computer as well as programs running remotely on a Win7 Pro laptop. These programs run without issue.

 

The simconnect.cfg file looks like this:   

[simConnect]

Protocol=IPv4

MaxReceiveSize=4096

DisableNagle=0

Address=MyHomePC

Port=2024

 

The simconnect.xml from the FSX main directory looks like this: (only showing the comm settings)

<SimConnect.Comm>

<Disabled>False</Disabled>

<Protocol>IPv4</Protocol>

<Scope>global</Scope>

<Address> MyHomePC </Address>

<Port>2024</Port>

<MaxClients>64</MaxClients>

<MaxRecvSize>4096</MaxRecvSize>

<DisableNagle>False</DisableNagle>

 

While collecting info for you I noted the scope setting and went from global to local, rebooted FSX but that does not work also.

I checked all my firewall settings and your programs have a trusted setting on all computers.

The computer I am most concerned with is the remote XP Home system. The Win7 laptop is optional.

I do not know what other info to provide at the time so please let me know your questions. 

 

Thank you.
Link to comment
Share on other sites

So on the face of it, those files look OK.  Connection to FSX is a two stage process, first SimConnect then STB-DS.  Can you tell me the error message you get when you try to connect, I'd like to understand the stage we get to.  Perhaps a screenshot may help also.

 

Did you use the STB configuration wizard to set up the connection.  Perhaps more a question for once it is working, but I'd also like to understand how that failed to complete the configuration for you.

 

Simon

Link to comment
Share on other sites

Just want to let you know I am not ignoring you and appreciate your help.. I was on a business trip the past week. I will work with this more this coming week and get back to you asap. The error message I continue to get was the 'unable to connect to Flight Simulator'.

 

Thank you for your time..

Link to comment
Share on other sites

I found a program called 'Simconnect Config Tool' I ran it and used parameters STB advises and now your program works. The only change I can find is in the SimConnect.cfg file which now reads:

 

 

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="SimConnect" version="1,0">
  <Descr>SimConnect</Descr>
  <Filename>SimConnect.xml</Filename>
  <Disabled>False</Disabled>
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>Global</Scope>
    <Address>192.168.0.10</Address>
    <MaxClients>64</MaxClients>
    <Port>2024</Port>
    <MaxRecvSize>4096</MaxRecvSize>
    <DisableNagle>False</DisableNagle>
  </SimConnect.Comm>
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>Auto</Protocol>
    <Scope>local</Scope>
  </SimConnect.Comm>
</SimBase.Document>

 

I don't know where my original error was but... its working now.

 

Thanks for your help.

Link to comment
Share on other sites

  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.