Jump to content
The simFlight Network Forums

Fsupic not seeing goflight secm


nim
 Share

Recommended Posts

Hi

Just starting out with fsupic registered version.

I use 10 goflight modules amongst other controls For fsx on a win 7 64 bit system

All are seen by fsupic and working fine with switch assignments except the single engine control module.

It does not show up in fsupic,by that I mean when I am in the button assignment section and move any Switch on secm there is no response in fsupic. The switch identification box is blank

I would be grateful for any suggestions

Thank you

Link to comment
Share on other sites

All are seen by fsupic and working fine with switch assignments except the single engine control module.

Do you mean the TPM/SECM module? I don't see a SECM on its own listed on their site.

I've never seen one of these units. If they identify themselves differently to either a TPM or SECM, then that may be the problem. I could add support but I'd either need to ask GoFlight to send me a unit, or get you to run a series of tests with Lua plug-ins in order to determine what bits do what. I'll try my contact at GoFlight first, and let you know.

FSUIPC does include support for the original SECM module -- up to two are supported. The switches should be arriving as joystick.202 for the first annd 203 for the second. Maybe your GFDev.dll is out of date?

BTW you need to mention which version of FS and which of FSUIPC you are using, as it might make a difference too. Meanwhile, make sure FSUIPC is bang up to date (see Download Links subforum), and enable button logging in the Logging tab, then operate each switch in tirn and show me the FSUIPC log.

Pete

Link to comment
Share on other sites

Hello Mr Dowson,

Thank you for your prompt reply.

I am running FSUIPC4,just purchased and downloaded about a week or so ago.

GoFlight 2.22

FSX Gold edition.

GFDev.dll is dated this year.

The SECM,(single engine control module) is the one on page two of the GoFlight modules page.Mine is pretty old(several years ) now as I have been collecting bits and pieces for a while now.

Your comment about FSUIPC supporting SECM and naming issues led me to look at control panel/devices.

Oddly,while all the other GoFlight modules are shown as named modules eg GF-T8,the old SECM is listed only as "USB input device",a standard system device ,maker unknown,location Port_#0001.Hub_#0010.

It is shown in GF config 2.22 as SECM and I can acess it via GF keys and use with other programes eg DCS A10C.

It works within FSX for aircraft models that support the fsx defaults.

Do you think that would be the reason it is not seen by FSUIPC?

Thanks again for your reply.

Link to comment
Share on other sites

I am running FSUIPC4,just purchased and downloaded about a week or so ago.

Version numbers a more useful. I would assume that it is 4.853, then, unless you downloaded one of the updates since the main release?

GFDev.dll is dated this year.

Version number? (If you did that logging and showed me the log I could see the version numbers of both FSUIPC and GFDev.DLL.

Your comment about FSUIPC supporting SECM and naming issues led me to look at control panel/devices.

Oddly,while all the other GoFlight modules are shown as named modules eg GF-T8,the old SECM is listed only as "USB input device",a standard system device ,maker unknown,location Port_#0001.Hub_#0010.

It is shown in GF config 2.22 as SECM and I can acess it via GF keys and use with other programes eg DCS A10C.

It works within FSX for aircraft models that support the fsx defaults.

Do you think that would be the reason it is not seen by FSUIPC?

Possiby, though it is GFDev.DLL's job to work that stuff out. It sounds like GFDev doesn't like it.

If you look in the FSUIPC documents folder, in the FS Modules folder, you'll see a ZIP file containing a number of Lua plug-ins -- supplied as examples. Please copy the GFDisplay.lua file into the Modules folder, then go to Keys or Buttons tabs, press reload, and then assign a keypress or button to "Lua GFDdisplay". Then use that key or button to start that plug-in off. It will list all the devices and do a sort of display test, then sit and wait for buttons and switches. Try that, see what happens.

Finally, check the Download Links subforum here, the thread about the Lua package. In there is a link to a program called "HidScanner". Run that and show me the Hidscanner log it produces.

Pete

Link to comment
Share on other sites

Hello

I am having trouble carrying out your suggestions.

Undoubtedly due to my lack of knowledge.

In microsoft games fsx folder,modules,I do not see any zip files so cannot find lua plugins

and in the downloads section of this forum i only see no files message wherever I look in downloads section.

I did note that my FSUIPC4 is version 4.3

I remain grateful for your suggestions

Is this the log file? I enabled button record,started and stopped file and moved all the switches on the SECM

********* FSUIPC4, Version 4.30 by Pete Dowson *********

User Name="Doug Mcewan"

User Addr= I deleted email address but happy to provide if you want it

FSUIPC4 Key is provided

WIDEFS7 not user registered, or expired

[Continuation log requested by user]

Running inside FSX on Windows Vista (SimConnect Acc/SP2 Oct07)

Module base=61000000

Wind smoothing fix is fully installed

140062 System time = 06:17:06, FSX time = 06:14:56 (20:14Z)

182828 Sim stopped: average frame rate for last 42 secs = 40.0 fps

187531 System time = 06:17:53, FSX time = 06:15:39 (20:15Z)

187531 *** FSUIPC log file being closed

Average frame rate for running time of 48 secs = 37.9 fps

Memory managed: 24 Allocs, 24 Freed

********* FSUIPC Log file closed *** *******

Link to comment
Share on other sites

In microsoft games fsx folder,modules,I do not see any zip files so cannot find lua plugins

and in the downloads section of this forum i only see no files message wherever I look in downloads section.

I did note that my FSUIPC4 is version 4.3

In that case I am not surprised!!! I am sorry, but I cannot possibly support such an old version! Where on Earth did you "just ... downloaded about a week or so ago!"? It is over 4 years and 50 versions old, and certainly should not be available anywhere! I'd like to know where you got it so I can make sure it isn't supplied there any more!

I suggest you update and try again. The earliest supported version is 4.853 which is available on both the places which legitimately supply my programs. There is also a n update to 4.859d in the Download Links subforumn here.

Your FSUIPC registration is actually not valid either with that old version as the registration system was changed a couple of years ago! I wouldn't be surprised if it was causing you all sorts of problems!

BTW, also, you pressed the "New Log" button. Please do NOT do this! It means initialisation data is missing from the log. Only do as suggested, do not press things at random.

Pete

Link to comment
Share on other sites

Hello

I purchased FSUIPC via the link on the schiratti website after typing in FSUIPC4 into google.

The link on the page was to sim Market GMBH. 24 euros if I remember correctly.

This was a very recently.

I have now downloaded version 4.853 from the schiratti site directly.

The registration code does seem to be working and the problem is resolved.

Interesting.

I think your software is very useful for this hobby and will happily pay another registration if that becomes necessary,but so far so good.Looks like old software but a new code??? I wonder if a hangover from the old freeware version that was on my FSX system from aircraft addons in past.

If I should need to rebuy,where would you recommend I go to?

Thank you for your time and prompt responses.

Link to comment
Share on other sites

I purchased FSUIPC via the link on the schiratti website after typing in FSUIPC4 into google.

The link on the page was to sim Market GMBH. 24 euros if I remember correctly.

This was a very recently.

Yes, but the link on the Schiratti page to the SimFlight purchase page does NOT download anything. All the download links both here and on the Schiratti page most certainly have not supplied version 4.30 for over 4 years. That's why I need to know where you actually downloaded it, NOT where you purchased it! They are two separate actions!

The link on the purchase page is actually out of date, as I just discovered, but it does point to 4.80, not 4.30. I will ensure that gets fixed too, but at least 4.80 is less than one year old! ;-)

If I should need to rebuy,where would you recommend I go to?

You don't need to "rebuy", and the only purchase place is the SimMarket FSUIPC4 page.

Regards

Pete

Link to comment
Share on other sites

Don't seem to be getting posts up.

I tried to attach the fsupic file I downloaded and the text of my email from sim market but it doesn't seem to have uploaded.

Anyway,all I can say is that I followed the link to sim market and then followed the link in the purchase email.

I am sorry if this is inadequate information but I don't have anything else for you at this stage.

I suspect the problem must be that there was an old version on my system somewhere that I mistook for the correct one sometime during the process. I have gone back through the email from sim market and the link does indeed go to your page.

The PayPal documentation all looks correct.There is no suggestion of a pirate organization flogging off old software that I can see.

I thank you for your advice and excellent,timely responses.

Link to comment
Share on other sites

Don't seem to be getting posts up.

I tried to attach the fsupic file I downloaded and the text of my email from sim market but it doesn't seem to have uploaded.

It's okay. I don't want those. The email from SimMarket would not point to a download location which supplied 4.30 in any case.

I suspect the problem must be that there was an old version on my system somewhere that I mistook for the correct one sometime during the process. I have gone back through the email from sim market and the link does indeed go to your page.

I've searched for rogue copies lying around on the 'net, and haven't located any 4.30 version, so I think it might have been a mixup on your PC only. Maybe something else you installed also overwrote your correct version with an older one -- there are some bad add-on installers which do that.

The PayPal documentation all looks correct.There is no suggestion of a pirate organization flogging off old software that I can see.

It isn't anything to do with licensing or payment, only the use of an out of date copy.

Forget it now.

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.