Jump to content
The simFlight Network Forums

Cannot get FSUIPC registered in P3D (pulling hair out!)


Recommended Posts

Hi folks,

I know Pete is away until 18th Feb, so hoping someone else can help.

I am trying to install the latest version 4.86 (just downloaded today) of FSUIPC into P3D ...... I don't have FSX installed.

Everything is installing ok in terms of the Modules, but no matter what I do I just cannot get my Registration

completed for P3D.

I have gone through the install numerous times, and the installer tells me that the registation was accepted, but when I go into P3D, the FSUIPC is unregistered. :neutral:

....the reason, no FSUIPC.key is updating into the P3D Modules folder.

Here is the log file :-

********* FSUIPC4, Version 4.86 by Pete Dowson *********

Running inside Prepar3D on Windows 7

Module base=614D0000

User Name=""

User Addr=""

FSUIPC4 not user registered

WIDEFS7 not user registered, or expired

47 System time = 15/02/2013 17:40:57

47 FLT path = "C:\Users\David\Documents\Prepar3D Files\"

47 Trying C:\Program Files (x86)\Lockheed Martin\Prepar3D\Modules\SimConnectP3D.dll

47 Found it: trying to connect

47 FS path = "C:\Program Files (x86)\Lockheed Martin\Prepar3D\"

437 LogOptions=00000000 00000001

437 SIM1 Frictions access gained

437 Wind smoothing fix is fully installed

437 G3D.DLL fix attempt installed ok

437 SimConnect_Open succeeded: waiting to check version okay

437 Trying to use SimConnect Prepar3D

3323 Running in "Lockheed Martin® Prepar3D®", Version: 1.4.4747.0 (SimConnect: 1.4.0.0)

3323 Initialising SimConnect data requests now

3323 FSUIPC Menu entry added

3354 C:\Users\David\Documents\Prepar3D Files\Default.flt

3354 C:\Program Files (x86)\Lockheed Martin\Prepar3D\SimObjects\Airplanes\Mooney_Acclaim\Mooney_Acclaim.AIR

32745 System time = 15/02/2013 17:41:30, Simulator time = 16:05:56 (15:05Z)

36941 Starting everything now ...

38251 Advanced Weather Interface Enabled

99045 Sim stopped: average frame rate for last 66 secs = 29.8 fps

143739 System time = 15/02/2013 17:43:21, Simulator time = 16:07:08 (15:07Z)

143739 *** FSUIPC log file being closed

Average frame rate for running time of 68 secs = 29.6 fps

G3D fix: Passes 8340, Null pointers 0, Bad pointers 0, Separate instances 0

Memory managed: 31 Allocs, 31 Freed

********* FSUIPC Log file closed ***********

Can anyone please help?

Thanks.

Edited by David Rogers
Link to comment
Share on other sites

...still pulling my hair out here.

Because some other posts alluded to the fact that can be 'permissions' related (on Win 7 64 bit), I uninstalled P3d and reinstalled it away from the Program Files folder, (in C:\Lockheed Martin\Prepar3D), and still when I run the FSUIPC4 installer, and enter my registrations, it just will not place a FSUIPC.KEY file into my modules folder.

I have my licence details in a text doc - can anyone tell me the 'format' of the key file so that I can create one with my licence details in, and manually place it into the Prepar3D\Modules folder, because the FSUIPC Installer just cannot execute this.....

Thanks again for any help.

Link to comment
Share on other sites

Hi Paul,

I thought exactly the same, and did a search for the FSUIPC.KEY but it's not on my system.

The issue seems to be because I have P3D but not FSX installed, the FSUIPC installer seems not to work properly when the search box comes up that is looking for FSX, and I cancel it. (even though it does go on to let me enter the registration - but it just does not result in the creation of a FSUIPC.KEY file :( ).

I've seen this a few times, from a Google search but have been unable to find a solution.

Ps... My install log is in the "spoiler" in the first post - a normal install, just showing no registration in the Modules folder.

I can give my licence details to Pete when he's back and perhaps he can create a FSUIPC.KEY that I can place in the Modules folder.

I only bought P3D today and absolutely everything else has gone perfectly - but I have been on for 4 hours with this FSUIPC registration problem, and have tried 3 full un/re-installs of P3D, and countless install attemptes for FSUIPC.

I have read all instructions, am using the very latest FSUIPC, a valid FSUIPC4 licence key bought from Simmarket, and a version of P3D bought an uninstalled today.

I've been using FS for 20 years and just cannot get my head around this one.

Link to comment
Share on other sites

Hi Paul,

Mmm, I have no FSUIPC4 Install.log in the Modules folder ...... probably indicative of this strange problem.

Each time I attempt a fresh install, I get these files in the Modules folder:-

FSUIPC Documents (folder)

FSUIPC4.DLL

FSUIPC4 (cfg)

FSUIPC log

SimConnectP3D.dll

........ nothing else, no install log, no key (despite entering a registration into the installer, and despite being told the code was accepted and confirmed.

I am seeing FSUIPC in the "Addons" menu in P3d, but obviously, it is the unregistered version. :(

Link to comment
Share on other sites

Is this something to do with having two .exe files in your P3D folder? If you use FS Estonia migration tool, you will have FSX.exe and Prepar3d.exe in your root folder. Try running P3D.exe and check to see if your FSUIPC is registered and you get all the lovely functionality, then close that and check out the fsx.exe by running that, and check the FSUIPC registration status.

I had this very problem, in that I ran the fsx.exe first, and saw no registration, despite the FSUIPC and WideFS 'check registration' routines running perfectly well on installation, and then found that by running both exe files one after the other, the FSUIPC registration became recognised by both versions.

I hope this may help,

Edited by gliderman
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.