Jump to content
The simFlight Network Forums

Saitek ProFlight Multi Panel and FSUIPC 4.852


 Share

Recommended Posts

I have installed FSUIPC 4.852 into my FSX installation, which includes several bits of hardware including a Saitek Pro Flight Multi Panel. Unfortunately all is not well with this installation. In essence, without FSUIPC installed (e.g. rename .DLL to .DLX) the system works perfectly as expected. However with the system installed, the Multi Panel does not behave as expected. For example if I press the AP button to engage the autopilot, some random action occurs such as the Vertical Speed autopilot being selected. If I then press AP again, some other lights will come on. Basically it makes the entire Multi Panel unusable. If I click on the graphics of the autopilot on the screen however, the correct commands occur i.e. click on AP and the autopilot engages. (Interestingly the Saitek mirrors this OK.) However if I then press the now lit AP button on the Multi Panel, some new random thing will happen such as the IAS will set to some random value. So as things are at the moment, if I wish to fly using an autopilot, I have to disconnect FSUIPC. Does anyone have a fix for this? What additional information can I provide? Thanks!

Link to comment
Share on other sites

I have installed FSUIPC 4.852 into my FSX installation, which includes several bits of hardware including a Saitek Pro Flight Multi Panel. Unfortunately all is not well with this installation. In essence, without FSUIPC installed (e.g. rename .DLL to .DLX) the system works perfectly as expected. However with the system installed, the Multi Panel does not behave as expected. For example if I press the AP button to engage the autopilot, some random action occurs such as the Vertical Speed autopilot being selected. If I then press AP again, some other lights will come on. Basically it makes the entire Multi Panel unusable.

Two things:

1. Version 4.852 is out of date and not supported. Please update to the current release, 4.86.

2. FSUIPC does nothing unless you tell it to, so it sounds like you have lots of incorrect assignments, possibly dating from a previous hardware add-on? Detelte the FSUIPC4.INI file from your FS Mondules folder, and start afresh.

Pete

Link to comment
Share on other sites

My typical luck, I bought this a few days before the update. Anyway, I completely removed the older 4.852, and downloaded 4.86 from http://www.schiratti.com/dowson.html. I confirmed 4.86 is installed OK, and reconfigured everything. And, after a preliminary test of a few of the planes, it does now appear to be working. Many thanks for the quick turnaround time :-) (Too bad I didn't get notified about the new version...)

Link to comment
Share on other sites

(Too bad I didn't get notified about the new version...)

Sorry, no notifications. Just check here in the Download Links subforum whenever you have cause to ask a question or report a problem. Last year there were over 50 updates, and you don't need every one, but it always helps to make sure you are up to date when requesting support, as then we are both on the same page, so to speak. ;-)

As an example, there's already a 4.861, but it is for a minor addition (a thread near here carries it, only, at present).

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.