Jump to content
The simFlight Network Forums
Sign in to follow this  
jinzhu1912

Why I can not read the data of Hydraulics

Recommended Posts

I was doing my graduation project.I need the data of Hydraulics to program the HYD page of ECAM of A320.

I find the data of Hydraulics was stored in the 2B08、2B1C、2C08、2C1C,but I don't get the data that I need.

Share this post


Link to post
Share on other sites

I was doing my graduation project.I need the data of Hydraulics to program the HYD page of ECAM of A320.

I find the data of Hydraulics was stored in the 2B08、2B1C、2C08、2C1C,but I don't get the data that I need.

Is the aircraft a default FS aircraft? Are you reading them correctly? I think they are 64-bit (double) floating point values.

You don't even say which version of FS you are talking about, nor the version number of FSUIPC.

Pete

Share this post


Link to post
Share on other sites

My aircraft is Wilco Airbus A320.I use FS9.The version number of my FSUIPC is 3.93.Now I have read the Hydraulics pressure psf correctly,but the Hydraulics reservoir pct is not right. My way is (double&)readblock2B00[0x08],(double&)readblock2B00[0x1c],I think it's right.

Share this post


Link to post
Share on other sites

I write wrong.but the Hydraulics reservoir pct is 1.008495845e-120.

You still have not stated what aircraft you are using nor the version of FS nor version of FSUIPC! How do you expect any help?

Use logging or FSInterrogate to wrok out what you are doing wrong!

Pete

Share this post


Link to post
Share on other sites

My aircraft is Wilco Airbus A320.I use FS9.The version number of my FSUIPC is 3.93.Now I have read the Hydraulics pressure psf correctly,but the Hydraulics reservoir pct is not right. My way is (double&)readblock2B00[0x08],(double&)readblock2B00[0x1c],I think it's right.

  • 0

Share this post


Link to post
Share on other sites

My aircraft is Wilco Airbus A320.I use FS9.

ALWAYS test on a default aircraft. Many add-on aircraft implement their own subsystems with their own values. FSUIPC's offsets listed are only FS's.

The version number of my FSUIPC is 3.93.

The is very old and I cannot support it. you must use 3.999z if you want support.

Pete

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.