Jump to content
The simFlight Network Forums
Russellmjohnston

MyTraffic 5.4c Ntdll.dll crash

Recommended Posts

Hello,

 

Since I installed 5.4c, I have been having ntll.dll crashes very frequently in any airplane (default C172 and no weather to 737NGX with REX Wx engine)  Before 5.4c, I was running 5.4b at 35% airline and 20% GA, and 100% UT2, and never had a crash.   I did a bunch of trial and error, and finally narrowed it down to MyTraffic.  Once I disabled it in the scenery library, I no longer had ntdll.dll crashes (even after slewing around the world at 40,000kts for hours).  I even used settings such as 10% Airline and it still ntdll.dll crashes.

 

As an example, last weekend I did KPHX-KORD-KBOS in the NGX.  While sitting at the gate, I CTD'd after 10 minutes (Airline at 40%, no GA).  Reloaded, took off, and it ntdll.dll'd around 10,000 feet.  Thankfully, I saved the flight and relaoded it during the climb and it crashed every single time at the same point (around 5 minutes in).  I disabled Mytraffic and no crash.  After disabling it, I was able to fly for the 6 hours real time with no crash.

 

Just reactivated MyTraffic around KPHX a few minutes ago, slewed from PHX to PAN (50nm northeast of PHX) and had the traffic bar open to see how many airplanes were up.  I had a ntdll error immediately and only had ~15 airplanes on the traffic bar (only had it at 20% density).

 

I do have the saved flight -- would be more than happy to send it to you if it helps you out.

 

System is:

i7-2660k @4.7

8GB

SLI GTX 580s

win7 64bit

 

Russell

Share this post


Link to post
Share on other sites

The important message is that it is not in the GA parts, so must be an airliner or a Military. Could you please for the moment rename MyTrafficMil.bgl to MyTrafficMil.bgl.passive and check if you still get the crashes, that would again narrow it.

Share this post


Link to post
Share on other sites

Yesterday it looked as if I got crashes at KSEA with all aircraft installed, and none with B735-B738 pulled out of the aircraft Folder, but checking only with these it runs stable.

Share this post


Link to post
Share on other sites

Was getting an occasional ntdll.dll crash with airlines only or GA only (no military), but only if I overloaded the sim.  Definitely seemed more stable without military, but the ntdll error was still present.

 

Swapped to 2012 schedules and did PHX - IAH, no ntdll crash at 32% airline (did OOM at the end but that's not MyTraffic's fault).

 

Will try the livery fix mentioned in the other thread.

 

Thanks!

 

Russell

Share this post


Link to post
Share on other sites

And what do we do if we use the LIVE schedule?

I would prefer to use UT2 for main lines and My Traffic for Military and Cargo only.

I've applied the patch from the other post, have yet to test flight.

 

Burkhard, have you found which file is causing these ntll.dll crashes yet?

I only use the Live schedule if that helps.

Share this post


Link to post
Share on other sites

Hi Burkhard, is there a newer version of the patches that you mentioned in the other thread? Because I remember installing those and still having issues around KPHX with the 2013 schedules.

 

Thank you :-)

-E

Share this post


Link to post
Share on other sites

I'm still getting random crashes due to a dodgy military element.

I only use the Live schedules and the crashes are repeatable.

It would be great if this could be fixed.

Share this post


Link to post
Share on other sites

Could you please do the following:

rename the file MyTraffic\scenery\MyTrafficCommercial.bgl to MyTrafficCommercial.bgl.passive - do you then still get instabilities? This would help to pin the problem down.

 

Also, did you install MyTraffic 5.4c by the full installer, or by an update...

Share this post


Link to post
Share on other sites

Full installer.

I renamed and did a very quick test flight with FSX set to 50% (this would normally provoke a crash) and the flight loaded and flew (10 minutes) ok.

Will try a longer flight tomorrow from NAS Fallon, no more time tonight.

Share this post


Link to post
Share on other sites

Burkhard, I just joined this thread, since I am having the same problem even with 2012 schedules. I reinstalled my 5.4c update, did the deletes, applied the patch...........and still have the problem. I terminated right after the scenery/aircraft load message, did not even get into the flight.

 

Here are links for:

 

My fsx.cfg: https://app.box.com/s/h6n1x337hokbmcs1vyt4

 

My PC: https://app.box.com/s/fm5q7xb7fyjibjbldaqj

 

My Simulator: https://app.box.com/s/mz6wiwd9bq9hs4towibb

 

and

 

my crash report: https://app.box.com/s/b0vk6e1ju2vccncslfiw

 

If I turn the airline traffic to zero everything is OK.

 

Regards,

 Bob

Share this post


Link to post
Share on other sites

Burkhard, I just joined this thread, since I am having the same problem even with 2012 schedules. I reinstalled my 5.4c update, did the deletes, applied the patch...........and still have the problem. I terminated right after the scenery/aircraft load message, did not even get into the flight.

 

Here are links for:

 

My fsx.cfg: https://app.box.com/s/h6n1x337hokbmcs1vyt4

 

My PC: https://app.box.com/s/fm5q7xb7fyjibjbldaqj

 

My Simulator: https://app.box.com/s/mz6wiwd9bq9hs4towibb

 

and

 

my crash report: https://app.box.com/s/b0vk6e1ju2vccncslfiw

 

If I turn the airline traffic to zero everything is OK.

 

Regards,

 Bob

 

Interesting results....I flew the exact same flight with the exact same settings except that my MT traffic was reduced from 40 to 20. The flight went fine UNTIL the very end. After landing and ending FSX I got the same ntdll.dll error....................

Share this post


Link to post
Share on other sites

And all this makes no sense at all, that could be inside MyTraffic, unless there is an effect like that your install has passes some undocumented limit of FSX concerning the number of textures or config entries...

 

Could you please move a bunch of aircraft folders that you consider irrelevant to your flying out of the MyTraffic\aircraft folder and check if this helps - I'm fighting against this Problem now since 8 months, it has stolen all development time of this year and never anything could be isolated as reproducable...

Share this post


Link to post
Share on other sites

Burkhard, I did the deletes and executed the patch as you suggested. I can get my traffic slider for aircraft to 40 without a problem, anything over 40 causes ntdll.dll crash. I have not moved aircraft out of the aircraft folder, as you suggested in this thread. But will do that with some tests of the same flight plans. Thanks

 

Bob

Share this post


Link to post
Share on other sites

Burkhard, I have moved 8 aircraft folders out of MyTraffic/Aircraft to a temporary desktop folder. I flew the same flight again with slider at 40, and the delete/patch54c but still got the CTD. I will keep experimenting but I can not seem to find a correlation to any particular setting/s. There have been other AMD/ATI driver problems (random artifacts, etc) so I wonder if there is a driver problem? I am running 12.8 (display driver 8.982.0.0). If I drop the aircraft slider to less than 40 than it seems less likely that I will get a CTD. If I remove the MTX aircraft completely and use the default AI I do not get a CTD even with the slider set to 100!

 

Regards,

 Bob

Share this post


Link to post
Share on other sites

I'm not sure it's vid card related because I have been having issues also with NV GTX560 since I went to c.

Share this post


Link to post
Share on other sites

This is related to a certain aircraft or flight which is why it's so hard to track down.

I'm pretty sure it's cargo or military as that's all I use.

It's also something that's changed since 4.b as I never had this problem before c.

Share this post


Link to post
Share on other sites

ALL: I have uninstalled 5.4C, reinstalled 5.4B, rebuilt the MyTraffic scenery in FSX, reset my FSX aircraft slider from 40 to 50..............

 

I flew the same slight I have flown the last 6 times when I got CTD's and this time NO CTD's successful flight except they assigned me a gate which already had an aircraft.  :???:

Share this post


Link to post
Share on other sites

Hello,

 

I bought the excellent MyTRAFFIC version MTXV54c in february 2014. Until today I used it with VoxAtc, so with traffic density to zero (no problem, no crash).

 

There are 2 days I used it with native Atc via MCE during a little flight plan from Lee Vining to Lake Tahoe via three others airports with traffic density to 40 (airlines and GA) and schedule spring 2013.

 

And...  got the Ntdll.dll crash every time ! I noticed it was not allways at the same place (I made 6 or 7 tests). After reading the forum, I used the schedule autumn 2012 and no more crash !

 

FSX Acceleration, MyTrafficX Pro MTXV54c,  MCE, Gsx, ORBX NCA, Rex textures and weather, Cessna A2A.

Intel i7-4770K CPU @ 3.50Ghz, 16,0 Go, Nvidia Gforce GTX 770 2,0 Go, Windows 7 Ultimate 64

 

Regards,

 

Richard Portier

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.