Jump to content
The simFlight Network Forums
Sign in to follow this  
pappyhep

Registration problem

Recommended Posts

Hi Pete -

 

Can't get registration to 'take' in p3d2.  Used FSUIPS forever and never had a problem before.  It says registration successful code 00, but no workee in p3d...says not registered.  This renders my sim unusable because I rely on FSUIPC for everything it can do.  order no. 320993 for FSUIPC and 1024446 for widefs7.  I wait patiently for your reply...not really.

 

Thanks for a great program,

 

Don Hepler

pappyhep@hotmail.com

Share this post


Link to post
Share on other sites
Can't get registration to 'take' in p3d2.  Used FSUIPS forever and never had a problem before.  It says registration successful code 00, but no workee in p3d...says not registered.

 

What version of FSUIPC? Please try using the latest installer. The only reason found for the problem you describe is a failure to copy the KEY file generated in a P3D version 1.4 folder to a version 2.0 folder when there's no FSX installation. That was fixed a couple of releases ago. The current release is 4.927.

 

Pete

Share this post


Link to post
Share on other sites

Pete - Tried latest version still no joy.  Get error message that registration was cancelled or doesn't check correctly.  Tried entering pw manually but that still didn't work, same message.  I have re-installed P3d2 without any change in results.  I do not have FSX installed and deleted my old P3d 1.4 files (before problem started).  Could I have deleted the key file?   Kinda' stumped here.

Don 
 

Share this post


Link to post
Share on other sites

Pete - Tried latest version still no joy.  Get error message that registration was cancelled or doesn't check correctly.

 

Where do you see that? Is the registration accepted in the dialogue when you enter it? If not then you are getting something wrong. every part -- name, address, key -- must be correct.

 

Tried entering pw manually but that still didn't work

 

How were you entering your details before?

 

I have re-installed P3d2 without any change in results.

 

It's nothing to do with that.

 

I do not have FSX installed and deleted my old P3d 1.4 files (before problem started).

 

Deleting P3D is not the same as uninstalling it. That's probably where it is all going wrong, but I can't tell a thing without seeing the Install log file. Paste it here please.

 

Could I have deleted the key file?

 

Well, if you deleted the Modules folder, yes, of course you did. All you needed to do was copy your INI and KEY fies from P3D 1.4 to P3D v2.

 

I think the problem will be that non-uninstalled copy of P3D 1.4. The registry will still be setup for that version.

 

But I can tell from the Install log file.

 

Pete

Share this post


Link to post
Share on other sites

Here 'tis, Buddy

 

Installer for FSUIPC4.DLL version 4.927a
 
Looking in registry for FSX install path:
     HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\10.0
     Parameter"SetupPath"
Not there, so looking in:
     HKEY_CURRENT_USER\FSX
     Parameter"AppPath"
... NOT found! ...
Looking in registry for ESP install path:
     HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft ESP\1.0
     Parameter"SetupPath"
Not there, so looking in:
     HKEY_CURRENT_USER\ESP
     Parameter"AppPath"
... NOT found! ...
Looking in registry for Prepar3D install path:
     HKEY_LOCAL_MACHINE\SOFTWARE\LockheedMartin\Prepar3D
     Parameter"SetupPath"
Not there, so looking in:
     HKEY_CURRENT_USER\Prepar3D
     Parameter"AppPath"
... NOT found! ...
Looking in registry for Prepar3D v2 install path:
     HKEY_LOCAL_MACHINE\SOFTWARE\Lockheed Martin\Prepar3D v2
     Parameter"SetupPath"
... >>>  OK! FOUND Prepar3D v2!  <<< ...
===========================================================
 
INSTALLATION FOR Prepar3D v2:
SetupPath="C:\Program Files (x86)\Lockheed Martin\Prepar3D v2\"
Checking version of the Prepar3D v2 EXE:
... Version 2.0.9448.0  (Need at least 1.0.677.0)
Checking compatibility with installed SimConnect:
    Found SimConnect build 60905 (Original)
    Found SimConnect build 195 (ESP Orig)
    Found SimConnect build 61242 (SP1 May07)
    Found SimConnect build 61259 (Acc/SP2 Oct07)
Checking if there's already a version of FSUIPC4 installed in:
       C:\Program Files (x86)\Lockheed Martin\Prepar3D v2\Modules\FSUIPC4.DLL
... Version 4.927a found.
Prepar3D v2 Modules folder already exists.
Okay -- installed FSUIPC4 into "C:\Program Files (x86)\Lockheed Martin\Prepar3D v2\Modules\FSUIPC4.DLL"
Looking for the current user's Application Data path: 
... found as "C:\Users\Pappys\AppData\Roaming"
Now finding \Lockheed Martin\Prepar3D v2\Prepar3D.CFG for all users, including this one
Looking in "C:\Users\Pappys\AppData\Roaming"
Found Prepar3D.CFG in "C:\Users\Pappys\AppData\Roaming\Lockheed Martin\Prepar3D v2\Prepar3D.CFG"
Now checking DLL.XML ...
... There is a previous DLL.XML, checking for FSUIPC4 section.
... FSUIPC4 section already exists but will be replaced.
     (for FSUIPC4, without Loader)
... FSUIPC4 section of DLL.XML written okay
Now checking for a SimConnect.XML file ...
... No SimConnect.XML file found. This is okay.
Looking in "C:\Users\Pappys\Application Data\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Contacts\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Cookies\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Desktop\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Documents\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Downloads\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Dropbox\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Favorites\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\InstallAnywhere\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Links\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Local Settings\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Music\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\My Documents\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\NetHood\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\New folder\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\New folder (2)\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Pictures\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\PrintHood\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Recent\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Saved Games\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Searches\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\SendTo\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\SkyDrive\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Start Menu\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Templates\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Videos\Roaming"
 ... No Prepar3D.CFG there
"Modules\FSUIPC Documents" folder already exists.
Now installing the Prepar3D SimConnect interface for FSUIPC4 into the "Modules" folder:
   Installed "SimConnectP3D2.dll" okay
Now installing additional files into the "Modules\FSUIPC Documents" folder:
   Installed "FSUIPC4 User Guide.pdf" okay
   Installed "FSUIPC4 for Advanced Users.pdf" okay
   Installed "FSUIPC4 History.pdf" okay
   Installed "List of FSX and P3D controls.pdf" okay
   Installed "FSUIPC Lua Library.pdf" okay
   Installed "FSUIPC Lua Plug-Ins.pdf" okay
   Installed "Lua License.pdf" okay
   Installed "Lua Plugins for VRInsight Devices.pdf" okay
   Installed "LuaFileSystem.pdf" okay
   Installed "Example LUA plugins.zip" okay
   Installed "Offset Mapping for PMDG 737NGX.pdf" okay
   Installed "FSUIPC4 Offsets Status.pdf" okay
===========================================================
 
All installer tasks completed.
Registration check for FSUIPC4 was cancelled or failed! (result code 10)
 
*************** End of Install Log ***************

Share this post


Link to post
Share on other sites

BTW Pete - In the years I have been using FSUIPC and watching your responses to other peoples problems, I have been very impressed with your attitude and alacrity.  Man you must not have time to do anything else.  If there was an award for customer service, you would get it hands down.

 

Best to you and yours.especially during the holidays.

 

Don Hepler

Pappyhep@hotmail.com

A retired Arizona desert rat

Share this post


Link to post
Share on other sites

Is this the message you were telling me about:

 

Registration check for FSUIPC4 was cancelled or failed! (result code 10)

 

?

 

Did you enter your name, email and key when asked? If not, then you need to do that! If you did, was it accepted?

 

I'm trying to work out what you are doing and what you see. It isn't easy to understand from what you tell me.

 

Regards

Pete

Share this post


Link to post
Share on other sites

Tried again.  Results:

Installer for FSUIPC4.DLL version 4.927a
 
Looking in registry for FSX install path:
     HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator\10.0
     Parameter"SetupPath"
Not there, so looking in:
     HKEY_CURRENT_USER\FSX
     Parameter"AppPath"
... NOT found! ...
Looking in registry for ESP install path:
     HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft ESP\1.0
     Parameter"SetupPath"
Not there, so looking in:
     HKEY_CURRENT_USER\ESP
     Parameter"AppPath"
... NOT found! ...
Looking in registry for Prepar3D install path:
     HKEY_LOCAL_MACHINE\SOFTWARE\LockheedMartin\Prepar3D
     Parameter"SetupPath"
Not there, so looking in:
     HKEY_CURRENT_USER\Prepar3D
     Parameter"AppPath"
... NOT found! ...
Looking in registry for Prepar3D v2 install path:
     HKEY_LOCAL_MACHINE\SOFTWARE\Lockheed Martin\Prepar3D v2
     Parameter"SetupPath"
... >>>  OK! FOUND Prepar3D v2!  <<< ...
===========================================================
 
INSTALLATION FOR Prepar3D v2:
SetupPath="C:\Program Files (x86)\Lockheed Martin\Prepar3D v2\"
Checking version of the Prepar3D v2 EXE:
... Version 2.0.9448.0  (Need at least 1.0.677.0)
Checking compatibility with installed SimConnect:
    Found SimConnect build 60905 (Original)
    Found SimConnect build 195 (ESP Orig)
    Found SimConnect build 61242 (SP1 May07)
    Found SimConnect build 61259 (Acc/SP2 Oct07)
Checking if there's already a version of FSUIPC4 installed in:
       C:\Program Files (x86)\Lockheed Martin\Prepar3D v2\Modules\FSUIPC4.DLL
... Version 4.927a found.
Prepar3D v2 Modules folder already exists.
Okay -- installed FSUIPC4 into "C:\Program Files (x86)\Lockheed Martin\Prepar3D v2\Modules\FSUIPC4.DLL"
Looking for the current user's Application Data path: 
... found as "C:\Users\Pappys\AppData\Roaming"
Now finding \Lockheed Martin\Prepar3D v2\Prepar3D.CFG for all users, including this one
Looking in "C:\Users\Pappys\AppData\Roaming"
Found Prepar3D.CFG in "C:\Users\Pappys\AppData\Roaming\Lockheed Martin\Prepar3D v2\Prepar3D.CFG"
Now checking DLL.XML ...
... There is a previous DLL.XML, checking for FSUIPC4 section.
... FSUIPC4 section already exists but will be replaced.
     (for FSUIPC4, without Loader)
... FSUIPC4 section of DLL.XML written okay
Now checking for a SimConnect.XML file ...
... No SimConnect.XML file found. This is okay.
Looking in "C:\Users\Pappys\Application Data\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Contacts\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Cookies\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Desktop\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Documents\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Downloads\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Dropbox\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Favorites\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\InstallAnywhere\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Links\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Local Settings\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Music\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\My Documents\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\NetHood\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\New folder\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\New folder (2)\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Pictures\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\PrintHood\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Recent\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Saved Games\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Searches\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\SendTo\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\SkyDrive\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Start Menu\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Templates\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Pappys\Videos\Roaming"
 ... No Prepar3D.CFG there
"Modules\FSUIPC Documents" folder already exists.
Now installing the Prepar3D SimConnect interface for FSUIPC4 into the "Modules" folder:
   Installed "SimConnectP3D2.dll" okay
Now installing additional files into the "Modules\FSUIPC Documents" folder:
   Installed "FSUIPC4 User Guide.pdf" okay
   Installed "FSUIPC4 for Advanced Users.pdf" okay
   Installed "FSUIPC4 History.pdf" okay
   Installed "List of FSX and P3D controls.pdf" okay
   Installed "FSUIPC Lua Library.pdf" okay
   Installed "FSUIPC Lua Plug-Ins.pdf" okay
   Installed "Lua License.pdf" okay
   Installed "Lua Plugins for VRInsight Devices.pdf" okay
   Installed "LuaFileSystem.pdf" okay
   Installed "Example LUA plugins.zip" okay
   Installed "Offset Mapping for PMDG 737NGX.pdf" okay
   Installed "FSUIPC4 Offsets Status.pdf" okay
===========================================================
 
All installer tasks completed.
Registration for FSUIPC4 was successful! (result code 00)
 
*************** End of Install Log ***************
 
PW was entered by copy/paste.  Opened P3D2.  Addon had fsuipc listed in square box.  When clicked it brought up unregistered version of fsuipc.
 
Fsuipc4.exe.log 
********* FSUIPC4, Version 4.927a by Pete Dowson *********
Running inside Prepar3D v2 on Windows 7
... Prepar3D has been renamed as "prepar3d.exe"
Module base=53F70000
User Name=""
User Addr=""
FSUIPC4 not user registered
WIDEFS7 not user registered, or expired
      109 System time = 18/12/2013 10:48:17
      109 FLT path = "C:\Users\Pappys\Documents\Prepar3D v2 Files\"
      109 Trying C:\Program Files (x86)\Lockheed Martin\Prepar3D v2\Modules\SimConnectP3D2.dll
      109 Found it: trying to connect
      125 FS path = "C:\Program Files (x86)\Lockheed Martin\Prepar3D v2\"
      608 LogOptions=00000000 00000001
      608 SIM1 Frictions access gained
      608 Wind smoothing fix is fully installed
      608 SimConnect_Open succeeded: waiting to check version okay
      608 Trying to use SimConnect Prepar3D
    11778 Running in "Lockheed Martin® Prepar3D® v2", Version: 2.0.9448.0 (SimConnect: 2.0.0.0)
    11778 Initialising SimConnect data requests now
    11778 FSUIPC Menu entry added
    11794 C:\Users\Pappys\Documents\Prepar3D v2 Files\Metro.FXML
    11794 C:\Program Files (x86)\Lockheed Martin\Prepar3D v2\SimObjects\Airplanes\RAZBAM_MetrolinerIII\FS_Metroliner_III.AIR
    63882 System time = 18/12/2013 10:49:20, Simulator time = 13:54:08 (17:54Z)
    68890 Starting everything now ...
    70060 Advanced Weather Interface Enabled
   102352 System time = 18/12/2013 10:49:59, Simulator time = 13:54:33 (17:54Z)
   102352 *** FSUIPC log file being closed
Average frame rate for running time of 26 secs = 42.1 fps
Memory managed: 22 Allocs, 22 Freed
********* FSUIPC Log file closed ***********
 
There is a FSUIPC4.key file of 1KB, type: registration Entries
 
Do you suppose if I just bought another FSUIPC (I would have no problem with doing that) it would work okay or do you think it will have the same results?
 
I love a challenge,
Don 
 

Share this post


Link to post
Share on other sites

 
There is a FSUIPC4.key file of 1KB, type: registration Entries

 
Do you suppose if I just bought another FSUIPC (I would have no problem with doing that) it would work okay or do you think it will have the same results?

 

 

No, don't do that. I see the results, this time, of entering your key was logged as "successful".

 

And you say there IS a KEY file -- in the P3Dv2 modules folder? That is actually a Text file, and it contains your name, email and Key. That's all. Don't post it here, but load it into, say, Notepad, and check it. It that is correct. If it is, and it IS in the installation of P3D you are actually using (i.e. in C:\Program Files (x86)\Lockheed Martin\Prepar3D v2\Modules, then I am stumped. The last time we had anything like this it (eventually) turned out that the chap was actually booting FS from an entirely different installation which wasn't known to the Registry and therefore not updated by FSUIPC's installer.

 

You DID run the installer with right-clicking and selecting "run as administrator", as instructed, didn't you? Windows has an awful habit of protecting all Program Files (x86) files  frombeing changed, and even shows tyou aliassed versions of the folders in Explorer.

 

Regards

Pete

Share this post


Link to post
Share on other sites

Pete -

 

Yup.  Key file is correct.  Maybe I'll just delete everything (P3D2, FSUIPC) and start over again.  BTW, I also have widefs pw.  Must I enter them both to get fsuipc to run?  Have only been using fsuipc pw because I am not currently using widefs.

 

Guess I'll start over unless I hear from you.

 

Don

Share this post


Link to post
Share on other sites
Key file is correct.

 

The key file is in the correct Modules folder, and it is correct (i.e. it matches what you entered), yet FSUIPC still appears unregistered?  That's only ever happened before when the computer system date is wrong, when it precedes the registration date.

 

If you haven't disabled UAC, then the modules folder you are looking at may not be the real one. That's one problem of installing into Program Files. Best to switch UAC off or always instal in separate folders -- like C:\P3D, nice and short and easy!

 

Else run Explorer by right-clicking on it and selecting "run as administrator". That should enable you to see the real folder.

 

Maybe you should ZIP up the KEY file and send it to me at petedowson@btconnect.com.

 

Maybe I'll just delete everything (P3D2, FSUIPC) and start over again.

 

No, I don't think that's a good idea. in any case, NEVER delete P3D, use the proper uninstall in the Control Panel.

 

BTW, I also have widefs pw.  Must I enter them both to get fsuipc to run?

 

No.

 

Pete

Share this post


Link to post
Share on other sites

UAC has been disabled forever.  Key file on the way.

 

Ach! never mind. I just spotted the problem. In your FSUIPC4 log file, it was there all the time:

 

.. Prepar3D has been renamed as "prepar3d.exe"

 

This message should never appear unless you've renamed the EXE file in the main folder. It expects it to be "Prepar3D.exe" and if it is not it tries to match the new name in its own files -- the KEY, INI and LOG files, in fact.

 

Can you check, please? The message above puzzles me, as it seems to imply that it was renamed with the original name (just lower case 'p' instead of 'P', which shouldn't matter ... though I'd need to check that).

 

This action in fSUIPC derives from facilities included years ago to allow different FS CFG files to be used with different matching FSUIPC INI files. The different CFG files were named after thedfferently named EXE files. Everything sort of ties together.

 

[LATER] No, renaming Prepar3D.exe as prepar3d.exe doesn't make any difference here.

 

[LATER STILL]

It looks like that message means it sees the Prepar3D program as being named

 

Prepar3D.exe.exe

 

which is most peculiar indeed. (FSUIPC strips off whatever follows the last '.' before putting the name in the message).

 

Pete

Share this post


Link to post
Share on other sites

Pete - I knew you would figure it out!  There were indeed two prepar3D files, one exe and one .exe.exe.  When I renamed the one with the double exe's to oldPrepar3D.exe.exe and opened Prepar3D.exe, it worked.  Hope your family doesn't find it too hard living with a genius!

 

Thanks for all your time and all the best,

Hep

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.