Jump to content
The simFlight Network Forums
Sign in to follow this  
enzo64

FSUIPC4 version 4.9.2.7.

Recommended Posts

I have updated to the latest FSX version and I cannot  go passed the splash screen.........when I delete the .DLL file ,FSX loads correctly.

 

 

 

Log Name:      Application

Source:        Application Error

Date:          12/17/2013 5:53:46 PM

Event ID:      1000

Task Category: (100)

Level:         Error

Keywords:      Classic

User:          N/A

Computer:      Enzo64-PC

Description:

Faulting application name: fsx.exe, version: 10.0.61472.0, time stamp: 0x475e17d3

Faulting module name: FSUIPC4.dll, version: 4.9.2.7, time stamp: 0x52b0393a

Exception code: 0xc0000005

Fault offset: 0x000138fc

Faulting process id: 0x81c

Faulting application start time: 0x01cefb7ac6cab016

Faulting application path: C:\Program Files (x86)\Microsoft Games\Flight Simulator X\fsx.exe

Faulting module path: C:\Program Files (x86)\Microsoft Games\Flight Simulator X\Modules\FSUIPC4.dll

Report Id: 15718c63-676e-11e3-906e-90e6bae88386

Event Xml:


  <System>

    <Provider Name="Application Error" />

    <EventID Qualifiers="0">1000</EventID>

    <Level>2</Level>

    <Task>100</Task>

    <Keywords>0x80000000000000</Keywords>

    <TimeCreated SystemTime="2013-12-17T22:53:46.000000000Z" />

    <EventRecordID>97990</EventRecordID>

    <Channel>Application</Channel>

    <Computer>Enzo64-PC</Computer>

    <Security />

  </System>

  <EventData>

    <Data>fsx.exe</Data>

    <Data>10.0.61472.0</Data>

    <Data>475e17d3</Data>

    <Data>FSUIPC4.dll</Data>

    <Data>4.9.2.7</Data>

    <Data>52b0393a</Data>

    <Data>c0000005</Data>

    <Data>000138fc</Data>

    <Data>81c</Data>

    <Data>01cefb7ac6cab016</Data>

    <Data>C:\Program Files (x86)\Microsoft Games\Flight Simulator X\fsx.exe</Data>

    <Data>C:\Program Files (x86)\Microsoft Games\Flight Simulator X\Modules\FSUIPC4.dll</Data>

    <Data>15718c63-676e-11e3-906e-90e6bae88386</Data>

  </EventData>

</Event>

Share this post


Link to post
Share on other sites

I have the same problem after installing vers. 4.927.

I had to revert to vers. 4.924a.

Are there any links for 4.922 or 4.926 to bypass the ASN problem?

Thanks ;)

Share this post


Link to post
Share on other sites

On the same boat here !!!!

 

Ouch!

 

Are you all using FSX SP1 or SP2, not Acceleration? Please let me know. I need to nail this.

 

Meanwhile please change the InterceptTextMenu parameter to 'No' instead of 'Yes'.

 

Pete

Share this post


Link to post
Share on other sites

Ouch!

 

Are you all using FSX SP1 or SP2, not Acceleration? Please let me know. I need to nail this.

 

Meanwhile please change the InterceptTextMenu parameter to 'No' instead of 'Yes'.

 

Pete

Peter, I'm using SP2

Share this post


Link to post
Share on other sites

Ouch!

 

Are you all using FSX SP1 or SP2, not Acceleration? Please let me know. I need to nail this.

 

Meanwhile please change the InterceptTextMenu parameter to 'No' instead of 'Yes'.

 

Pete

Peter,

SP2 here, no Accel

Share this post


Link to post
Share on other sites

Peter,

SP2 here, no Accel

 

Yes, right. I found a silly typo affecting SP2 only. The work-around above will fix it, or download 4.927a now available.

 

Sorry, It's been a very busy period what with ASN mods, P3Dv2 and Christmas with family coming looming, all just after a holiday! Oh, and I'm definitely getting senile!

 

Regards

Pete

Share this post


Link to post
Share on other sites

Yes, right. I found a silly typo affecting SP2 only. The work-around above will fix it, or download 4.927a now available.

 

Sorry, It's been a very busy period what with ASN mods, P3Dv2 and Christmas with family coming looming, all just after a holiday! Oh, and I'm definitely getting senile!

 

Regards

Pete

 

 

Thanks Peter......... your customer service is unbeatable!

Share this post


Link to post
Share on other sites

Hi!

After the new version of FSUPIC 4.927a was installed I thought the fatal error was gone, but after 5 hours of flight, FSX crashed.

I have these parameters to look at; (FSX with SP2)

 

<?xml version="1.0" encoding="UTF-16"?>

-<WERReportMetadata>

-<OSVersionInformation>

<WindowsNTVersion>6.1</WindowsNTVersion>

<Build>7601 Service Pack 1</Build>

<Product>(0x3): Windows 7 Home Premium</Product>

<Edition>HomePremium</Edition>

<BuildString>7601.18247.amd64fre.win7sp1_gdr.130828-1532</BuildString>

<Revision>1130</Revision>

<Flavor>Multiprocessor Free</Flavor>

<Architecture>X64</Architecture>

<LCID>1033</LCID>

</OSVersionInformation>

-<ProblemSignatures>

<EventType>APPCRASH</EventType>

<Parameter0>fsx.exe</Parameter0>

<Parameter1>10.0.61472.0</Parameter1>

<Parameter2>475e17d3</Parameter2>

<Parameter3>FSUIPC4.dll</Parameter3>

<Parameter4>4.9.2.7</Parameter4>

<Parameter5>52b0393a</Parameter5>

<Parameter6>c0000005</Parameter6>

<Parameter7>000138fc</Parameter7>

</ProblemSignatures>

-<DynamicSignatures>

<Parameter1>6.1.7601.2.1.0.768.3</Parameter1>

<Parameter2>1044</Parameter2>

</DynamicSignatures>

-<SystemInformation>

<MID>2169DFB7-A33F-4078-8B1D-949316B94156</MID>

<SystemManufacturer>System manufacturer</SystemManufacturer>

<SystemProductName>System Product Name</SystemProductName>

<BIOSVersion>3211</BIOSVersion>

</SystemInformation>

</WERReportMetadata>

 

Regards

ReidS

Share this post


Link to post
Share on other sites

Sorry, I had to move your post from "download Links" to the proper Support Forum". For now it is here, in the 4.927 link but i'd really preferred you start a thread with an appropriate title.

 

I can't really continue support in the SuForums which are designed as points ofrefference for users. All support needs to be carried out here, in the Support Forum.

 

After the new version of FSUPIC 4.927a was installed I thought the fatal error was gone, but after 5 hours of flight, FSX crashed.

 

Which "fatal error" are you talking about?

 

After 5 hours all the possible routes through FSUIPC have been thoroughly exercised! It doesn't change behaviour over time, so this is most puzzling.

 

I have these parameters to look at; (FSX with SP2)

 

Okay, I'll take a look. But I'd like some context, please. What is this really related to when you say you thought "the fatal error had gone"?

 

Pete

Share this post


Link to post
Share on other sites

Okay, I'll take a look. But I'd like some context, please. What is this really related to when you say you thought "the fatal error had gone"?

 

This offset in FSUIPC:

 

<Parameter7>000138fc</Parameter7>

 

indicates the exact same error as in 4.927 not 4.927a. I cannot see any way for the path through here could possibly be okay for 5 hours then suddenly change.

 

Are you absolutely sure those error details you posted are not from an earlier problem? They look identical to what you'd expect with 4.927, not 4.927a at all.

 

Maybe you'll just have to change the InterceptTextMenu parameter to 'No' instead of 'Yes'. Or I shall remove support for the facility in SP2 -- because i don't think there will ever be a way for me to see why things changed after 5 hours! That routine is being used at a rate of something close to 50 time per second in normal flight!

 

:sad:

Pete

Share this post


Link to post
Share on other sites

Hi Pete.

 

I've just bought the active sky next for FSX with SP2 and installed the latest FSUIPC version 4.927a and I cannot use the ASN. It pops out before I can't do anything.

 

Then I tried changing yes to no in  the InterceptTextMenu parameter to 'No' instead of 'Yes'. and it continues poping out.

 

What can I try?

 

Thanks a lot.

Share this post


Link to post
Share on other sites
I've just bought the active sky next for FSX with SP2 and installed the latest FSUIPC version 4.927a and I cannot use the ASN. It pops out before I can't do anything.

 

What does "pops out" mean? And what is it which "pops out"? And how does it stop you not doing anything?

 

If you have a problem with ASN you need to go to the ASN support Forum.

 

Then I tried changing yes to no in  the InterceptTextMenu parameter to 'No' instead of 'Yes'. and it continues poping out.

 

That parameter certainly has nothing to do with "popping out", whatever that may be. It also has nothing to do with ASN. Sorry.

 

Pete

Share this post


Link to post
Share on other sites

Sorry Pete.

 

I shall say that when I start ASNext it shows the ASN main screen and the when it goes to show the ASN config screen it "flicks" for less than a second and I cannot do anything and it leaves the ASN.

 

In the forum of HiFi they say that this problem was fixed with your FSUIPC 4.927a but in my case does not work. Some people in this thread had the same problem and solved it but this is not my case.

 

I also installed the ASN hotfix for FSX located in the web of ASN.

 

That's the reason because I posted in your forum.

 

What should I do?

Share this post


Link to post
Share on other sites
I shall say that when I start ASNext it shows the ASN main screen and the when it goes to show the ASN config screen it "flicks" for less than a second and I cannot do anything and it leaves the ASN.

In the forum of HiFi they say that this problem was fixed with your FSUIPC 4.927a but in my case does not work. Some people in this thread had the same problem and solved it but this is not my case.

 

I don't think that's right. The problem between ASN and FSUIPC was only that in versions between 4.924 and 4.925a, inclusive (fixed in 4.925b and later), things like wind smoothing and turbulence effects were prevented from operating because FSUIPC took over the hooks ASN needed into FSX.

 

There has never been anything whatsoever in FSUIPC which can possibly cause ASN itself to crash. It is an independent program and doesn't use or need FSUIPC at all.. So, whoever told you that on the ASN forum is wrong. Please go back and try to get an answer from someone who knows what he is talking about. The problem you have sounds more like a corrupted install of ASN itself.

 

Pete

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.