Jump to content
The simFlight Network Forums
Sign in to follow this  
TW79

Saitek Yoke / Throttle 0 to 16k

Recommended Posts

All,

 

I have purchased a few Saitek products with no issue. However I have an issue with my latest purchase, the yoke and throttle quadrant.

 

The yoke seems to work fine, but the throttle quadrant (prop and mix also) goes from 0 to 16k with no range in between. I deleted all my joystick and axes assignments in FSX, but this issue remains. The calibration in Windows works perfectly with full range of motion.

 

I'm really stumped on this one. Can anyone provide some input as to how I can fix this?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.