Jump to content
The simFlight Network Forums

Autosaves Accumulating


Recommended Posts

Thank heavens for the autosave for FSUIPC, saves me OFTEN!.  I have "asked it" to only save one flight. Which it does. But when I go into the documents section for my flight sim (P3D), there are a whole list of autosaves in there.  Is there any way to save the latest but not ALL of them? Just curious. (To solve the problem now, after each flight, I just go in and delete all the autosaves). Maybe i've got a setting wrong, maybe this is the "way it is" ... but I don't remember this happening before. Thank you. More curiosity than a problem.

Link to comment
Share on other sites

The files FSUIPC knows about should not be accumulating more than the number of iterations you've allowed in the settings. For files it doesn't know about you need to tell it via parameters in the INI file. This is described in the FSUIPC Advanced Users guide. The ones it knows about are FLT, FXML, FSSAVE, WX, PSS, FMC, ABL, RCD, SPB and IPCBIN.

 

Pete

Link to comment
Share on other sites

Hello,

I observed the same strange behaviour, as I use the autosave and it worked perfectly until now.

I tried to investigate a little and discovered that Prepar3d v2.3 save now one more file (.pnl if I remember correctly) containing the panel state.

Maybe FSUIPC deletes all the .wx and.flt files beyond the specified number  (eg: keeps the last 10) but it's unaware of the existance of .pnl files, so it don't delete them.

Did I guess correctly? 

Link to comment
Share on other sites

Hello,

I observed the same strange behaviour, as I use the autosave and it worked perfectly until now.

I tried to investigate a little and discovered that Prepar3d v2.3 save now one more file (.pnl if I remember correctly) containing the panel state.

Maybe FSUIPC deletes all the .wx and.flt files beyond the specified number  (eg: keeps the last 10) but it's unaware of the existance of .pnl files, so it don't delete them.

Did I guess correctly? 

 

I never noticed the .pnl files. I'll add that in the next update. Not sure when that'll be though.

 

 

Meantime, as workaround, which could be the parameter to be specified in .ini file?

 

You can do it by simply adding one line to the [AutoSave] section of the INI file. Please see the Autosave section in the Advanced User's guide for FSUIPC4.

 

Pete

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.