Jump to content
The simFlight Network Forums

Seeing multiplayer aircraft in P3D/FSC9.5 via WideFS 6.99


Recommended Posts

Hi there,

 

First of all, here's the required information about our setup:

 

1. Prepar3D (V2.3) on 3 PCs on LAN (not connected to the internet).
2. FSUIPC 4.936 / WideFS7 (2069). (Wideclient 6.999)
3. FS Commander 9.5 with FSCP3DCFG2 file installed in the main P3D folder.

4. Our system is on a private network, and no internet access so we don't download AIRAC Cycles
5. FS9.5 downloaded from website. Purchased licence from SimMarket
6. Operating System: Windows 7/64

 

Description of our setup: 2 PCs, which I'll name #1 and #2 use P3D with TACPACK. Normally use #1 PC to host the sessions.

#3 PC simulates our AWAC aircraft, and also has P3D v2.3 installed.

Once all 3 are joined up over the network, I don't have any issues seeing the #1 and #2 aircraft on the #3 PC in normal P3D ATC RADAR.


I start FSC and connect to FS via the GPS option. All the labels are on and AI is selected.

The #1 and #2 aircraft show up on the ground at the airport and is visible on FSC.

 

The problem I have is that for some reason, the multiplayer aircraft disappear when airborne. On other occasions, only the #1 aircraft is visible. I can see the call sign and data for the #1 aircraft.

All the options are enabled to see AI traffic on FSC. 

 

I have tried exiting out of both P3D multiplayer session and FSC, then starting up WideFS7. It comes up with a window indicated FS98 Waiting for Connection, and the window stays blank. 

Nothing seems to be happening. I load FSC and connect to FS and I get an error message stating that it cannot connect. Message #14. 

I don't know if it's a network configuration or not. I can't see why it would it be, because the #1 and #2 aircraft are visible in the FSC session. 

 

Anyone have any ideas as to why the contacts would disappear off FSC when airborne?

 

Any help would be appreciated.


Thank you.

 

Rossco

 

Link to comment
Share on other sites

2. FSUIPC 4.936 / WideFS7 (2069). (Wideclient 6.999)

 

The current and supported version is 4.937. I cannot support old versions. You need to update.

 

The problem I have is that for some reason, the multiplayer aircraft disappear when airborne. On other occasions, only the #1 aircraft is visible. I can see the call sign and data for the #1 aircraft.

All the options are enabled to see AI traffic on FSC. 

 

FSUIPC doesn't know anything about multiplayer traffic, only about AI. And there are separate tables in FSUIPC for ground AI and airborne AI. I've no idea what the programs you are using are doing.

 

I have tried exiting out of both P3D multiplayer session and FSC, then starting up WideFS7. It comes up with a window indicated FS98 Waiting for Connection, and the window stays blank. 

Nothing seems to be happening. I load FSC and connect to FS and I get an error message stating that it cannot connect. Message #14. 

I don't know if it's a network configuration or not. I can't see why it would it be, because the #1 and #2 aircraft are visible in the FSC session. 

 

Sorry, are you reporting a problem with WideFS or with multiplayer traffic? I am now confused. If WideFS won't connect it may be a firewall problem or simply ports already in use. I can't help without information -- WideServer log from the FS PC and WideClient log from the client. close both ends down first. Paste the log contents into a message here.

 

Anyone have any ideas as to why the contacts would disappear off FSC when airborne?

 

Have you tried FSC support? If WideFS isn't connecting I assume FSC isn't using WideFS?

 

Pete

 

Link to comment
Share on other sites

Hi Peter,

 

I've tried posting this topic to the FSC forum, but I've had over 60 views but no response to it.

 

Wideclient logs:

 

********* WideClient Log [version 6.999n] Class=FS98MAIN *********
Date (dmy): 20/11/14, Time 13:47:02.374: Client name is ACO-PC
       31 LUA: "C:\Users\ACO\Desktop\Initial.LUA": not found
       62 Attempting to connect now
       62 Trying to locate server: Need details from Server Broadcast
       62 Failed to connect: waiting to try again
     2121 Attempting to connect now
    11887 New Client Application: "FSC" (Id=2652)
    45302 Trying to locate server: Need details from Server Broadcast
 
    47767 ****** End of session performance summary ******
    47767 Total time connected = 0 seconds
    47767 Reception maximum:  0 frames/sec, 0 bytes/sec
    47767 Transmission maximum:  0 frames/sec, 0 bytes/sec
    47767 Max receive buffer = 0, Max send depth = 0, Send frames lost = 0
 
    47767 **************** Individual client application activity ****************
    47767 Client 2652 requests: 10 (Ave 10/sec), Data: 540 bytes (540/sec), Average 54 bytes/Process
 
    47767 ********* Log file closed (Buffers: MaxUsed 1, Alloc 10 Freed 10 Refused 0) *********
 
********* WideClient Log [version 6.999n] Class=FS98MAIN *********
Date (dmy): 18/11/14, Time 17:44:29.108: Client name is ACO-PC
       47 LUA: "C:\Users\ACO\Desktop\Initial.LUA": not found
       63 Attempting to connect now
       63 Trying to locate server: Need details from Server Broadcast
       63 Failed to connect: waiting to try again
     2122 Attempting to connect now
     4306 New Client Application: "FSC" (Id=3392)
    45318 Trying to locate server: Need details from Server Broadcast
    67549 New Client Application: "AIBridge" (Id=2892)
   131119 Trying to locate server: Need details from Server Broadcast
 
   183551 ****** End of session performance summary ******
   183551 Total time connected = 0 seconds
   183551 Reception maximum:  0 frames/sec, 0 bytes/sec
   183551 Transmission maximum:  0 frames/sec, 0 bytes/sec
   183551 Max receive buffer = 0, Max send depth = 0, Send frames lost = 0
 
   183551 **************** Individual client application activity ****************
   183551 Client 3392 requests: 10 (Ave 10/sec), Data: 540 bytes (540/sec), Average 54 bytes/Process
   183551 Client 2892 requests: 45 (Ave 45/sec), Data: 1926 bytes (1926/sec), Average 42 bytes/Process
 
   183551 ********* Log file closed (Buffers: MaxUsed 1, Alloc 55 Freed 55 Refused 0) *********

 

Apologies for any confusion Peter. Just trying to work some things out with this. P3D ATC RADAR seems to pick up the multiplayer traffic with no problems.

Just need to work out what's going on between WideFS7 and FS Commander.

 

Kind regards,

 

Rossco

Link to comment
Share on other sites

Wideclient logs:

 

You haven't supplied the WideServer log file, just two copies of the client log!

 

However, the lack of any connection is obviously because your PCs are in different workgroups and you haven't bothered to tell the Client the name and protocol of the Server. Please read the part of the WideFS user guide which advises you to read it in RED letters. It is easy enough to fix, just check the documentation.

 

I cannot see how any of my software is involved in Multiplayer as it knows nothing about it. Maybe it is the AIBridge program which injects this data into FSUIPC's tables for other programs to read, in which case your problem does resolve down to lack of attention to configuring WideFS.

 

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.