Jump to content
The simFlight Network Forums
Sign in to follow this  
TorranceR1

Saitek Throttle Setup

Recommended Posts

I have recently been trying to setup my Saitek Throttle and seem to be having some problems. I have Assigned to axis' on my throttle to a throttle each aka. Axis Y for Throttle 1 and Axis Z for Throttle 2. I assigned both in the Axis assignment section of FSUIPC and then pressed 'Set' for both Throttle 1 and 2 in the Calibration section but when I went into the VC I had a problem. I tried moving both at the same time and the first thing I noticed was that Throttle 1 jumped straight to about 50% even though I only pushed it forward slightly on my Saitek Throttle. Throttle number 2 seemed fine, when I move it a slight bit it only moves a slight bit in the simulator so Throttle 1 is the only one I am having problems with. I am still fairly new to FSUIPC so still trying to get the hang of it.

 

My FSUIPC.ini file - http://pastebin.com/RGBuYGX0

 

Thanks, Robbie

Share this post


Link to post
Share on other sites

I have recently been trying to setup my Saitek Throttle and seem to be having some problems. I have Assigned to axis' on my throttle to a throttle each aka. Axis Y for Throttle 1 and Axis Z for Throttle 2. I assigned both in the Axis assignment section of FSUIPC and then pressed 'Set' for both Throttle 1 and 2 in the Calibration section but when I went into the VC I had a problem. I tried moving both at the same time and the first thing I noticed was that Throttle 1 jumped straight to about 50% even though I only pushed it forward slightly on my Saitek Throttle. Throttle number 2 seemed fine, when I move it a slight bit it only moves a slight bit in the simulator so Throttle 1 is the only one I am having problems with. I am still fairly new to FSUIPC so still trying to get the hang of it.

 

It's a typical problem with Saitek -- they get things wrong in the Registry. I think the answers are over in the Saitek support forum. It either involves a driver reinstall, or some Registry editing. Ask over there. It isn't FSUIPC.

 

However, you do seem to have a few superfluous and possibly interacting assignments in your FSUIPC4 INI file. Look:

 

  1. [Axes]
  2. PollInterval=10
  3. RangeRepeatRate=10
  4. 0=0X,256,D,1,0,0,0
  5. 1=0Y,256,D,2,0,0,0
  6. 2=0Z,256,D,22,0,0,0
  7. 3=0U,256,D,26,0,0,0
  8. 4=0V,256,D,4,0,0,0
  9. 5=1X,256,D,7,0,0,0
  10. 6=1Y,256,D,8,0,0,0
  11. 7=1R,256,D,3,0,0,0 == Rudder
  12. 8=2X,256,D,7,0,0,0
  13. 9=2Y,256,D,8,0,0,0
  14. 10=2R,256,D,3,0,0,0 == Rudder

 

So, in the general (non-profile) assignments you have two rudders -- one on your Yoke, the other on your Quadrant?

 

The same applies to the Cessna and PMDG 737NGX profiles. But in the Latter you also have a real duplication, not of throttles (that's a Saitek install problem), but:

 

THREE different assignments to spoilers

TWO ailerons, TWO elevators, and two assignments to a #26 which is strange as #26 isn't an axis.

 

 

  1.  
  2. [Axes.PMDG 737NGX]
  3. RangeRepeatRate=10
  4. 0=0X,256,D,1,0,0,0 == Aileron
  5. 1=0Y,256,D,2,0,0,0 == Elevator
  6. 2=0Z,256,D,26,0,0,0 == UNKNOWN? There's no #26 so I don't know how you got these
  7. 3=0U,256,D,26,0,0,0 == UNKNOWN?
  8. 4=0V,256,D,22,0,0,0 ==Spoilers
  9. 5=1X,256,D,1,0,0,0 == Aileron
  10. 6=1Y,256,D,2,0,0,0 == Elevator
  11. 7=1R,256,D,3,0,0,0 == Rudder
  12. 8=1V,256,D,22,0,0,0 ==Spoilers
  13. 9=2X,256,D,22,0,0,0 ==Spoilers
  14. 10=2Y,256,D,9,0,0,0
  15. 11=2Z,256,D,10,0,0,0
  16. 12=2R,256,D,3,0,0,0 ==Rudder
  17. 13=3X,256,D,7,0,0,0
  18. 14=3Y,256,D,8,0,0,0
  19. 15=3R,256,D,3,0,0,0 == Rudder

 

Regards

Pete

Share this post


Link to post
Share on other sites

Hi Pete. I'll reinstall the drivers for my quadrant and if the problem still exists. If it still exists then I will do what you said and take a look at their support forums.

 

Thanks, Robbie

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.