Jump to content
The simFlight Network Forums
Burkhard

MyTraffic 6 released

Recommended Posts

Hi Burkhard,

I am finding it difficult to install this version of MTP V6.

 

I have uninstalled all my previous versions of My Traffic and installed MTPV6 on my "F" drive where I also have FSX installed.

MTPV6 is not within the FSX folder.

 

This the entry in scenery.cfg in users etc

[Area.270]
Title=MyTraffic
Local=..\MyTraffic Professional\MyTraffic
Active=TRUE
Required=FALSE
Layer=128

 

This is the entry in fsx.cfg

SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.2=SimObjects\GroundVehicles
SimObjectPaths.3=SimObjects\Boats
SimObjectPaths.4=SimObjects\Animals
SimObjectPaths.5=SimObjects\Misc
SimObjectPaths.6=MyTraffic Professional\My Traffic\Aircraft"
SimObjectPaths.7="\Aircraft"

 

Attached is the folder from MTPV6

 

Could you check these and let me know what might be the problem please?

 

Let me know if you require any other filesFolders.txt

 

 

Share this post


Link to post
Share on other sites

hey burkhard..

 

I am a proud user of my traffic x pro 5.4C...hen i came to know about the release of my traffic 6..i was happy and sad..the happy part is that it is still upgrading and fully active..the sad part is that i have to spend an extra money to buy my traffic 6!! There is no free upgrade for any existing users..this saddens me..:( 

 

The main reason is that i requested you to provide some changes in liveries...please see the post below:

 

http://forum.simflight.com/topic/77910-request-of-change-in-livery/#entry472886

 

Now i wont be getting these since i cant buy my traffic 6...is there no way there is a provision for users of my traffic 5 to get a rebated update? also what are the change log from my traffic 5 to 6?

 

thanking you

 

govind

Share this post


Link to post
Share on other sites

@tesza

 

The entry in FSX.cfg should be in your case

SimObjectPaths.6="F:\MyTraffic Professional\My Traffic\Aircraft"

 

Scenery entry should work, if not try

Local=F:\MyTraffic Professional\MyTraffic

Share this post


Link to post
Share on other sites

MyTraffic always had two free upgrades ( with 5.4 even 3) and then one that was not free, but rebated and cost about 15-16€, This now is done in form of the promotion ending end of April, after that there will be no rebate and marketing will start for new users.

 

The main reason is that the sales system was no longer able to handle so many old products, so this had to be broken, and the fact that more than 12000 files in MyTraffic got created new after the last major release, 5.4, plus MyTraffic 6 replacing so many other products and offerening support for so many new things like P3DV2, FSX SE, Windows 8...

Share this post


Link to post
Share on other sites

Fantastic product! I've been a longtime MyTraffic user for my AI FSX traffic. Without any difficulties, I uninstalled my previous version of MyTraffic and installed 6. All seems to be running smoothly, but I've noticed two nuances that have been bothering me:

 

1) At 48% traffic density, I see a lot of duplicate aircraft (same equipment and company) parked at the gates. For example, at KMIA, there are three or more AA 777 bound for SAEZ, two or more Copa 737 destined for Panama City, etc. I'm guessing that I simply need to play with the density slider thin out duplicates.

 

2) More troubling is the issue that I'm having with European bound international flights from the US appearing in the early AM vs their normally scheduled PM times. For example, at KIAD, United's flights to Geneva, Amsterdam, Dubai, etc. are all appearing at 6AM rather than 6PM (or later in the evening), when they should be at the gates boarding. I've seen this same issue at other large US int'l airports (e.g., KMIA). Are the times off in the schedule tables? Is there a fix that I can make to FSX to correct this timing imbalance?

 

Any help would be GREATLY appreciated!!

 

Many thanks.

Share this post


Link to post
Share on other sites

1) Yes, reduction of the sliders should do the job, especially in the US there are often flights between two airports with the same equipment less than 30 minutes apart, and their suppression had been critiziesed, so this limit which was 1 hour was reduced.

 

2) No idea for the moment, have to check, is this for all time zones or only a specific one - abbreviations of time zones change frequently, and are used the same at different places with different times, many days of work alone with every new schedule to get this sorted...

Share this post


Link to post
Share on other sites

Hi Burkhard

 

I've been trying to install Mytraffic 6 in FSX-SE but I have a problem, inside the fsx se I have the massage saying area 136 not found in scenery cfg, I go there but nothing is written in that file concerning mytraffic, I remove it and installed again and same problem,

 

I created manually this

 

[Area 136]

Title=MyTraffic

Local=C:\MyTraffic Professional\Mytraffic

Active=TRUE

Required=FALSE

Leyer-136

 

and after installed again now I have the same error but with area 137 not found, so, I don't know what is going on.

 

 

Share this post


Link to post
Share on other sites

Hi Burkhard,

I have followed your advice and set the FSX cfg entry and scenery entry as advised.

Still no traffic though?

SimObjectPaths.0=SimObjects\Airplanes

SimObjectPaths.1=SimObjects\Rotorcraft

SimObjectPaths.2=SimObjects\GroundVehicles

SimObjectPaths.3=SimObjects\Boats

SimObjectPaths.4=SimObjects\Animals

SimObjectPaths.5=SimObjects\Misc

SimObjectPaths.6=MyTraffic Professional\My Traffic\Aircraft"

SimObjectPaths.7="F:\MyTraffic Professional\MyTraffic\Aircraft"

SimObjectPaths.7="\Aircraft"

Area.270]

Title=MyTraffic

Local=F:\Microsoft Flight Simulator X\

Active=TRUE

Required=FALSE

Layer=128

regards tesza

Share this post


Link to post
Share on other sites

Hi tesza

Guess this is not what burkhard advised.

The entry in the scenery.cfg has to be:

Local=F:\MyTraffic Professional\MyTraffic

The entries in the fsx.cfg must be changed as follows:

Delete the SimObjectPaths.6

line and change the

SimObjectPaths.7="F:\MyTraffic Professional\MyTraffic\Aircraft"

to

SimObjectPaths.6=F:\MyTraffic Professional\MyTraffic\Aircraft

This should solve your problems if all the rest is setup correctly.

Kind regards

Christian

Share this post


Link to post
Share on other sites

Thanks, Christion, @TESZA:  about P3D.cfg it should read:

 

SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.2=SimObjects\GroundVehicles
SimObjectPaths.3=SimObjects\Boats
SimObjectPaths.4=SimObjects\Animals
SimObjectPaths.5=SimObjects\Misc
SimObjectPaths.6="F:\MyTraffic Professional\MyTraffic\Aircraft"
SimObjectPaths.7="\Aircraft" this only in case that you have a folder <P3D>\aircraft where aircraft for FS9 are installed, if not omitt.

 

scenery.cfg should be:

Area.270]

Title=MyTraffic
Local=F:\MyTraffic Professional\MyTraffic
Active=TRUE
Required=FALSE
Layer=128

Share this post


Link to post
Share on other sites

@orolamca

 

The normal path for scenery.cfg is in the all users folder.

 

But some users report that some addon create a copy of scenery.cfg in the users roaming profile, where FSX.cfg is, and this then is used instead 

 

What they reported is the following: If you have FSX-DVD and FSX-SE installed in parallel, and a scenery.cfg in %appdata%\Microsoft\FSX, then FSX-SE uses this scenery.cfg and not its own, leading to messages as you describe.

 

Can this apply to your problem? 

Share this post


Link to post
Share on other sites

@orolamca

 

The normal path for scenery.cfg is in the all users folder.

 

But some users report that some addon create a copy of scenery.cfg in the users roaming profile, where FSX.cfg is, and this then is used instead 

 

What they reported is the following: If you have FSX-DVD and FSX-SE installed in parallel, and a scenery.cfg in %appdata%\Microsoft\FSX, then FSX-SE uses this scenery.cfg and not its own, leading to messages as you describe.

 

Can this apply to your problem? 

 

 

Well Burkhard, I have Windows 7 64 bit and I don't have the all users folder don't know why, I just have C:\Users\Myname\appdata\roaming\microsoft\fsx-se so, what to do about it? and I don't have FSX installed. I would like to have and answer about this problem,

Edited by orolamca

Share this post


Link to post
Share on other sites

Hi Christian,

Thanks for you reply.

Followed your advice as below however no traffic is showing, traffic is set to 83%

All seems to be set up okay?

 

scenery.cfg

 

[Area.128]
Title=MyTraffic
Local=F:\MyTraffic Professional\MyTraffic
Layer=128
Active=TRUE
Required=FALSE

 

FSX.cfg

SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.2=SimObjects\GroundVehicles
SimObjectPaths.3=SimObjects\Boats
SimObjectPaths.4=SimObjects\Animals
SimObjectPaths.5=SimObjects\Misc
SimObjectPaths.6=F:\MyTraffic Professional\MyTraffic\Aircraft

 

Regards tesza

Share this post


Link to post
Share on other sites

Hi tesza

 

please check if you have a quite big file in your

F:\MyTraffic Professional\MyTraffic\Scenery - Directory

 

Should be around 125MB and is called "Mytrafficcommercial.bgl" (or something like that - I'm not at my home-pc at the moment)
and there should also be two others ("Mytrafficglobal.bgl" and "Mytrafficmil.bgl" - I think)

Also check if the following file is set to passive:  "trafficAircraft.bgl" (should be "trafficAircraft.bgl.passive")
in F:\Microsoft Flight Simulator X\scenery\world\scenery\

If all this is ok there must be other things that your traffic does not show up (mabe old traffic-bgls from another addon).

 

You are sure you edited the right fsx.cfg file and the right scenery.cfg (there sometimes are more than one!)???

 

The right fsx.cfg is in here: C:\Users\YOURNAME\AppData\Roaming\Microsoft\FSX

The right scenery.cfg is in here: C:\Users\All Users\Microsoft\FSX

 

All the so far given information are also in the new "MyTraffic 6 Installation Guide.pdf"... ;-)

 

Regards

Share this post


Link to post
Share on other sites

Thanks for taking the time to reply to my post.

 

1) I reduced the traffic density to 38% and that seemed to take care of most of the duplicate flights bound for the same destinations.

 

2) I experimented with visiting KSFO, KDEN, KORD, CYYZ, KBOS, and KEWR at 6AM and at 6PM local time each. In every case, the international bank of aircraft (both US and Int'l carriers) bound for Europe were present in the early AM rather in the evening when realistically they should depart. I'm using the traffic schedule file for Spring 2015. Have you heard of this error from others, or might this be a simulator issue on my end? I don't see any apparent problems with domestic operations, with aircraft active from morning to evening and quiet from midnight to 6AM. Thanks very much.

Share this post


Link to post
Share on other sites

Hi Burkhard & Christian,

Thanks for your help with my install issues.

 

I thought I would post again just to let everyone know how I solved the install issue on my pc!

I have two main drives and had set up FSX on my F drive.

 

MTP would not show traffic while it resided in this drive.

 

I reinstalled , this time placing MTP in the default C drive and all now works :razz:

 

I had tried everything to get it to work on the F drive but I guess it just did not want to co-habit with FSX????

 

Cheers tesza

Share this post


Link to post
Share on other sites
Dear Burhhard,
 
I am using MyTraffic for more than 10 years now - and I can only say: Phantastic work.
 
MyTraffic 6 works seamlessly in Prepar3d 2.5. Two minor questions on liveries:
 
- In EDDH I am still seeing some old Germanwings liveries with the Spring 2015 schedules. How can I correct this? Also, I am seeing lots of LH 747 and 330/330 at EDDH, which is of course not completely realistic, but that does not bother me.
- I have a specific interest in South American Traffic e.g. Bolivia. I can see still a lot of Aerosur traffic there - the airline is out of business for a while now, while others like the regional Amaszonas are not appearing at all.
 
Anything I am doing wrong, which can be corrected?

All for the Spring 2015 schedules.
 
 
Kind regards,
 
Niels

Share this post


Link to post
Share on other sites

First thing is reduce the traffic density slider below 50%, then you should only see traffic originating from actual data. 

Share this post


Link to post
Share on other sites

I too am having problems with getting MT6 to work.  I was running UT2, and still have it on my system, but put sliders for it to 0%.  I have read all of the above posts, and tried all of the above, but still cannot seem to get any traffic at all.  I have sliders set to about 50%, and have been just trying to install it in FSX (although I have prepar3d installed also).  I have place the # sign in front of the cfg line referencing UT2.  The following is what my cfg lines and location look like.  Any help would be appreciated.

 

C:\Users\Gary\AppData\Roaming\Microsoft\FSX
 
User Objects=Airplane, Helicopter
SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.2=SimObjects\GroundVehicles
SimObjectPaths.3=SimObjects\Boats
SimObjectPaths.4=SimObjects\Animals
SimObjectPaths.5=SimObjects\Misc
# SimObjectPaths.6=SimObjects\UT2 Aircraft
SimObjectPaths.6="C:\MyTraffic Professional\MyTraffic\Aircraft"
# SimObjectPaths.7="\Aircraft"
# SimObjectPaths.7=SimObjects\AI Aircraft
 
 
 
C:\ProgramData\Microsoft\FSX
 
[Area.246]
Title=MyTraffic
Local=C:\MyTraffic Professional\MyTraffic
Active=TRUE
Required=FALSE
Layer=115
 
Thanks in advance for any help.
 
Gary

Share this post


Link to post
Share on other sites

@gary

 

Both entries look OK.

 

Please do the following test:

 

When you can set a start location, select the airport ETAR (Ramstein Airbase), do you get a lot of military parkings that you can choose as your start location. If yes, then the scenery entry is fine.

Copy one of the (smaller) aircraft folders from MyTraffic\aircraft over to simojects\airplanes, as example the folder R99MX - do ypu get a warning about duplicate entries now? Than the FSX.cfg works.

 

In this case, the most likely reason is that you have AI schedules in FS8/ttolls format instlled, ever installed WOAI as example? MyTraffic Communicator contans a tool "search for traffic bgls" thast gives you a list of candidates for such files which use to shut doen FSX AI traffic and forcing it to emulate FS8 AI traffic,

Share this post


Link to post
Share on other sites

That was it!!!  A long time ago, I had used WOAI, and still had a bunch of traffic bgls still there.  I deleted them, and everything seems to work OK.  Thanks again.

 

Gary

Share this post


Link to post
Share on other sites

Hello   I have had MTX 5.c installed  .. I had problems of seeing no traffic after I installed another add - on  GFX .. and now I just bought the newest version of MTX6   .. Your product works when it does work . When I had problems before of seeing no traffic in MTX5c , I would have too Compltely Remove all entries in Fxcfg . Sceneray   Dll .. and re-ran MTX5C   and than I would see traffic . , I did not know that you could fix things with re-nounce bat , however after 8 attempts of running that re-nounce Bat file I gave up , I followed every soulution In your Post and Still did see  any traffic . Now the question is shall I remove My traffic 5c from the hard-drive , make sure all entries in the dll, cfg, and scenery files are removed ? . I am downloading MTX6 as of now , Your kind response is very much appreciated 

 

 

metakrockerlion 

Share this post


Link to post
Share on other sites

Hi Burkhard - I am completely lost with respect to compiling the database for the MyTraffic 6. I have been reading the various forums and have tried what I read but I must be doing something wrong. I have been using Mytraffic X for years, and wanted to use this for FSX Steam Edition. I have both FSX CD and FSX-SE installed, but I come to a complete dead end when trying to get this working. In the communicator, I am stuck at this: TrafficDataBasebuilder not yet copied ! Can you help me get this up and running. FYI, I just want to install normal schedules, nothing else. Thanks in advance for your  help!

 

Cheers, Pete

Share this post


Link to post
Share on other sites

Hi Burkhard - I am completely lost with respect to compiling the database for the MyTraffic 6. I have been reading the various forums and have tried what I read but I must be doing something wrong. I have been using Mytraffic X for years, and wanted to use this for FSX Steam Edition. I have both FSX CD and FSX-SE installed, but I come to a complete dead end when trying to get this working. In the communicator, I am stuck at this: TrafficDataBasebuilder not yet copied ! Can you help me get this up and running. FYI, I just want to install normal schedules, nothing else. Thanks in advance for your  help!

 

Cheers, Pete

Hi Pete, for my normal FSX system, to find this file, I went into SDK>environment kit>Traffic Toolbox SDK> and in here is the TrafficDatabaseBuilder.exe. I copied this into, in my case, C;\MyTraffic Professional\MyTraffic and now my communicator finds the TrafficDatabaseBuilder by noting TrafficDatabaseBuilder found. It was important to update the SDK before transferring this file. Hope this helps you.

 

Regards

 

Ged

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.