Jump to content
The simFlight Network Forums
Ray Proudfoot

New Router and cannot now connect to Data Server

Recommended Posts

A couple of weeks ago I was given a new router which resulted in changes to IP addresses for my FSX computer and the one running STB.

 

Despite entering new new IP address into STB - Configuration - Settings (and saving changes) STB cannot link to FSX.

 

The following message is displayed:- Unable to connect to Flight Simulator X. Please make sure a flight has completed loading before trying to connect again.

 

Help please.

Share this post


Link to post
Share on other sites

While IP addresses will work, you are typically best served using computer names.  Otherwise you'll need to allocate static IP addresses to your FSX computer on your router (and your client if using UT2), if you rely on DHCP one day the IP lease will expire.

 

So let's assume you are on static IP addresses at least for FSX.  Please check first the IP address of your FSX computer is presented in both:

1) simconnect.cfg in my documents;

2) TrafficBoardFrontEnd.exe.config in the STB install path;

 

Simon

Share this post


Link to post
Share on other sites

Hi Simon,

 

Thanks for your quick response. I searched the board and found it was best to use computer names rather than ip addresses but still no joy I'm afraid. I use Electronic Flight Board which also relies on simconnect and that's fine with a change of ip.

 

Here's my simconnect.cfg on the client...

 

[simConnect]
Protocol=IPv4
Address=FLYING
Port=32123
MaxReceiveSize=4096
DisableNagle=0

In trafficboardfrontend.exe.config I have the following entry...

 

<client>
      <endpoint address="net.tcp://flying:2024/stbdata/Ut2Service"
        binding="netTcpBinding" bindingConfiguration="NetTcpBinding_IStbData"
        contract="IStbUt2Data" name="NetTcpBinding_IStbData" />
      <endpoint address="net.tcp://flying:2024/stbdata/AirportService"
        binding="netTcpBinding" bindingConfiguration="NetTcpBinding_IStbData"
        contract="IStbAirportData" name="NetTcpBinding_IStbData" />
    </client>

 

Does that help or would you prefer the full files? I have tried different port numbers (default 500) but still no joy.

Share this post


Link to post
Share on other sites

Hi Simon,

 

I've got it working again. Changed the port to 500 in simconnect.xml and that seems to have done the trick. Only problem now is getting the airline logos to show. Just showing placeholders at present.

Share this post


Link to post
Share on other sites

Glad it's working again Ray. The ports need to be the same number at each end of the connection, it's how the applications find each other.  Of course if it's working don't change it, just interested to know your simconnect ports at each end (simconnect.cfg and simconnect.xml)

 

Simon

Share this post


Link to post
Share on other sites

Hi Simon,

 

I have to admit that simconnect does remain a real PITA for me on the occasional time I need to tweak it.

 

simconnect.cfg and simconnect.xml have port 500 but trafficboardfrontend.exe.config has 2024.

 

Can you explain why trafficboardfrontend.exe.config would use a different port?

 

I'm not really sure what the original entries were as I was desperately changing things to get a handshake. I'm also using computer name now rather than ip address.

Share this post


Link to post
Share on other sites

Hi Ray,

STB performs the following communications:

 

1) Talks to the FSX SimConnect server using port 500.  Both ends of the link, e.g. STB and FSX need the port number so they know to expect each other.

2) Talks to the STB-DS app running on the FSX PC.  This runs over port 2024 at both ends.  This configured by TrafficBoardFrontEnd.exe.config on the client side, and STBDataServer.exe.config on the server side.

 

The ports must be different numbers, as SimConnect and STB-DS are talking about different things.

 

Either way, you are in good shape now

 

Simon

Share this post


Link to post
Share on other sites

Simon,

Sorry to have to raise this again but having just changed my router from BT HH5 to a TP-Link one I’m having problems getting STB for P3D v3.4 to communicate with the server program.

I’ve tried both Computer name and IP Address in both SimConnect.cfg and SimConnect.xml But I just keep getting the “unable to connect” message. The port number of 500 is present in both those files.

It worked fine up to when the router was changed. I know the IP addresses have changed but even having changed them it still refuses to work.

Is a log generated anywhere that allows me to see the exact error message?

Share this post


Link to post
Share on other sites

Inexplicably having rebooted both computers a couple of hours later and changed to using the computer name in simconnect,cfg and xml files it now works. Baffling! 😄

Share this post


Link to post
Share on other sites

I've no idea how Windows goes about figuring out the computer name to IP address to MAC address relationship, but I guess it just took its sweet time on this one.

Typilcally there's no meaningful error with this sort of thing, just "connection timed out" which is all Microsoft is prepared to tell us.

Simon

Share this post


Link to post
Share on other sites

Thanks Simon. I suspect it was down to the fact the router had been running less than 24 hours so maybe the previous IP addresses were still trying to be used. All very confusing (and frustrating) but hopefully sorted now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.