Jump to content
The simFlight Network Forums
Sign in to follow this  
flying-w

Which STB for which Simulator (FSX, FSX Steam Edition and Prepar3D V2/V3/V4)?

Recommended Posts

STB can be used with the following simulators, see each section below the latest version information and for the development and support status:

  • Microsoft Flight Simulator X (FSX);
  • Dovetail Games FSX Steam Edition;
  • Lockheed MartinPrepar3D V4.2 and V4.3;
  • Lockheed Martin Prepar3D V4.0 and V4.1;
  • Lockheed Martin Prepar3D V3;
  • Lockheed Martin Prepar3D V2;

There are various editions of STB available, depending on the Simulator or combinations of Simulators you have installed.  Each STB edition can be installed and used on the same computer as any of the other editions listed below, depending on your simulator needs.  Any questions, just ask!

 

Prepare3D V4.2, V4.3:

650293240_Prepar3DV4Tiny.png.572773fa5e68b69c811ff754d64caf68.png

  • STB V4 for Prepar3D V4.2 and V4.3.  Current STB version is V4.2.2018.13500
  • All you need to do to get to this level is install the STB V4 base product, then install this update.
  • Not compatible with FSX, FSX-SE, Prepar3D V2, V3, V4.0 and V4.1.
  • This is a separate product compared to STB for FSX editions and needs to be purchased for use with Prepar3D.
  • As Prepar3D V2, V4 and V4 can all be installed at the same time, so can STB V3.3 for Prepar3D-V2, STB V3.4 for Prepar3D-V3 and STB V4 for Prepar3D-V4.

 

FSX and FSX Steam Edition

619973246_MSFSXSmall.png.c4a475e4cda87f86733f9fabcd78a746.png  431263388_FSXSESmall.png.b4313fae03f101073dda9874a6815662.png

  • Can be used with either Microsoft FSX or FSX Steam Edition "Standalone", i.e. not installed on the same computer as Microsoft FSX.
  • Support is discontiuned for FSX Steam Edition "side by side", i.e. on the same computer as Microsoft FSX.
  • Not compatible with Prepar3D.
  • STB V3.6 for FSX and FSX-SE (Standalone):
    • Current STB Client version is V3.6.2018.20201.
  • STB V3.2 for FSX and FSX-SE (Standalone):
    • Final STB Client version is V3.2.1.15.
    • STB V3.2 is discontinued, please upgrade to STB for FSX V3.6 at your earliest opportunity.  There is no charge for V3.6 if you already own STB for FSX V3.2.  To obtain V3.6, please visit the shop from which you originally purchased STB, or contact us for assistance.
    • Special note for FSX Steam Edition only:  Due to the way the STB Simulator plugin was compiled, you will need to install the FSX SP1 Simconnect client in to FSX-SE.  You can find the installer in your steam library, for example:
      • C:\Program Files (x86)\Steam\steamapps\common\FSX\SDK\Core Utilities Kit\SimConnect SDK\LegacyInterfaces\FSX-SP1\SimConnect.msi

 

Prepare3D V4.0 and V4.1:

650293240_Prepar3DV4Tiny.png.572773fa5e68b69c811ff754d64caf68.png

  • STB V4 for Prepar3D V4.0 and V4.1  Final STB Client version is V4.0.2018.03100
  • Not compatible with FSX, FSX-SE, Prepar3D V2, V3, V4.2 and later.
  • This is a separate product compared to STB for FSX editions and needs to be purchased for use with Prepar3D.
  • As Prepar3D V2, V3 and V4 can all be installed on the same computer at the same time, so can STB V3.3 for Prepar3D V2, STB V3.4 for Prepar3D V3 and STB V4 for Prepar3D V4.
  • Development for STB V4 for Prepar3D V4.0 and V4.1 has ended.  Support is provided on a best effort basis for known problems only.

 

Prepare3D V3:

970596728_Prepar3DV3Tiny.png.a43cfe85502dfddba754719d48334cdd.png

  • STB V3.4 for Prepar3D V3.  Final STB Client version is V3.4.0.29.
  • Not compatible with FSX, FSX-SE, Prepar3D V2 and Prepar3D V4.
  • This is a separate product compared to STB for FSX editions and needs to be purchased for use with Prepar3D.
  • As both Prepar3D V2 and Prepar3D V3 can be installed on the same computer at the same time, STB V3.3 for Prepar3D V2 and STB V3.4 for Prepar3D V3 can also.
  • Development for STB V3.4 has ended.  Support is provided on a best effort basis for known problems only.

 

Prepare3D V2:

970596728_Prepar3DV3Tiny.png.a43cfe85502dfddba754719d48334cdd.png

  • STB V3.3 for Prepar3D V2. Final STB Client version is V3.3.2.11.
  • Not compatible with FSX, FSX-SE, Prepar3D V3 and Prepar3D V4.
  • This is a separate product compared to STB for FSX and needs to be purchased for use with Prepar3D.
  • Owners of STB V3.3 for Prepar3D V2 are entitled to use STB V3.4 for STB Prepar3D V3 free of charge.
  • Development for STB V3.3 has ended.  Support is provided on a best effort basis for known problems only.

 

Simon

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.