Jump to content
The simFlight Network Forums
Penz

How to install Mt6 in P3D v3

Recommended Posts

I'm a bit unsure of what you see Ollie, and quite frankly I'm not entirely sure of what to expect myself with regards to AI light ranges.

I just tried standing in EKCH and checking an incoming MT Airbus, it had one steady light showing from more than 6 NM out (usually the first visual cue I get of an AI aircraft at night in FSX too!), and the blinking red and green lights came on at around 3 NM range. Did that change from v2?

- JP

Share this post


Link to post
Share on other sites

Thanks for the response :)

I'll get some videos as I think there's some variation.

I'm seeing some aircraft at a real good distance away approx 7 miles with the strobe on.

Will get a video to share

Cheers

Ollie

Share this post


Link to post
Share on other sites

It's a good thing to share MT experiences Ollie. :)

Hope you're enjoying some nice v3 flying!

- JP

Share this post


Link to post
Share on other sites

I think you got the answer in the thread at AVSIM José?

I have had a busy couple of days so I didn't see your post until today, sorry.

- JP

 

I can't seem to located this thread. I got the exact same error as he did. Followed the recipe in this thread but doesn't work. No AI traffic.

Share this post


Link to post
Share on other sites

Fi5kuS, if you get the same scenery.CFG error it means that you added the wrong folder to the P3D scenery library.
 
It is the main MyTraffic folder you need to add, the one with subfolders like Aircraft, scenery and texture, it is NOT the same as the aircraft folder you added to "simobjects.cfg".
 
Try to have a look at this screenshot, showing the folder on my PC:
MT6_Folder_zpsggpiqrni.jpg

Of course, the folder will most likely be in a different location on your PC, and the folder contents slightly different.

Please check the MT6 entry you made to the scenery library. If that doesn't help, please report back. Can't have you flying around without AI.  :)
 
- JP

(Here is a link to the AVSIM thread: http://www.avsim.com/topic/475704-prepar3d-v3-and-my-traffic-6/. José's post is on page 5.).

Share this post


Link to post
Share on other sites

 

 

I tried install MT6 in P3D v3 followed instructions above and I had this issue:

 

Jose,

 

Looking at  the message, I think the problem is you drilled down one level too far. When you add an area to the scenery library, you have to navigate to the folder one level above the scenery folder:

 

If you want to add C:\Jose'sGreatScenery\Scenery, you would choose the folder C:\Jose'sGreatScenery as the location. In other words, the location for the scenery should be one level above the actual scenery folder.

Share this post


Link to post
Share on other sites

Hi folks,

Need some additional thoughts.

I followed the first thread of Penz to install MT6 (Professional) into P3d v3..............and I am showing no traffic whatsoever.

I have checked entry in simobjects.cfg and it is correct. I made sure to rename ....bgl to .bgl.old.

I installed the new traffic folder into existing traffic folder and let it overwrite any old files.

I made the correct entry into "Scenery" in P3d console and loaded it.

NO Content errors.

Again, No traffic period, even with settings at 100%.

Do I need to re-install My Traffic from scratch???

Thanks so very much for reading,

Tom

Share this post


Link to post
Share on other sites

Tom, if your MT6 was working in v2.X, there are really only two things that can go wrong. You certainly shouldn't have to reinstall.

 

One of the possible mistakes is, as already mentioned a couple of time above, adding the wrong entry to the P3D scenery library.

 

The other is adding something wrong to "simobjects.cfg". You cannot just copy my example entry, the "Path=XXX" part has to correspond to the MT6 aircraft folder on YOUR system.

 

That's really it. If the above two things are correct, you will have traffic.

 

- JP

Share this post


Link to post
Share on other sites

I too had thought I had done everything correct as far as adding to simobjects and scenerycfg. I had no traffic showing. I looked again and saw that in simobjects.cfg I had added my next Entry number correctly, BUT I had missed out the full stop.

This is what I mean:

[Entry11]

Should be

[Entry.11]

As soon as I added the full stop I had ai traffic.

A simple error, but just check your simobjects.cfg entry. May not be the cause of your lack of ai but could be.

Share this post


Link to post
Share on other sites

Hi folks,

Thank you for your help. I re-checked and found no errors, and still have NO traffic.

[Entry.10]

Title=MyTraffic Vehicles

Path="P:\MyTrafficProfessional\MyTraffic\Aircraft"

Required=True

Active=True

P:\Lockheed Martin\Prepar3D v3\Scenery\World\scenery

trafficAircraft.bgl.passive

Added Scenery in P3d - P:\MyTrafficProfessional\MyTraffic

Folks, What do I need to do.

Thanks so very much,

Tom

Share this post


Link to post
Share on other sites

how much of a fps are you losing when activating MT6?  I went from locked at 30 at KORD to now at 12FPS with 8% AI.  Any way of improving that?  I have an I7, GTX970 setup.

Share this post


Link to post
Share on other sites

First you need to add the AI aircraft to the sim. You do that by adding the path to the MT6 aircraft folder to P3D "simobjects.cfg", in the same way that the configurator does for P3D v2.

Example: My MT6 folder is "F:\MT6", so I add a new entry to "%programdata%\Lockheed Martin\Prepar3d v3\simobjects.cfg" pointing to the MT6 aircraft folder like this

[Entry.11]
Title=MyTraffic Vehicles
Path=F:\MT6\MyTraffic\Aircraft
Required=True
Active=True

It may not be [Entry.11] in your case, use the next available number in sequence.

For the scenery, I just use the in-sim scenery library manager to add "F:\MT6\MyTraffic".

The last step is to disable "[P3D3]\Scenery\World\scenery\trafficaircraft.bgl" by renaming it to "trafficaircraft.bgl.off" like the configurator does. This removes the stock Pacifica and Orbit etc. AI routes.

 

Hope this can help a couple of fellow P3Dv3'ers. :) 

 

 

Hello / Bonjour Penz,

 

Thanks you very much for your comments and advice for P3Dv3!

If I get this correctly, we Install as per the instruction guide provided for v2.5

  • Localize My Traffic to P3dv3
  • Localize P3D v3
  • Manage simobject.cfg
  • Disable the stock traffic
  • Add the in-sim scenery
  • Install your aircraft.zip file

In other words, there's not much difference from 2.5, just pointing to the v3 folders instead.

Just checking!

 

Thanks!

Share this post


Link to post
Share on other sites

Quick question:

I have successfully installed MyTraffic Professional - made necessary entries etc., and DO have traffic in P3d v3.

DO I have to / or / need to run the "Configurator" to localize to P3D v3 / or anything else in the tool?

You answer would be most appreciated.

Tom

Share this post


Link to post
Share on other sites

No, the configurator just is a tool for the Communicator to help for the supported sims, once things are set up you can do everything by hand too - it has no function for the sim itself.

Share this post


Link to post
Share on other sites

hope someone can help me...

I have followed the instructions but haven't been able to get any planes on the ground in p3d v3.

 

I changed the simobjects.cfg folder and added as in the original post. In the communicator very little happens. I have added the MyTraffic folder from my C Drive but no planes.

 

It seems to give me general traffic but I cannot see any airlines. I can also see that the mytraffic scenery is working as it overlays some of my addon scenery. But no ai airline traffic

Edited by wg89

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.