Jump to content
The simFlight Network Forums
Sign in to follow this  
Erikviktor1

WIDEFS Crashes when using USB switch on networked PCs

Recommended Posts

Hello fellow simmers,

 

I have a problem when I switch my USB mouse and keyboard  and monitor from the client Pc to the Server running P3D V2.

 

WideFs on client pC runs well and very stable and connects SAITEK panels.

Interesting: I connect the panels using the SAITEK FS2004 PANEL PLUGIN and NOT the FSX plugin!

The Saitek panels /WideFS work well until I use the USB switch to see the Server screen / connect the mouse and keyboard.

When I switch back to the client WideFS crashed and I get the following  message "FS ELIMINATOR FOR FSUIPC CLIENT application has stopped working"

 

Note; for pratical purposes and development my rig is set up like a server with 2 client PC and a USB switch that allows me to view and control each PC as required. I use this during development, not in the regular home cockpit.

 

It took me a while to find out that the problem seemed to be related to the USB switching.

 

Fsuipc log clearly shows the USB/HID disconnect and reconnect..

" ++++ HID USB DEVICE RECONNECTED; REINITIALISING FSUIPC CONNECTIONS"

 

 

A few observations:;

WIdeFS and SAITEK panels run well on client when not switching USB mouse or when using a separate mouse connected to PC.

Crash is WIDEFS/FSUIPC related. saitek Panels plugin 2004 does NOT crash.

I installed the panels and WideFS on the 2d Client and the same problem comes up, so it doesn't seem to be related to any client hardware or software issue.

I use a network (ethernet) switch. When using this switch instead of a regular router, the server PC HOMEGROUP settings are lost everytime I reboot and have to be readjusted.

 

As it seems to be FSUIPC related, is there anything I can change in the logging settings that might avert this?

 

Could the crash be related to a dataflow issue caused by the USB disconnect/connect logged by FSUIPC5 (as shown by the log) and maybe an unstable or damaged ethernet switch?

But then why is no other interface affected?.

 

Other software that use client interfaces such as Simplugins and Flight1 GTN running on clients are not affected by this problem and run very stable.

 

Reinstalling FSUIPC4, P3D, add-ons did NOT solve the probem.

Updating hardware drivers on server and clients did not solve the problem. No hardware problems.

 

I hope someone can help explain how to solve this.

 

Happy landings!

 

Erik

 

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.