Jump to content
The simFlight Network Forums
patrickdoman

FSUIPC updated, but having issues with CH Pro pedals and the rudder config

Recommended Posts

Pete,

Good evening. I am wondering about an issue I am experiencing on my machine. I updated to Windows 10 last year to get beyond the sleeping controllers in Windows 8.

I got by that issue but then upgraded to Prepar 3D v 2.x.

 

From there, I began having some problems with the controllers.
I had invested in the paid version of your application and recently purchased it again. Lost my old key. When I go to Prepar 3D i had the activate FSUIPC

 

 

I went through some articles on the website here. I tried to figure out how to configure FSUIPC to manage my controllers and the buttons.

I couldn't figure them all out.
For instance the flaps. Now, when I try to put the flaps down, the gear goes down as well. I think the simulator keys are still activated.

How do I go about resetting FSUIPC back to defaults settings wise? so I can go through and document the mappings as they are in the simulator.

 

I am looking to begin the process of purchasing a new flight sim chair and monitor mount. All the switches and knobs as well.

When I do this I am sure I will need to reconfigure everything.

 

I setup a profile in FSUIPC for Prepar3d.

But in doing that, I think I messed things up a bit.

Now the settings are conflicting.

I noticed that when I try to use the rudder, even though its setup in FSUIPC and I have unchecked enable controller in Prepar, I can't use the pedals to turn.

With that I want to start over.

Is there a way to completely disable the controller in Prepar? Or do I need to go in each time to uncheck the box each time? As I add more devices to this mix and begin to switch out my current setup and build the Flight Simulator out, I want to make sure I can easily program the devices. There are soo many settings and options, it would be nice if there were a way to simply import the settings from the simulator into the FSUIPC program and then be able to disable the settings in the simulator.

 

 I know you're busy so I appreciate your time.

 

 

Share this post


Link to post
Share on other sites

I went through some articles on the website here. I tried to figure out how to configure FSUIPC to manage my controllers and the buttons.

I couldn't figure them all out.

 

Did you try the FSUIPC User Guide, instaslled in your FSUIPC Documents folder? It's simple enough stuff. Assign as you wish, calibrate if needed.

 

For instance the flaps. Now, when I try to put the flaps down, the gear goes down as well. I think the simulator keys are still activated.

 

You don't mean "keys" I think, but controllers. Why didn't you disable the controllers completely in the simulator, then, as instructed in the user guide?

 

You can assign in the sim OR in FSUIPC but NEVER both or you will get conflicts and other odd things happening. Just disable controllers completely in the sim if you want to assign in FSUIPC!

 

How do I go about resetting FSUIPC back to defaults settings wise?

 

Just delete the FSUIPC4.INI file in the Modules folder. ALL of your FSUIPC settings are in that file.

 

I setup a profile in FSUIPC for Prepar3d.

But in doing that, I think I messed things up a bit.

Now the settings are conflicting.

 

Setting up profiles cannot cause conflicts. If you have conflicts you have forgotten to disable controllers in the sim.

 

I noticed that when I try to use the rudder, even though its setup in FSUIPC and I have unchecked enable controller in Prepar, I can't use the pedals to turn.

 

You've not set up the rudder in FSUIPC properly then. You'd need to tell me what you assigned it to and in what mode. For instance, if you assigned it in the mode "direct to FSUIPC ..." then you must also calibrate in FSUIPC. The control you assigned to may also matter. To assign to exactly the same control as the sim you use the FS control "Axis rudder set". Different add-on aircraft may need different treatment for best results.

 

Is there a way to completely disable the controller in Prepar? Or do I need to go in each time to uncheck the box each time?

 

Just uncheck the "enable controllers" selection in the Options - Settings - Controls dialogue. It will be saved when you close down.

 

There are soo many settings and options, it would be nice if there were a way to simply import the settings from the simulator into the FSUIPC program and then be 

 

No point. The whole point of using FSUIPC is to enable you do do more, not the same. You don't HAVE to assign anything in FSUIPC to use facilities like the calibration. The reason there are so many options is that FSUIPC is a set of tools, for you to use as you wish. If you only want something simple and straightforwards, why assign in FSUIPC at all? You can still calibrate there if you wish. The two things are separate. Calibration works on the FS control values NOT on the devices.

 

Pete

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.