Jump to content
The simFlight Network Forums

Connecting P3D v3 to EPIC


Recommended Posts

Hello, 

I am working on an existing SIM that uses EPIC and is currently running under ESP.  I am attempting to install P3D v3.  I am fairly new to all of this and currently my EPIC appears to load correctly and P3D loads along with FSUIPC.  I have no connection between P3D and the EPIC system.  There is an old installation of P3D V1.x on the "legacy disks"  that does connect properly to EPIC but I haven't been able to figure out what I am missing. 

 

Rather than trouble shooting this at such a high level I am hoping for some guidance in locating the any documentation that would just explain what components need to be aligned to make this all work.  I am suspect that a SimConnect issue may be behind all of this. 

 

Below is my FSUIPC.ini file Any help would be appreciated.

 

Steve

 

[General]
UpdatedByVersion=4949p
History=R6KPB830EBYWA2HF6VO9V
AxesWrongRange=No
TCASid=Flight
TCASrange=40
AxisCalibration=No
DirectAxesToCalibs=No
ShowMultilineWindow=Yes
SuppressSingleline=No
SuppressMultilineFS=No
AxisIntercepts=No
DontResetAxes=No
InitDelay=0
GetNearestAirports=No
OOMcheck=Yes
WeatherReadFactor=2
WeatherRewriteSeconds=1
CustomWeatherModify=No
SimConnectStallTime=1
InitialStallTime=10
NormalStallTime=1
LuaRerunDelay=66
Console=No
InitDelayDevicesToo=No
NewInterceptTextMenu=No
UseSystemTime=No
UseMidMouseBtn=Yes
MouseWheelMove=No
MouseWheelTrim=No
MouseWheelTrimSpeed=1
JoystickTimeout=20
PollGFTQ6=Yes
BlankDisplays=No
FixControlAccel=No
FixMachSpeedBug=No
NewDeleteVehiclesForAES=No
AutoScanDevices=Yes
AssignJoystickIDs=Yes
VisibilityOptions=No
OneCloudLayer=No
CloudTurbulence=No
CloudIcing=No
GenerateCirrus=No
SuppressCloudTurbulence=No
MaxIce=-4
MinIce=-4
UpperWindGusts=No
SuppressWindTurbulence=No
SuppressWindVariance=No
WindTurbulence=No
TurbulenceRate=1.0,5.0
TurbulenceDivisor=20,20,40,40
SuppressAllGusts=No
MaxSurfaceWind=0
WindLimitLevel=200
WindDiscardLevel=400
WindAjustAltitude=No
WindAjustAltitudeBy=2000
SmoothBySimTime=No
WindSmoothing=No
WindSmoothness=2
WindSmoothAirborneOnly=Yes
PressureSmoothness=0
TemperatureSmoothness=0
DisconnTrimForAP=No
ZeroElevForAPAlt=No
ThrottleSyncAll=No
WhiteMessages=No
ShowPMcontrols=No
SpoilerIncrement=512
MagicBattery=No
RudderSpikeRemoval=No
ElevatorSpikeRemoval=No
AileronSpikeRemoval=No
ReversedElevatorTrim=No
ClockSync=No
ClockSyncMins=5
ClearWeatherDynamics=No
OwnWeatherChanges=No
TimeForSelect=4
LoadFlightMenu=No
LoadPlanMenu=No
PauseAfterCrash=No
BrakeReleaseThreshold=75
SaveDataWithFlights=No
ZapSound=firework
ShortAircraftNameOk=Substring
UseProfiles=Yes
EnableMouseLook=No
DelayedMouseLookZoom=No
OOMcheckInterval=10
FSVersionUsed="Lockheed Martin® Prepar3D® v3",3.2.3.2
SimConnectUsed=3.2.0.0

[JoyNames]
AutoAssignLetters=No
0=EPIC USB (HID)
0.GUID={ABCEB6A0-3292-11E0-8006-444553540000}
1=EPIC USB (HID)
1.GUID={ABCEB6A0-3292-11E0-8007-444553540000}
2=EPIC USB (HID)
2.GUID={ABCEB6A0-3292-11E0-8008-444553540000}
3=EPIC USB (HID)
3.GUID={ABCEB6A0-3292-11E0-8009-444553540000}

[WideServer]
WideFSenabled=Yes
AdvertiseService=1
Port=8002
Port2=9002

[sounds]
Path=C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\Sound\
Device1=Primary Sound Driver
Device2=Speakers (3- Realtek High Definition Audio)
Device3=Realtek Digital Output(Optical) (3- Realtek High Definition Audio)
Device4=Realtek Digital Output (3- Realtek High Definition Audio)

[Axes]
PollInterval=10
RangeRepeatRate=10

[buttons]
PollInterval=25
ButtonRepeat=20,10

[AutoSave]
Next=1
Interval=60
Files=10
SaveOnGround=No
AutoSaveEnabled=No

[GPSout]
GPSoutEnabled=No

[GPSout2]
GPSoutEnabled=No
 

 

 

Link to comment
Share on other sites

I am working on an existing SIM that uses EPIC and is currently running under ESP.  I am attempting to install P3D v3.  I am fairly new to all of this and currently my EPIC appears to load correctly and P3D loads along with FSUIPC.  I have no connection between P3D and the EPIC system.  There is an old installation of P3D V1.x on the "legacy disks"  that does connect properly to EPIC but I haven't been able to figure out what I am missing. 

 

iMy EPIC driver for FSX/ESP was released only in Beta form 13 (THIRTEEN) years ago and never fully tested due to lack of harware on my part and lack of users. There is no way I can actually support it, but if it works with current versions of FSUIPC on P3D 1.x (also now unsupported) it should certainly work with P3D 3. So I can only think it's something to do with your configuration.

 

Below is my FSUIPC.ini file Any help would be appreciated.

 

The FSUIPC.ini file has nothing to do with any additional modules. It just stores your settings, those made from the FSUIPC menu. None are related to anything outside FSUIPC and WideFS. Sorry. 

 

Pete

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.