Jump to content
The simFlight Network Forums
Lampoil

Ultimate Traffic 2 AI disappear and reappear

Recommended Posts

Hi,

 

I have a problem with Ultimate Traffic 2 & Super Traffic Board 3 which I hope someone could help me with.

 

I have FSX & T360 as AI running fine with STB3, lately I added UT2 to my setup and some of the UT2 AI disappear and reappear every few minutes but everything else seems to be working fine.

 

I have left T360 in the set up as I use the military and cargo BGL/AI.

 

All works normal as STB shows the departure times and destinations of the UT2 AI as ???? until I connect UT2 and STB via the FSX add-on menu, after approx 1 minute the departure times and destination then show as expected, however some of the UT2 AI are shown as massively delayed and STB removes them, 1 minute later they reappear in FSX and STB with ???? and this sequence carries on!

 

This only happens when STB is running.

 

Appreciate any help

 

LO

Share this post


Link to post
Share on other sites

All works normal as STB shows the departure times and destinations of the UT2 AI as ???? until I connect UT2 and STB via the FSX add-on menu, after approx 1 minute the departure times and destination then show as expected, however some of the UT2 AI are shown as massively delayed and STB removes them, 1 minute later they reappear in FSX and STB with ???? and this sequence carries on!

 

The "???" is the way Ultimate Traffic 2 works, it does not publish it's schedule information until at least a minute after the AI is created by UT2 or transmissions start to STB.

 

What are the departure times, compared to the current time in the simulator, of those aircraft that are deleted?

 

Simon

Share this post


Link to post
Share on other sites

Hi Simon,

 

Thank you for showing an interest in my problem.

 

I am not at my pc buts lets say the time in the Sim is Saturday 17:00, AI is spawned at the airport parking spots for some of the up coming departures, then there are also AI parked for the following day Sunday 5am etc.

 

Once the UT2 transmission starts and updates the departure times STB deletes the AI for the Sunday stating they are delayed, one minute later and UT2 spawns the AI again and updates STB  with ????, etc etc.

 

Before I installed UT2 STB did not delete the T360 AI spawned for the following day, this problem is only with the UT2 AI.

 

I have tried to alter the settings in STB to prevent the deletion of delayed AI but they still get deleted and reappear.

 

 

Jim 

Share this post


Link to post
Share on other sites

Hi Jim

The problem is a familar one.  To cut a long story short the UT2 scheduling engine seems to have some issues around the end of the week.  A number of flights can get created by the engine, but they never depart (or I've never waited around long enough to find out if they ever do!).  Based on the information received from UT2, STB thinks these flights are scheduled for Sunday last week rather than Sunday tomorrow in your example, so from that sense they are late.  I'm afraid I was not able to get this problem fixed in UT2, and there's nothing I can do on my side to "correct" them.

 

Try unchecking all the options in the "Flight Control" section of the "Board Control" tab in Settings.  If this does not help, I imagine I can add a new setting to disable STB's handling of this situation.

Thanks
Simon

Share this post


Link to post
Share on other sites

Hi Simon,

 

I unchecked all the settings in the board control tab but still the same.

 

I set up at EGSS at 16:00 today Thur 5th May and there was 16 AI planned for departure until 17:30, these AI are fine,  then there was another 18 AI which STB stated was to depart on Monday between 5:30-6:10 am, all of these AI disappear and reappear. Unfortunately if I reduce the amount of AI it also reduces the upcoming schedules flights as well.

 

I wonder if this be something Traffic 360 could have altered in FSX to ensure airports had traffic as their flight plans were not real schedule.

 

I also note in the Common setting on the STB data interpretation tab the "remove delayed and Cancelled Flights after" option, but the most you can enter is 900 minutes.

 

Any settings alteration you can suggest would be helpful and appreciated.

 

Regards

 

Jim

Share this post


Link to post
Share on other sites

Hi Jim,

The way you describe the problem, it sounds like the UT2 scheduling issue I've been talking about.  What I'll consider is implementing a setting such that you can turn off the interpretation of UT2 flights as delayed and ultimately deleted.

 

May I ask please, the exact version of STB you have? You can find this in the Help -> About window.

 

Simon

Share this post


Link to post
Share on other sites

Hi Simon,

 

STB is on the latest version 3.2.1.7.

 

Just for info I have STB on a networked laptop and use STB server which is also on on the latest version.

 

Regards

 

Jim

Share this post


Link to post
Share on other sites

Hi Jim

I changed the way the "UT2 Interpretation engine" works in STB to try to understand what UT2 is intending when creating these flights.  So far it seems to be working, at least in the sense they no longer get into the cancel/delete/reappear loop.  It may have side affects as it slightly changes the assumptions made for all "yet to depart" aircraft created by UT2, but so far I've not seen a direct issue.  However I then noticed a problem where the simulator was not sending a clock signal after the user visits the simulator menus during a flight, and that was causing schedule interpretation problems.  At the moment I don't think it's related to the other changes, but I'm not at the bottom of it yet.  When I have an angle on it, I can move forward.

 

Simon

Share this post


Link to post
Share on other sites

OK, I think I need to let this one role.  The problems with the clock signal are difficult to reproduce, I've not seen it in days now so we'll address it if it's a widespread issue in the field.  I suspect if it is there at all, it's a problem that's always been there from day 1.

First check you are on the latest regular STB maintenance, V3.2.1.7.  If you are, then you can download and apply these updates.  They are just file replacements, so just backup your files in your STB installation folder then drop the new files from the zip in there.

There are two changes in the package:

1) A change to the UT2 interpretation engine to address the issue of UT2 traffic getting stuck on a cancelled/deleted/re-spawn loop.

2) A fix for MyTraffic V6 putting double quotes into the simulator cfg file, and causing problems during airport compilation.

If you try this update, please feedback your experiences.

 

Many thanks

Simon

STB_FSX_Hotfix_3.2.1.10.zip

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi Simon,

Sorry for the delay as I have been very busy and it almost slipped my mind, however thanks for the hotfix as it has certainly helped with my issue (no more disappearing and re-appearing planes) .

Thanks

Jim

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.