Jump to content
The simFlight Network Forums

Please help X-55 not being seen!! Ver 4.955


Recommended Posts

Hi,  I have FSX with FSUIPC 4.955 not working.   I have X-55 Rhino HOTAS with Saitek rudders and for whatever reason it is flat out not seeing my hardware.  The hardware is flat out not seen by FSUIPC.  I got to try to calibrate or set the throttle or the buttons...nada   Here is my .ini file.    This is for FSX by the way.  

 

Thanks in advance!!

 

[General]
UpdatedByVersion=4955
History=9EQNXNA7CIA84L0EOQK5R
InitDelayDevicesToo=No
NewInterceptTextMenu=No
UseSystemTime=No
UseMidMouseBtn=Yes
MouseWheelMove=No
MouseWheelTrim=No
MouseWheelTrimSpeed=1
JoystickTimeout=20
PollGFTQ6=Yes
BlankDisplays=No
FixControlAccel=No
FixMachSpeedBug=No
DeleteVehiclesForAES=Yes
AutoScanDevices=Yes
AssignJoystickIDs=Yes
VisibilityOptions=No
OneCloudLayer=No
CloudTurbulence=No
CloudIcing=No
GenerateCirrus=No
SuppressCloudTurbulence=No
MaxIce=-4
MinIce=-4
UpperWindGusts=No
SuppressWindTurbulence=No
SuppressWindVariance=No
WindTurbulence=No
TurbulenceRate=1.0,5.0
TurbulenceDivisor=20,20,40,40
SuppressAllGusts=No
MaxSurfaceWind=0
WindLimitLevel=200
WindDiscardLevel=400
WindAjustAltitude=No
WindAjustAltitudeBy=2000
SmoothBySimTime=No
WindSmoothing=No
WindSmoothness=2
WindSmoothAirborneOnly=Yes
PressureSmoothness=0
TemperatureSmoothness=0
DisconnTrimForAP=No
ZeroElevForAPAlt=No
ThrottleSyncAll=No
WhiteMessages=No
ShowPMcontrols=No
SpoilerIncrement=512
MagicBattery=No
RudderSpikeRemoval=No
ElevatorSpikeRemoval=No
AileronSpikeRemoval=No
ReversedElevatorTrim=No
ClockSync=No
ClockSyncMins=5
ClearWeatherDynamics=No
OwnWeatherChanges=No
TimeForSelect=4
LoadFlightMenu=No
LoadPlanMenu=No
PauseAfterCrash=No
BrakeReleaseThreshold=75
SaveDataWithFlights=No
ZapSound=firework
ShortAircraftNameOk=Substring
UseProfiles=Yes
EnableMouseLook=No
DelayedMouseLookZoom=No
AxesWrongRange=No
TCASid=Flight
TCASrange=40
AxisCalibration=No
DirectAxesToCalibs=No
ShowMultilineWindow=Yes
SuppressSingleline=No
SuppressMultilineFS=No
AxisIntercepts=No
DontResetAxes=No
InitDelay=0
GetNearestAirports=Yes
OOMcheck=Yes
OOMcheckInterval=10
WeatherReadFactor=2
WeatherRewriteSeconds=1
CustomWeatherModify=No
SimConnectStallTime=1
LuaRerunDelay=66
Console=No
Annotate=Yes
NewDeleteVehiclesForAES=No
LogOptionProtect=Yes
FSVersionUsed="Microsoft Flight Simulator X",10.0.61637.0
SimConnectUsed=10.0.61259.0

[JoyNames]
AutoAssignLetters=No
1=Saitek Pro Flight X-55 Rhino Stick
1.GUID={6908BF30-A67A-11E5-8005-444553540000}
0=Saitek Pro Flight Rudder Pedals
0.GUID={6908BF30-A67A-11E5-8001-444553540000}
2=Saitek Pro Flight X-55 Rhino Throttle
2.GUID={3F579C00-AAEF-11E5-8001-444553540000}

[Axes]
PollInterval=10
RangeRepeatRate=10
0=0R,256,F,65696,0,0,0    -{ TO SIM: RUDDER_SET }-
1=2Y,256,F,65697,0,0,0    -{ TO SIM: THROTTLE_SET }-

[Buttons]
PollInterval=25
ButtonRepeat=20,10

[AutoSave]
Next=1
Interval=60
Files=10
SaveOnGround=No
AutoSaveEnabled=No

[GPSout]
GPSoutEnabled=No

[GPSout2]
GPSoutEnabled=No

[WideServer]
WideFSenabled=Yes

[Sounds]
Path=D:\FSX\Sound\
Device1=Primary Sound Driver
Device2=Speakers (Realtek High Definition Audio)
Device3=Realtek Digital Output (Realtek High Definition Audio)
Device4=NS-37D20SNA14-0 (NVIDIA High Definition Audio)
Device5=NS-37D20SNA14-C (NVIDIA High Definition Audio)
Device6=NS-37D20SNA14-4 (NVIDIA High Definition Audio)

[JoystickCalibration]
AllowSuppressForPFCquad=Yes
ExcludeThrottleSet=No
ExcludeMixtureSet=Yes
ExcludePropPitchSet=Yes
SepRevsJetsOnly=No
ApplyHeloTrim=No
UseAxisControlsForNRZ=No
FlapsSetControl=0
FlapDetents=No
ReverserControl=66292
Reverser1Control=66422
Reverser2Control=66425
Reverser3Control=66428
Reverser4Control=66431
MaxThrottleForReverser=256
AileronTrimControl=66731
RudderTrimControl=66732
CowlFlaps1Control=66162
CowlFlaps2Control=66163
CowlFlaps3Control=66164
CowlFlaps4Control=66165
SteeringTillerControl=0
MaxSteerSpeed=60
Throttle1=-16380,-512,512,16380/32

[Profile.f18]
1=VFA-105 "Gunslingers" CAG

[JoystickCalibration.f18]
AllowSuppressForPFCquad=Yes
ExcludeThrottleSet=Yes
ExcludeMixtureSet=Yes
ExcludePropPitchSet=Yes
SepRevsJetsOnly=No
ApplyHeloTrim=No
UseAxisControlsForNRZ=No
FlapsSetControl=0
FlapDetents=No
ReverserControl=66292
Reverser1Control=66422
Reverser2Control=66425
Reverser3Control=66428
Reverser4Control=66431
MaxThrottleForReverser=256
AileronTrimControl=66731
RudderTrimControl=66732
CowlFlaps1Control=66162
CowlFlaps2Control=66163
CowlFlaps3Control=66164
CowlFlaps4Control=66165
SteeringTillerControl=0
MaxSteerSpeed=60
Throttle=-7040,7040

[Profile.all]
1=Virtavia C-17A 0

[Axes.all]
RangeRepeatRate=10
0=0R,256,F,65696,0,0,0
1=2Y,256,F,65697,0,0,0
atRate=10
0=0R,256,F,65696,0,0,0
1=2Y,256,F,65697,0,0,0

[Profile.F15]
1=F15E_tiger
 

Link to comment
Share on other sites

Hi,

I have FSX with FSUIPC 4.955 not working. 

this might not be the right wording as already the attached INI file shows it is working.

You always need to attach the latest FSUIPC4 log file.

Can you see and calibrate that controller in Windows Controller panel (in Systems panel)?

 

Regards

Thomas

Link to comment
Share on other sites

6 hours ago, Kungfoogrip said:

I have X-55 Rhino HOTAS with Saitek rudders and for whatever reason it is flat out not seeing my hardware.  The hardware is flat out not seen by FSUIPC.

Saitek seems particularly prone to these installation errors. 

Did you check the FAQ subforum? The first thread is " Fixing joystick connections not seen by FSUIPC ".

As Thomas asks, is it seen by FSX?

And looking at your INI:

6 hours ago, Kungfoogrip said:

[JoyNames]
AutoAssignLetters=No
1=Saitek Pro Flight X-55 Rhino Stick
1.GUID={6908BF30-A67A-11E5-8005-444553540000}
0=Saitek Pro Flight Rudder Pedals
0.GUID={6908BF30-A67A-11E5-8001-444553540000}
2=Saitek Pro Flight X-55 Rhino Throttle
2.GUID={3F579C00-AAEF-11E5-8001-444553540000}

[Axes]
PollInterval=10
RangeRepeatRate=10
0=0R,256,F,65696,0,0,0    -{ TO SIM: RUDDER_SET }-
1=2Y,256,F,65697,0,0,0    -{ TO SIM: THROTTLE_SET }-

The X-55 is seen twice, once as a Stick and again as a Throttle. Not only that but you actually have an assignment made to the Throttle!

There are furthur assignments later, too, in a Profile called "all":

6 hours ago, Kungfoogrip said:

[Axes.all]
RangeRepeatRate=10
0=0R,256,F,65696,0,0,0
1=2Y,256,F,65697,0,0,0
atRate=10
0=0R,256,F,65696,0,0,0
1=2Y,256,F,65697,0,0,0

Though that section appears to be corrupted, with an incomplete line and duplicate entries. Looks like your FSX crashed or something whilst the INI file was being written. Either that or it's some sort of disk corruption.

You also have the throttle calibrated:

6 hours ago, Kungfoogrip said:

Throttle1=-16380,-512,512,16380/32

So, are all these settings wrong? How were they created if the X55 is "flat out not seen by FSUIPC"? FSUIPC cannot guess that you have an X55 and do some assignments and calibration on its own volition. It only does wat you tell it.

Pete

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.