Jump to content
The simFlight Network Forums

Can some explain this in the FSUIPC log please


Recommended Posts

Hi guys

I've been suffering from a random stutter for a while, I've never thought of looking in the FSUIPC log for help.  I've noticed this which coincides with my mini freezes...it's reported multiple times.  I also have LINDA running and see this in the LINDA console in realtime as well.

   262050 Sim stopped: average frame rate for last 29 secs = 29.3 fps
   380237 Sim stopped: average frame rate for last 99 secs = 30.3 fps
   728290 D:\Steam Library\steamapps\common\FSX\EFB_current_garmin.pln
   833435 Sim stopped: average frame rate for last 379 secs = 25.5 fps

I do have the AivlaSoft EFB program installed and that's where my knowledge ends!  I've run a couple of flights without this running and I still get the same error log. 

So I would like to know if I am misreading this, if not what can I do to fix it??

I run FSX-SE with Steve DX10 fixer using latest version of FSUIPC and Linda, if you need any other details please let me know.

Thanks
Sid

Link to comment
Share on other sites

1 hour ago, sidfadc said:

I've noticed this which coincides with my mini freezes...it's reported multiple times.

For a technical explanation, the "Sim Stopped" message is only logged on two events, both notified to FSUIPC by SimConnect:

The most usual one is "SimStop": described by MS as follows:

The simulator is not running. Typically the user is loading a flight, navigating the shell or in a dialog.

Note that this does not include "pause" which pauses simulator time but not all of the other things going on in the sim,

and "MultiplayerSessionEnded", described in the P3D documentation as:

sent when the multiplayer race session is terminated. If a client player leaves a race, this event will be returned just to the client. If a host leaves or terminates the session, then all players will receive this event. This is the only event that will be broadcast to all players.

Autosave doesn't normally signal either event as it isn't really a stop at all, but it can cause hesitations when using add-on aircraft which themselves freeze the sim whilst collecting all their data to save. The PMDG aircraft are especially noticeable for this.

However, autosave hesitations would be regular, as the interval set for them. If your freezes do really coincide in time with the Sim Stopped logging, then they are evidently very irregular -- in your extract there's 118 seconds (nearly 2 minutes) between the first two, then another 453 seconds (over 7.5 minutes) to the next!

You'll probably need to do some elimination tests, running without many add ons then gradually adding them back and re-testing each time.

Pete

 

Link to comment
Share on other sites

Thanks for the input guys.

I definitely don't have autosave enabled, I checked fsuipc.ini.  Next flight I'll post the complete log file.  For some daft reason last night I right clicked on the line in the linda console and selected "don't report this anymore" or something similar.  Now when the sim freezes it doesn't report the line...

D:\Steam Library\steamapps\common\FSX\EFB_current_garmin.pln

Is there anyway to revert this change so it does report?

In terms of the timings Pete, yes the stutters are very random and sporadic!

Considering I have a lot of addons any idea what order to do this in? Best way to turn an add on off by deactivating the scenery in the library?  Things live active sky I can just not run with the sim.  I don't think the issue is relating to a particularly payware aircraft because of the 3 I normally fly (PMDG 737, A2A Comanche & MJCQ400) II experience stutter with all three.

Link to comment
Share on other sites

57 minutes ago, sidfadc said:

For some daft reason last night I right clicked on the line in the linda console and selected "don't report this anymore" or something similar.  Now when the sim freezes it doesn't report the line...

D:\Steam Library\steamapps\common\FSX\EFB_current_garmin.pln

I thought you were saying the sim was freezing then the "Sim stopped" line appeared, which seems more reasonable to me -- that's why I explained when Sm stopped was logged in so much detail.

The line showing a PLN filename is just logging the fact that a plan was just loaded into FS's GPS.

59 minutes ago, sidfadc said:

Is there anyway to revert this change so it does report?

I don't know anything at all about LINDA. I certainly didn't know it loaded plans. But if the plan loading is causing the hesitations, why do you want them back?

1 hour ago, sidfadc said:

Considering I have a lot of addons any idea what order to do this in? Best way to turn an add on off by deactivating the scenery in the library?

The add-ons I was referring to would not be scenery. Scenery should not cause hesitations, unless you are talking about slow loading of buildings when approaching airports. I think most folks suffer that with the heavier airports.

Pete

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.