Jump to content
The simFlight Network Forums

Recommended Posts

First of all hello to everybody!

I use a registrered version of FSUIPC4 , previously everything was working fine and then since a few days I get an error message with FSX-SE saying

Flight Simulator has detected a problem with a third-party software program(add-on):

Name: FSUIPC4DLL.FS new universal PC interface
Version: 4.955c
Company: Peter L.Dowson
File: Modules\FSUIPC4.dll

Of course if I say YES it crashes FSX-SE.

I 've no problem so far with this version of FSUIPC on my P3DV3 install.

I've migrated from Win8.1 to Win10, almost a month ago, but this problem occured only very recently previously I had no problem with it.

My specs are: 

FSX SE - P3D 3.3.5 - Windows 10 64 bit, Intel core i7-4720HQ, CPU 2.6 GHz, 32 GB RAM, NVidia GeForce GTX 980M. 

I hope you can help me 

Best regards

Pat Mussotte

Link to post
Share on other sites
8 minutes ago, Pat Mussotte said:

Of course if I say YES it crashes FSX-SE.

No "of course" about it. I get such warnings a lot with BGLMANX.DLL (the module used by GSX), but sometimes it continues okay.

However, there's really no way I can help without more information. If FSX-SE crashes there will be crash details -- either grab them at the time, or refer to the Windows "Event Viewer" for the application log showing the error.

Also, if FSUIPC is loading and running at all there will be a Log produced, "FSUIPC4.LOG", in the FS modules folder. Please find that and paste its contents here. It will show how far FSUIPC is getting.

Pete

 

Link to post
Share on other sites
1 hour ago, Pat Mussotte said:

Yes! I launch again FSX-SE and this time no error message! It's far beyond my understanding why I get an error message after playing without trouble for at least a month!

I think it's a SimConnect module loading glitch, which is a bug in FSX and FSX-SE related to its "trust" checking (the system which asks if you really want to load a module when it's new or a new version).  Microsoft knew about it right back to the start of FSX, but never managed to fix it because it is so elusive -- it doesn't happen to everyone, nor very often, but sometimes can be very persistent.

I think it is some timing clash between different activities during loading, and it very very timing dependent.  The module concerned (FSUIPC in this case) doesn't actually get to run by the time the problem occurs, it is in the loading process.

Pete

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.