Jump to content
The simFlight Network Forums
Sign in to follow this  
FeelThere

KJFK FOR TOWER!3D HAS BEEN RELEASED

Recommended Posts

Dear Controllers,

We just released our first airport add-on for Tower!3D. 
Based on the popularity of the Tower!2011 sim, we picked KJFK for our first release. KJFK for TOwer!3D requires SP2 for Tower!3D.
Nyerges Design will update their Real Traffic add-on within 1 or 2 days to make it compatible with KJFK. It will be a free download and we will inform you as soon as it will be available. Until then only the fictional traffic will be shown.
Once again to avoid confusion/flaming; there will be a FREE update from Nyerges Design within 1-2 days to provide realistic schedules, traffic and visuals (as we heard it will also include some new visual models for some new plane types too)

Share this post


Link to post
Share on other sites

I just bought this addon and it runs beautifully. I have been running Real Traffic so I could not just install KJFK. I figured the best way to install and run this was to move my old installation of Tower 3D and reinstall from scratch. I only ran it for a few minutes but I had no issues. I can hardly wait to run this with Real Traffic (and Real Color).

Share this post


Link to post
Share on other sites

Can you confirm whether the the old terminals 3 and 6 were removed, or if they are still present, as they were in the early screenshots from several months ago?  Just curious if they are using the present-day layout, or the old one that was used in KJFK for tower2011?

Share this post


Link to post
Share on other sites
16 minutes ago, achilles1971 said:

There are planes that you clear for takeoff and never appear in the DBRITE Radar...so you can't release the "contact departure" message. Am i missing something ??

1. Do you have SP2 installed?  This is required.

 

2. Do you have Real Traffic installed?  Another user mentioned something about not being able to install it if Real Traffic is already installed.  I don't have it yet, but just wondering that might be the issue?

 

3. Have your tried uninstalling, re-downloading KJFK, and reinstalling?  Could be a simple as something going wrong during the download or installation.

Share this post


Link to post
Share on other sites

1.Ok

2.OK.

3. Done 

Still have the problem.

50 % of the ariplanes don't get airbone...in fact they seem to crash against the the trees at the end of 31L/31R

I've got the message "successful takeoff" but they never appear in the DBRITE radar so i can't release the message "contact departure"

The other 50% are ok

 

Share this post


Link to post
Share on other sites

Okay, I just bought KJFK and am seeing it too.  My initial observations indicate that it may be related to aircraft type.  Specifically, aircraft type JT1 seems to always encounter this issue.  I have not thoroughly tested all types yet.  My guess would be that something was changed in this aircraft's runway parameters, since it appears the aircraft never leaves the ground.  Can anyone confirm that they are not encountering this problem with this aircraft type?

 

P.S. I would be happy to generate a .bat file, but cannot since this option still does not work on my machine.

Share this post


Link to post
Share on other sites

I wonder if this problem is caused by Real Traffic as it changes the aircraft types and models. I did a clean install (SP2 version) and did not reinstall Real Traffic. I have over 2 hours on the game at JFK and have had no issues.

  • Upvote 1

Share this post


Link to post
Share on other sites

Possibly, though it really should not, and there was nothing in the instructions that said we needed to uninstall Real Traffic.  Moreover, it seems odd that only some (possibly just one) of the fake aircraft types are affected, rather than all of them.

Share this post


Link to post
Share on other sites

Gentlemen,

With your report please include:
-the date of your purchase and the name of the installer. Just yesterday we posted an SP2a (which is not required if you have SP2 as it fixes some problem with future add-ons and should not have any effect on KJFK, but let's see)
-do you have Real Traffic included and if so, please try with a clean (non RT) installer.

As soon as we can figure out what is wrong we can jump into that and fix it for you. Please try to give us information as it didn't happen on any test computer. Please leave the noise out from this topic to allow us to collect information the fastest way.

 

Thank you

 

Vic

Share this post


Link to post
Share on other sites

Thank you for getting back to us.  I currently Have SP2 and Real Traffic Installed,and am having the problem.  I will now install SP2a and see if that makes a difference.  I will get back to you ASAP.

  • Upvote 1

Share this post


Link to post
Share on other sites

Okay.  Test #1  SP2a does not resolve the problem.  I can also confirm that it only occurs with aircraft type JT1, and that it always occurs with this aircraft, even using Runway 31L - full length.  RJ1 and JTO/Heavy both seem to work fine.  I have not as yet seen any turpoprop traffic at this airport. 

Next, as requested, I will try uninstalling RT and see how that affects it.

Share this post


Link to post
Share on other sites

Test #2:  Running KJFK without Real Traffic DOES eliminate the problem.  However, I gather that the only way to do this for someone who already has RT is to completely uninstall the sim and delete all the internal folders.  Simply removing RT3D by using the uninstall tool from the control panel does not solve the problem, since apparently RT overwrites something in the default data for the JT1 (see below). 

By the way, before uninstalling Tower3D, I tried removing my Extensions folder and running KLAX with the default traffic, and the JT1 had the same problem there too!  Again RT is doing something to the JT1.

Finally, there is also an issue with the KJFK installer.  In order for the airport to work, it must be installed in the Extensions folder (by default, it simply drops an Airfield folder into the root directory of the sim which DOES NOT work).  If the user does not already have an Extensions folder, the installer does not create one, nor are there an instructions telling the user this.  Thus a new user, with no experience in modifying schedules, and who does not have RT installed, would likely have no idea how to get this add-on to work.  That seems like a big problem to me, and so the installer needs some modification on the developer's end.

 

I hope this helps.

 

Andrew

 

Share this post


Link to post
Share on other sites

Thank you Andrew,

 

The first problem will be solved hopefully by tomorrow as Nyerges will update RT for KJFK and then the problem should be solved. The install path is a good catch thank you! We will fix the installer asap too.

Share this post


Link to post
Share on other sites

Reinstalled Tower3D in to the default folder this is the SP2A, loaded the KJFK into the folder it suggested everything worked fine. I have not loaded Real Traffic. There are 5  JT1 aircraft at start, they all took off at runways 22L and 22R every thing looks fine at the moment apart from the yellow taxiway lines coming down the runway to the next interchange.

Share this post


Link to post
Share on other sites

Yep.  All looks good now.  Looking forward to the Real Traffic update, and to Real Color.  By the way, If you buy Real Color for one airport, will liveries still show in for other airports that share the same airline (the way it did in Tower2011)?

Share this post


Link to post
Share on other sites
12 hours ago, Avwriter said:

Yep.  All looks good now.  Looking forward to the Real Traffic update, and to Real Color.  By the way, If you buy Real Color for one airport, will liveries still show in for other airports that share the same airline (the way it did in Tower2011)?

Yes, they will :)

Share this post


Link to post
Share on other sites

hello,

i have the steam version of tower 3D

Did get the KJF  add on installed in the correct directory.

However KJFK will not load , the loading screan stays at 0%.

Did reinstall tower 3D and then KJFK again, same issue.

Please help.

 

Share this post


Link to post
Share on other sites

I do notice that KJFK loads a little slower than the default airports.  For me, it seems to hang at 0% for about 20-30 seconds, and then loads normally.  If it is really hanging indefinitely, you might try including your operating system and comp specs for the developers to see.   

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.