Jump to content
The simFlight Network Forums
svenks

Small problem with FSUIPC install

Recommended Posts

Hi Peter

I just updated my FSUIPC installation to the latest one, dated nov 8th.

But it didn't appear in the add-ons menu, so I had a look at the installation logs and various other files.

It turns out that the install procedure installs FSUIPC4_Loader.dll in the "Modules\FSUIPC Documents" folder, while dll.xml correctly expects to find it in the modules folder...

Copying it to the modules folder fixed the problem.

Thought you might like to know :)

BRGDS

Sven Sorensen

Share this post


Link to post
Share on other sites
18 minutes ago, svenks said:

It turns out that the install procedure installs FSUIPC4_Loader.dll in the "Modules\FSUIPC Documents" folder, while dll.xml correctly expects to find it in the modules folder...

Copying it to the modules folder fixed the problem.

That's not right at all. FSUIPC's installer never used to install the loader at all, it was in the ZIP only as an option, with warnings against using it.

In general it should NOT be used, but folks were copying the complete ZIP contents into the Modules folder without reading the instructions, so I changed that so it wasn't included in the ZIP but installed as one of the extras in the FSUIPC Documents subfolder, so it could still be found if actually needed. The installation document, which you should have read, explains where things are.

If the DLL.XML file still contained the Loader reference after you ran the installer without the Loader DLL being present in the Modules folder, then something went wrong and the DLL.XML file wasn't properly updated. Check the Install log for errors!

I'd strongly recommend removing the Loader from the Modules folder and re-running the Installer to correct the DLL.XML file. If it doesn't you need to show me the Install log AND the DLL.XML file from the AppData folder.

Pete

 

Share this post


Link to post
Share on other sites

Hi Pete

First of all: I did read the installation document, but I also let the installer do its thing  without trying to outsmart it. In other words> I just ran it.

As you can see from the attached log file, the installation completed successfully (at least I do not see any errors,but maybe you can), but the installer did - quite purposefully it seems - create the DLL.XML entry containing the reference to FSUIPC4_Loader.dll. The xml file does NOT reference FSUIPC4.dll, but only FSUIPC4_Loader.dll. And the timestamp is the same as for the install log file.

FSUIPC4.dll (correct version) is present in the modules folder but as I said, FSUIPC4_Loader was not until I put it there.

I'm attaching the log file and the resulting dll.xml file. I'm also attaching a previous version of dll.xml, a backup created by FSlabs A320 installer. As you can see, the FSUIPC4.dll is indeed referenced there.

I will now edit the dll.xml file to reference FSUIPC4.dll directly. I do think you should have a look at the installer.

BRGDS

Sven

DLL_preA320X.xml

dll.xml

FSUIPC4 Install.log

Share this post


Link to post
Share on other sites
10 minutes ago, svenks said:

As you can see from the attached log file, the installation completed successfully (at least I do not see any errors,but maybe you can), but the installer did - quite purposefully it seems - create the DLL.XML entry containing the reference to FSUIPC4_Loader.dll.

Yes, as shown here, in the log:

Now checking DLL.XML ...
... There is a previous DLL.XML, checking for FSUIPC4 section.
... FSUIPC4 section already exists but will be replaced.
     (with FSUIPC4_Loader entry)
... FSUIPC4 section of DLL.XML written okay

It does this ONLY if it sees that the Loader has been placed into the Modules folder. This is the Modules folder it is using and looking in:

G:\Games\FSXW7\Modules\

12 minutes ago, svenks said:

FSUIPC4.dll (correct version) is present in the modules folder but as I said, FSUIPC4_Loader was not until I put it there.

This is what I don't understand. Might you have two installations of FSX, two Modules folders?

18 minutes ago, svenks said:

I do think you should have a look at the installer.

Well, something unique must be happening on your system, because the Installer is well tested, and virtually unchanged for many releases. It is used by all FSUIPC users, including on 4 varied systems myself. The code in this area simply tests whether the Loader is present in the Modules folder and if so sets up the DLL.XML file to use it.

I'd need to know a lot lot more about your system. I could add more logging to actually show the return Windows gives it when it tests for the presence of the loader, but is this worthwhile?

Pete

 

Share this post


Link to post
Share on other sites

While I do have en old fsx installation on another harddisk, the only modules folder is the one the installer correctly finds beneath fsxw7.

The only thing that is really special is that the fsxw7 folder is located on a SSD which is then mounted under g:\games, which is a HDD.

Anyway, as the problem is solved, let's not worry about it. 

Thanks for your time, Brgds

Sven 

Edited by svenks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.