Jump to content
The simFlight Network Forums
winsaudi

Pro - no pilot voices

Recommended Posts

When you refer to "game.log" do you mean Output_log? I ask this because I installed the Tower on another computer. After running the tower.bat, I could not locate the game.log. Even a search of the computer did not locate a "game.log." If it does exist, in what file does it reside?

Thanks,

Nick

Share this post


Link to post
Share on other sites

The game.log file gets created in the Tower!3D Pro folder when you run the sim using tower3d.bat. Some people don't see a game.log after running the bat file. Personally I've never had this issue. However, I have checked the "Run this program as an administrator" box on tower3d.exe and modified the security on the Tower!3D Pro folder to give myself "Full control" over the folder and all sub-folders..

Share this post


Link to post
Share on other sites

Finally able to create a game.log. Permissions must be set for the entire Tower3d Pro file for all the categories (Creator, Users etc). If you do it individually within the folder the game.log is not generated. Onward and upward. Attached are the game.log and speech.log as you requested.

Thanks,

Nick

game.log

speech.log

Share this post


Link to post
Share on other sites

"Audio device error encountered. - Error Code: 0x2"

 

There is something's wrong with either a sound driver or speech on your computer.

Share this post


Link to post
Share on other sites

I reinstalled Microsoft Speech 5.1. Still no voice. Voice recognition seems to be working. All indications are that the sound drivers are working. I am able to run Tower 2011 without difficulty to speech recognition and pilot voices. Your documentation indicates that there was a major re-write on speech and voice. Where would I look for difficulties in speech synth drivers on my computer?

Thanks again for your continued support.

Nick

Share this post


Link to post
Share on other sites


Looks like you have this problem:
https://social.msdn.microsoft.com/Forums/vstudio/en-US/9075023b-8bc4-4632-a573-77470b403a48/i-get-an-audioexception-0x2

Although it some settings on your system (or a broken install somewhere) we would like to to ask a few things to see if we can help;

First of all can you please tell me what is the exact version of your windows including language settings?

 

Vic

Share this post


Link to post
Share on other sites

I did check the link, but it was not very helpful. All audio devices check fine. Dxdiags displays "no problems found."  I have uninstalled the audio programs and let the computer reinstall them resulting in the same results. There is obviously a problem somewhere, but I am at a loss to find its source.

Nick

Share this post


Link to post
Share on other sites

After some additional troubleshooting with a program called App Crash View. It shows: C:\Windows\System32\Speech\SpeechUX\SpeechUXPS.DLL as a component of Tower 3d pro. It seems it is being used as a speech generation DLL. Do you have any knowledge as to how this generates speech in the program? Could this be the defective program that is causing the speech not to be generated?

Thanks,

Nick

Share this post


Link to post
Share on other sites

I am having this issue now that I found my pro version, however, after reading this post, I will try running it as admin and see if it clears up and allows me to hear pilot voices.  I have not tried voice recognition yet.  I figured, one problem at a time, right?

Share this post


Link to post
Share on other sites

Vic,

No joy, but thanks for the effort. I am toying the the idea of doing a fresh install of 7. That should cure the problem. It is a matter of waiting for the right time so any anomaly does not jeopardize the computer for work.

 

Nick

Share this post


Link to post
Share on other sites

Hi,

I bought Tower!3d Pro today and experiencing the same problems. No pilot sounds. It is the steam version on a Windows 7 64 bit computer running English speech recognition. I run the game as admin and do have other sounds. I also tried reinstalling. Sound and voice works on Tracon!2012 and Tower!2011. I also installed the Microsoft update link from Vic. Can anybody help?

game.log: https://pastebin.com/sPSGF6fv

Share this post


Link to post
Share on other sites

Yes I'm using Win10 now(just did the upgrade today) and I have set the time and language settings to english. The timezone is my location, because I would like to use the correct time ;)

Fun fact: tower3d.bat doesn't work anymore, even reinstalled it(again) and it doesn't help.

Share this post


Link to post
Share on other sites

I see you have steam for Pro, try clicking the pro on steam to bring up preferences -- local files and run the flies again, also have you still got the internet access when running Pro through steam,

Share this post


Link to post
Share on other sites

Yes I have the Steam Pro version. I have a Steam window open, connected to the internet. Then I go to the Tower!3d folder in steamapps/common and right click to run tower3d.exe or tower3d.bat(which doesn't work) as administrator. I checked the local file integrity via Steam, the files were all ok. 

Share this post


Link to post
Share on other sites

Have you done the following you will have to find the folder within steam,A Lot of people are having issues with voice I can only give my views for what its worth.  Most of the time issues with things not working at startup seem to be Admin Rights therefore if you open the directory where FEELTHERE is installed right click to bring up a list with Properties being at the bottom -- Security,   then allow Permissions for all your group and users names by ticking every thing you can,  Do the same for Tower3d Pro Applications found in the Feelthere folder and the same for MNWINDOWS. Applications  You can start Pro from Tower 3d Pro using right click Run as Admin.as well as the Icon on the Desktop.

Share this post


Link to post
Share on other sites

Thanks for your efforts Flightsimpilot. 

All permissions are checked on the Tower!3d Pro folder in the steam folder. I searched my whole pc and there is no FeelThere folder found except the ones used for FS9 and one in AppData with ad.txt in it, the only file. That has all the permissions as well.

Share this post


Link to post
Share on other sites

As follow-up to my last post about no pilot voices in 3d Pro, I made an end-run. On an underused hard drive, I installed Win7 64. After booting to that drive, Tower 3d pro now produces pilot voices. To my dismay, only the generic Microsoft female voice works. That voice is a major irritation to hear.  Am I correct in assuming that the only way to get male voice is to run the program under Windows 10?

Thanks,

Nick

Share this post


Link to post
Share on other sites

Yes you are right ,  Win 10 voices have a collection of both Male and Female. I have been fortunate to have acquired 3 hard drives for which Pro resides on a drive away from Microsoft x64 programs. 

Share this post


Link to post
Share on other sites

I know this is an old thread, but I've been working on this problem for a couple hours now and I finally found a solution that I thought would help people in the future having this same problem. I'm guessing that everyone that has this problem (even when running as administrator) is using headphones for the sound output, as I was. Here's what the problem was and how I fixed it:

 

I had to go into control panel (Windows 10 64-bit) -> Ease of Access -> Speech Recognition -> Advanced speech options -> Text to speech tab. That brought up a menu where you could change the voice selection for text to speech. I tested the speech and no audio was present in my headphones. So I clicked on the audio output button and then selected my headphones in the playback menu, then clicked Configure. I thought my headphones might not be functioning correctly, so I played the test sound...I heard the audio when the left and right channels played, but the center, subwoofer and both rear channels were silent. The audio output was set as 5.1 Surround...which if you have surround sound headphones I imagine that would work, but apparently mine are not. So then it hit me that most spoken audio is sent through the center channel in movies, so I switched the output to stereo and that fixed it right up. Everything sound-related in Tower 3D Pro works perfectly now.

 

I hope that helps someone save a couple of hours of frustration at some point. I really wanted to play this game but I was about ready to ask for a refund...Thankfully I found this and I hope it works for anyone having a similar problem.

Edited by kanekutter05
Edited for clarity

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.