Jump to content
The simFlight Network Forums
Sign in to follow this  
Portanav

Further FSUIPC4 and P3D throttle and stick problems

Recommended Posts

Hi Pete;

I am using two Saitek Pro Rudder Pedals and CH Yokes on Prosim 737 with FSX:SE and your most recent FSUIPC4. Recently my #2 (right side) Yoke, Rudders and Brakes have stopped working. When I check the windows "Game Controller", both Yokes, Rudder Pedal devices are attached, identified and working properly. When I go into FSUIPC to the Device Assignments only the left side works correctly; the right side is not picked up by moving the yoke, rudder or brake pedals.

This has only recently started happening and I can determine why. I don't think it's the USB's because they are all identified and working within the computer system; am I wrong in making this assumption?

Can you help me solve this?

Regards,

Michael.

Share this post


Link to post
Share on other sites
57 minutes ago, Portanav said:

When I go into FSUIPC to the Device Assignments only the left side works correctly; the right side is not picked up by moving the yoke, rudder or brake pedals.

Sorry, what do you mean by the "Left" and "Right" sides? I don't understand. The axis assignments tab only has one place where it shows the values received from the axis,and that's top centre.

Pete

 

Share this post


Link to post
Share on other sites
7 hours ago, Portanav said:

Hi Pete;

I am using two Saitek Pro Rudder Pedals and CH Yokes on Prosim 737 with FSX:SE and your most recent FSUIPC4. Recently my #2 (right side) Yoke, Rudders and Brakes have stopped working. When I check the windows "Game Controller", both Yokes, Rudder Pedal devices are attached, identified and working properly. When I go into FSUIPC to the Device Assignments only the left side works correctly; the right side is not picked up by moving the yoke, rudder or brake pedals.

This has only recently started happening and I can determine why. I don't think it's the USB's because they are all identified and working within the computer system; am I wrong in making this assumption?

Can you help me solve this?

Regards,

Michael.

Hi,

please copy and paste the full content of your FSUIPC4.ini and FSUIPC4.log to your message. Also make sure you used the latest installer for FSUIPC4.966c.

Thomas

Share this post


Link to post
Share on other sites
15 hours ago, Pete Dowson said:

Sorry, what do you mean by the "Left" and "Right" sides? I don't understand. The axis assignments tab only has one place where it shows the values received from the axis,and that's top centre.

Pete

 

Pete, left side means Captain's controls (yoke, rudder & brake pedals); right side means co-pilot's controls. It's the co-pilot's side (controls) that do not work.

Regards,

Share this post


Link to post
Share on other sites
1 hour ago, Portanav said:

left side means Captain's controls (yoke, rudder & brake pedals); right side means co-pilot's controls. It's the co-pilot's side (controls) that do not work.

Ah, sorry. I misread. So you have two sets of identical controls, like me, and simply want to assign both sides to the same controls? And are both sets identical devices? Are they connected differently -- different USB hub perhaps? Or one via a hub the other not?

As well as the INI and LOG files as requested by Thomas:

Could you run my HidScanner utility please and send me the log file it makes? It’d in the “useful additional programs” thread of “Download Links” subforum.
 
Also export the relevant registry parts:
 
HKEY_CURRENT_USER\System\CurrentControlSet\Control\MediaProperties\PrivateProperties
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\MediaProperties\PrivateProperties
 
Do this by running RegEdit from the Windows start menu, going down the Explorer style layers to those and with that layer selected do File-Export give them each a name (it’ll save as a .reg file).
 
Then rename them from .reg to .txt so the mail system or my anti-virus doesn’t reject them (.reg files, when run, change the registry), and send those to me at petedowson@btconnect.com.
 
Just going back to your first post (added rather misleadingly to a thread mainly about X-55's, which seem to be the main source of problem), you said
 
Quote

I am using two Saitek Pro Rudder Pedals and CH Yokes on Prosim 737 with FSX:SE and your most recent FSUIPC4. Recently my #2 (right side) Yoke, Rudders and Brakes have stopped working.

Any reason you are not assigning directly in ProSim? I think that's the more usual way for ProSim users. Does that not see both sets? (I'm a ProSim user, but cannot assign that way because my controls are PFC serial port devices, handled by my own drivers).

Also, can you say what might have changed 'recently' when they stopped responding in FSUIPC?

Thanks

Pete
 

Share this post


Link to post
Share on other sites

Hi Pete;

I seemed to have solved the problem. I decided to strip down the rudder pedals on the co-pilot's side, which was giving the problem. I found one of the wire connectors slack on the brake pot. Securing it properly to the pot has fixed the problem, or so it appears. So all flight control usb devices are functioning correctly now.

If you still want the data requested I have attached for your perusal.

Thanks very much,

Michael.

Current User.reg.txt

FSUIPC4.ini

FSUIPC4.log

HidScanner.log

Local Mach.reg.txt

Share this post


Link to post
Share on other sites

Thanks for the report. I will take a look at the files, out of interest, but since you've solved it i'll consider the matter closed.

Pete

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.