Jump to content
The simFlight Network Forums

FSUIPC Crashes FSX SE changing to full screen???

Recommended Posts

Apologies for the long post but this is very odd [ and using the wrong forum earlier!!].

1.    Run FS9, FSX, P3D for XX years with no problems from FSUIPC
2.    Couple of months ago installed FSX SE side by side with FSX.
3.    Installed lots of add-ons – several UK2000 scenery, GEX, UTX, PMDG,  iFly etc.

Started seeing an odd crash when changing from windowed mode to full screen. After lots of research including reinstalling FSX SE 3 times concluded the following:

1.    Clean install of FSX SE – No add-ons, no dll;.xml, no exe.xml – FSX SE runs correctly with no crashing
2.    Install latest version of FSUIPC [the ONLY add-on] – run FSX SE loading in windowed mode [maximised “0” or “2”]  FSUIPC enabled.  When FSX SE loads at default location,  select full screen mode – FSX SE crashes.

Details are:

Problem Event Name – BEX
Fault Module  -- Unknown
Exception Code – c000005

Now, if I run FSX SE with maximised set to 1 – ie full screen – FSX SE loads ok and I can change back to window and then to full screen as often as I like – no problems.

But – if I select the FSX SE.cfg to start in windowed mode this is entirely reproduceable.

Note.  Tried several different NV drivers and many different settings.

Note – saw in an earlier post that the file wxstationlist.bin might have an effect.

So, if I delete that file, then run FSX SE with FSUIPC enabled – all ok. I can change screen mode with no problems. I then close FSX SE and wxstationlist.bin rebuilds – if I then restart FSX SE in windowed mode  - same crash when I restart FSX SE in window mode and then change to fullscreen.

Very easy work-around.  Always initially load FSX SE in full screen mode.  But this is not the point – what is the difference between FSX and FSX SE that causes this   ………………….

V grateful for any help


John Rooum

Link to comment
Share on other sites

35 minutes ago, jrooum said:

Install latest version of FSUIPC [the ONLY add-on] – run FSX SE loading in windowed mode [maximised “0” or “2”]  FSUIPC enabled.  When FSX SE loads at default location,  select full screen mode – FSX SE crashes.

Well, you don't mention which version of FSUIPC you are using. If it isn't the currently supported version (4.966c) please update.

FSUIPC is totally unaware of the screen mode and is completely uninvolved with graphics altogether, especially if you aren't running any Lua plug-ins (which can use the screen, and in most respects could fall under the category "add-ons").

The only thing the presence of FSUIPC will possibly influence is what is in memory and where it is. A crash like yours indicates a corruption or other error elsewhere which sometimes affects nothing apparent and other times crashes. "BEX" is normally an attempt to execute data (or rubbish) as if it were a part of the program.

Since it occurs with no other add-ons I would suspect the installation of the Sim itself, It it isn't that it might be hardware -- memory or its accessing.

Try an uninstall and reinstall of the Sim first. Also make sure FSUIPC is up to date.



Link to comment
Share on other sites


Many thanks.  First thing I did this pm was to redownload the latest FSUIPC  just to make sure.  Also, this is my third clean reinstall of the FSX SE sim - so my thoughts are to hardware or the OS - but why is FSX boxed ok??

But you have given some other ideas where I might look so I will do some more investigation tomorrow [I have an old i860 pc which originally ran FSX so I might try FSX SE in that as a test bed!!] along with digging into other running services  etc etc

Thanks again




Link to comment
Share on other sites


A short update in case anyone sees this issue in the future - very unlikely.

Your response above put me on the right track.  Whenever i reinstall/rebuild one of my flight simulators I automatically copy a LUA script {ipcReady.lua - displays touchdown VS} into the modules folder - I have done it for years without any problems.

So I removed the script and, of course, FSX SE /  FSUIPC ran perfectly.

Also I had noticed that SE took approx 4 secs more that the boxed version to change from window to fullscreen mode - which suggested that I might have a graphics problem in SE. So I removed the display element from the lua script and, again, SE ran correctly and the LUA script recorded the touchdown VS in the FSUIPC log as expected. Of course I have tried different NV drivers and settings without any effect.

Finally, I looked at the FSX.cfg for SE and compared it with the boxed version.  Eventually found that the answer was to run SE in DX10 preview mode - window/full screen mode changes are normal and the full ipcReady.lua  script runs and displays correctly.

So in all, it looks as though I have some form of graphics conflict in the unique situation on the lua script in FSX SE DX 9 - could be hardware or software but perhaps understandable in view of the age of my system - the 660TI gpu is getting a bit long in the tooth now [like me!!]

John Rooum

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.