Jump to content
The simFlight Network Forums

Problem with FSUIPC recognizing multiple CH Throttle Quadrants simultaneously


Recommended Posts

I am currently having a problem getting FSUIPC4 to simultaneously recognize both the CH Throttle Quadrants (TQs) that I have.  Although this setup worked without a problem for months after I originally got FSUIPC, I have been unable to assign the axes but to one of the TQs.  My setup includes the CH Eclipse Yoke, the CH Pro Pedals, and two CH Throttle Quadrants (to get a total of twelve levers for use with four engine prop aircraft for independent control of the throttles, mixtures, and props).  I am running a Windows Vista 64-bit OS on a Hewlett Packard m9340f Pavilion computer with 6 GB of RAM.  I am using a registered copy of FSUIPC4 (version 4.965) with FSX Acceleration.  I have Active Sky 2016 and am using the CH Control Manager as described by jahman in his "Setting Throttle Reverse, Prop Feather, and Mixture Idle-Cutoff" post with respect to initial setup.  In CH Control Manager, all the CH devices are recognized and function independently as they should.  However, when doing the Axis Assignments in FSUIPC, it appears that only one of the TQs is recognized, and the other is either totally ignored (i.e. no recognition that it is moving when repeatedly hitting "Rescan" or seen as the same TQ as the other (e.g. X axis on the second TQ is seen as the X axis on the other TQ).  Usually, the other TQ is totally unrecognized.  If the recognized TQ is disconnected, the other TQ is recognized as the one disconnected (i.e. it controls the axes formerly controlled by the disconnected TQ).

X-plane 10 has no problem seeing both TQs.  If I disconnect or connect the unrecognized TQ from/to its USB port, the audio outputs are there to indicate that the computer "sees" it.  I have gone so far as to replace the power supply in the computer with a much higher power unit to ensure that there was not a deficiency there.  This yielded no noticeable difference in the results.  I also have run the JoyIDs program in case there was some problem with the TQs being properly identified.  That also yielded no improvement.

As I said, my original setup ran without problems until I had a problem that corrupted the install of FSX such that I could not open the panel windows using the "shift n" on any aircraft whether FSX original or add-on.  This resulted in my completely deleting and reinstalling FSX and FSUIPC along with it.  Prior to that reinstallation, I never had a problem with using both TQs together, even after the corruption.  The original version of FSUIPC4 was 4.949, which I used until the reinstallation of FSX and FSUIPC4.

I have also tried moving the TQs to different USB ports, which one time resulted in a temporary recognition of both TQs.  At that time, I saw that the FSUIPC4.ini file recognized different GUIDs for the TQs.  When it is failing to recognize both independently, the FSUIPC4.ini file, shows the same GUID twice (i.e. the same GUID for each TQ).  I tried to manually assign letters to the each of the items (i.e. the yoke, the pedals, and each TQ).  This was unsuccessful and the fsuipc4.ini file indicated the numbers were also assigned to the each of the items.  When I tried to assign letters, I used GUIDs that I saw when the the TQs were individually recognized.  I clearly don't understand the process to assign letters manually to the controllers. I have also tried many times to go with the numbers that FSUIPC assigns with no success since I had to reinstall FSX.  That was the process I used prior to FSX being corrupted as mentioned previously.  Is there any possibility that FSUIPC4 version 4.949 would be better at recognizing the TQs individually?  As I said, I had no problem when letting it do so prior to FSX being corrupted and reinstalled.

The conclusion I draw so far is that the problem is that FSUIPC seems not to be able to differentiate between the two CH TQs consistently.  I do not claim to understand all the details related to FSUIPC4  assigning GUIDs to the TQs.  So, I would appreciate any insight that may be offered with respect to getting FSUIPC4 to separately recognize the TQs.

I am attaching the log file as well as the FSUIPC4.ini that last occurred.  In addition to those, I am attaching an excerpt from an FSUIPC4.ini file that showed different GUIDs for the two TQs.

Thanks for whatever insight you can provide with respect to ensuring that each TQ is individually recognized.

FSUIPC4.ini

FSUIPC4.log

Throttle Quadrant Identifiers & GUIDs.txt

Link to comment
Share on other sites

I did as you indicated and my individual throttle quadrants were recognized without any problems so far.  At this point, I have completed the assignment of the axes for all the controllers including the throttle quadrants.  I hope to complete calibration of all the axes and reassignment of the buttons tomorrow evening when I have a little more time than I did tonight.

Thank you very much for the prompt reply and the fixes that you have implemented.  So far, I have gotten farther than I have been since before the FSX corruption that started this problem.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.