Jump to content
The simFlight Network Forums

Tower!3D Pro Multiplayer Connection Problems - RESOLVED


Recommended Posts

Doing multiplayer when trying to connect the server is started and waiting for connection is displayed, the client goes to join but after about 10-15 seconds the message "not connected" comes up. Further attempts are unsuccessful.

Pinging the "server" is successful with 62ms response times:
----???.???.???.??? PING Statistics----
92 packets transmitted, 92 packets received, 0% packet loss
round-trip (ms)  min/avg/max/stddev = 62.0/63.10/72.2/1.61

Traceroute gets as far as the ISP in the "servers" city then times out, which is probably expected.

Router is set to forward any IP address on port 21112 to serve



Verified local IP address:
Wireless LAN adapter Wi-Fi 2:

   Connection-specific DNS Suffix
   IPv4 Address. . . . . . . . . . . :
   Subnet Mask . . . . . . . . . . . :
   Default Gateway . . . . . . . . . : fe80::1205:b1ff:fe6b:ca92%9

Probing the port:

Protocol and Application
Unknown Protocol for this port
Unknown Application for this port


Firewall rules are set to:
tower3d        Private    Yes    Allow    No    C:\program files (x86)\feelthere\tower!3d pro\tower3d.exe    Any    Any    UDP    Any    Any    Any    Any    Any    Any    Any    
tower3d        Private    Yes    Allow    No    C:\program files (x86)\feelthere\tower!3d pro\tower3d.exe    Any    Any    TCP    Any    Any    Any    Any    Any    Any    Any    
Tower3DPro    All         Yes    Allow    No    Any                                                                                         Any    Any    UDP    21112    Any    Any    Any    Any    Any    Any
Tower3DPro    All         Yes    Allow    No    Any                                                                                         Any    Any    TCP    21112    Any    Any    Any    Any    Any    Any

In playing multiplayer with Tower!3DPro the only way a connection could be established is if playing on a local network or through a VPN using Hamachi by LogMeIn.

Am I missing something? Between four of us we have not been able to connect to each other.

Since it is late Friday, I'll give you guys a couple hours to hash through the problem :)


P.S. Would the game.log file from the server or client have any information?  
The server game.log file shows:
Platform assembly: C:\Program Files (x86)\FeelThere\Tower!3D Pro\tower3d_Data\Managed\System.Configuration.dll (this message is harmless)
Platform assembly: C:\Program Files (x86)\FeelThere\Tower!3D Pro\tower3d_Data\Managed\System.Xml.dll (this message is harmless)
Runways found: 28
Runways found: 28
Start Server

Simple Port Tester Results

Link to comment
Share on other sites

tcpdump results from probe on port 21112

C:\Users\rick\>WinDump.exe -i \Device\NPF_{B70F1552-E4CB-493D-97BE-E6FD8EEAADD6} port 21112
WinDump.exe: listening on \Device\NPF_{B70F1552-E4CB-493D-97BE-E6FD8EEAADD6}
07:30:09.473831 IP ps417858.dreamhost.com.37557 > PC_9.21112: UDP, length 4
07:30:09.923513 IP ps417858.dreamhost.com.53328 > PC_9.21112: S 4285599512:4285599512(0) win 29200 <mss 1460,nop,nop,sackOK,nop,wscale 7>
07:30:09.923994 IP PC_9.21112 > ps417858.dreamhost.com.53328: S 738672445:738672445(0) ack 4285599513 win 64240 <mss 1460,nop,nop,sackOK>
07:30:09.962060 IP ps417858.dreamhost.com.53328 > PC_9.21112: . ack 1 win 29200
07:30:09.963540 IP ps417858.dreamhost.com.53328 > PC_9.21112: F 1:1(0) ack 1 win 29200
07:30:09.963803 IP PC_9.21112 > ps417858.dreamhost.com.53328: . ack 2 win 64240
07:30:09.975194 IP PC_9.21112 > ps417858.dreamhost.com.53328: F 1:1(0) ack 2 win 64240
07:30:10.009976 IP ps417858.dreamhost.com.53328 > PC_9.21112: . ack 2 win 29200


Link to comment
Share on other sites

Uh-Oh, liar, liar, pants on fire :)  I fingered it out, thanks to tcpdump:

C:\Users\rick\>WinDump.exe -i \Device\NPF_{B70F1552-E4CB-493D-97BE-E6FD8EEAADD6} host rickpc_7
WinDump.exe: listening on \Device\NPF_{B70F1552-E4CB-493D-97BE-E6FD8EEAADD6}
08:12:42.006213 IP rickpc_7.59209 > Laptop.22222: UDP, length 12
08:12:42.023789 IP Laptop.22222 > rickpc_7.59209: UDP, length 12
08:12:42.047751 IP rickpc_7.59209 > Laptop.22222: UDP, length 12
08:12:42.089900 IP rickpc_7.59209 > Laptop.22222: UDP, length 12
08:12:42.132966 IP Laptop.22222 > rickpc_7.59209: UDP, length 41
08:12:42.140406 IP rickpc_7.59209 > Laptop.22222: UDP, length 12
08:12:42.150846 IP rickpc_7.59209 > Laptop.22222: UDP, length 50
08:12:42.171276 IP Laptop.22222 > rickpc_7.59209: UDP, length 12
08:12:42.181472 IP Laptop.22222 > rickpc_7.59209: UDP, length 133
08:12:42.190434 IP rickpc_7.59209 > Laptop.22222: UDP, length 12
08:12:42.211393 IP Laptop.22222 > rickpc_7.59209: UDP, length 12
08:12:42.230549 IP rickpc_7.59209 > Laptop.22222: UDP, length 12
08:12:42.230670 IP Laptop.22222 > rickpc_7.59209: UDP, length 37

Of course this was on a local network, waiting for someone to get online to test the WAN.


Link to comment
Share on other sites

Vic, I'm going to steal Ricky's thunder but we have found the issue with Pro multiplayer. It is using port 22222 instead of 21112. We'd appreciate an emergency fix or a fix as soon as possible to correct the issue.

We were never able to connect using port 21112, but when we changed the rule to 22222 we then were able to connect. But as discussed in the following thread, http://forum.simflight.com/topic/82796-tower3d-pro-multiplayer-port-assignment/ port 22222 is not a good port to use. The thread mentions it was fixed, but looks like it needs to be fixed again.

Thanks, Craig  

PS - The online manual still references 22222 in one section and 21112 in another.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.